Brother printer over WiFI - most programs can't print "filter failed"

Hi everyone,

I have a Brother MFC-J625DW printer that I connect to over WiFI. It normally works perfectly on Ubuntu and Arch with the manufacturer’s Linux drivers. But for the life of me I can’t get it to work either on Leap 42.1 or on Tumbleweed. It used to work on openSUSE 13.2.

Stranger still, I can print a test page from the yast2-printers, and I can also print from Wine apps (notepad), but I can’t print a test page from system-config-printers and I also can’t print front LibreOffice or gedit or any other normal program. The details in the print queue for the failed job say “filter failed”.

Here’s a fresh cups error_log (only contains this single operation) after a successful print from Notepad in Wine:

And here’s another clean error_log after a failed attempt to print from gedit:

Thanks for any help you can offer.

Solved it! Turns out that poppler-tools needs to be installed.

And for an openSUSE Leap 42.1 custom installation, I have again been pulling out my hair to get this same Brother MFC-J625DW printer to work. This time, CUPS was giving me absolutely no errors in the error_log. It seemed to think it was successful, but the printer did nothing. I finally found an old, out of date Brother printer driver page that reminds that the drivers are 32-bit, and so on a 64-bit system the 32-bit compatibility libs are necessary. That’s what I was missing. Installing libstdc++6-32bit with its dependencies fixed it.