Brother P-Touch 2430PC

Dear all,

any ideas how to get the label printer Brother P-Touch 2430PC to work.
The printer is detected by YAST, but there is no driver?

best regards

se if any of this helps

OpenPrinting database - Printer: Brother PT-2420PC

Yes I did,
and I installed the drivers (this arte foomatic XML files) , but the printer-driver is not in YAST or CUPS. The Hardware is well recognized, but how to have the driver in the YAST or CUPS - database ?

can you tell us what you did in cups please

Steps in CUPS

Add Printer
specify name : P-Touch_2430 → continue
Choose from list: Brother PT-2430PC (USB#1) (Brother PT-2430PC)
Now a box with Printers from brother appears but not with the p-touch, instead I could choose a ppd-file, which I don’t have.

Cancel operation in CUPS

Steps in YAST

Hardware → Printer → Add → Choosed connection and printer in the top box. but “Assign Driver” is nothing appropriate

Is this helpfull ?

we use gnome; it has a search function in the Systems folder;

if you look in your whole filesystem;

for *.ppd and see if there are any brother ppds if you installed ptouch

and here is some research for you;

found, but only PT-9500 available. This driver don’t work with PT 2430PC.


no related ppds are found.

I tried the earlier link from

CUPS/Foomatic driver for Brother P-touch label printers

./configure shows:

checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… /bin/mkdir -p
checking for gawk… gawk
checking whether make sets $(MAKE)… yes
checking for gcc… gcc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ISO C89… none needed
checking for style of include used by make… GNU
checking dependency style of gcc… gcc3
checking for a BSD-compatible install… /usr/bin/install -c
checking for cupsParseOptions in -lcups… yes
checking for cupsRasterReadHeader in -lcupsimage… yes
checking for lrint in -lm… yes
checking how to run the C preprocessor… gcc -E
checking for grep that handles long lines and -e… /usr/bin/grep
checking for egrep… /usr/bin/grep -E
checking for ANSI C header files… yes
checking for sys/types.h… yes
checking for sys/stat.h… yes
checking for stdlib.h… yes
checking for string.h… yes
checking for memory.h… yes
checking for strings.h… yes
checking for inttypes.h… yes
checking for stdint.h… yes
checking for unistd.h… yes
checking cups/cups.h usability… yes
checking cups/cups.h presence… yes
checking for cups/cups.h… yes
checking cups/raster.h usability… yes
checking cups/raster.h presence… yes
checking for cups/raster.h… yes
checking fcntl.h usability… yes
checking fcntl.h presence… yes
checking for fcntl.h… yes
checking for stdlib.h… (cached) yes
checking for string.h… (cached) yes
checking for unistd.h… (cached) yes
checking for an ANSI C-conforming const… yes
checking for stdbool.h that conforms to C99… yes
checking for _Bool… yes
checking for inline… inline
checking for stdlib.h… (cached) yes
checking for GNU libc compatible malloc… yes
checking return type of signal handlers… void
checking for memset… yes
checking for strcasecmp… yes
checking for strstr… yes
checking for strtol… yes
configure: creating ./config.status
config.status: creating Makefile
config.status: WARNING: seems to ignore the --datarootdir setting
config.status: creating ptouch-driver.spec
config.status: creating ptouch-driver-foomatic.spec
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands


make all-am
make[1]: Entering directory /home/software/p-touch/ptouch-driver-1.3' make[1]: Leaving directory /home/software/p-touch/ptouch-driver-1.3’

make install

make[1]: Entering directory /home/software/p-touch/ptouch-driver-1.3' test -z "/usr/local/lib/cups/filter" || /bin/mkdir -p "/usr/local/lib/cups/filter" /usr/bin/install -c 'rastertoptch' '/usr/local/lib/cups/filter/rastertoptch' test -z "/usr/local/share/foomatic/db/source" || /bin/mkdir -p "/usr/local/share/foomatic/db/source" /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'driver/ptouch.xml' '/usr/local/share/foomatic/db/source/driver/ptouch.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-QL-500.xml' '/usr/local/share/foomatic/db/source/printer/Brother-QL-500.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-QL-550.xml' '/usr/local/share/foomatic/db/source/printer/Brother-QL-550.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-QL-650TD.xml' '/usr/local/share/foomatic/db/source/printer/Brother-QL-650TD.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-PC.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-PC.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-18R.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-18R.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-1500PC.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-1500PC.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-1950VP.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-1950VP.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-1950.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-1950.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-1960.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-1960.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-2300.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-2300.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-2420PC.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-2420PC.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-2450DX.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-2450DX.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-2500PC.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-2500PC.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-2600.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-2600.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-2610.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-2610.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-3600.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-3600.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-550A.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-550A.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-9200DX.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-9200DX.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-9200PC.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-9200PC.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-9400.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-9400.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-9500PC.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-9500PC.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'printer/Brother-PT-9600.xml' '/usr/local/share/foomatic/db/source/printer/Brother-PT-9600.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-AdvanceDistance.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-AdvanceDistance.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-AdvanceMedia.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-AdvanceMedia.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-Align.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-Align.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-BytesPerLine.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-BytesPerLine.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-ConcatPages.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-ConcatPages.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-CutMark.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-CutMark.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-CutMedia.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-CutMedia.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-HalfCut.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-HalfCut.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-SoftwareMirror.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-SoftwareMirror.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-LabelPreamble.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-LabelPreamble.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-MirrorPrint.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-MirrorPrint.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-NegativePrint.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-NegativePrint.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-PageSize.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-PageSize.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-PixelTransfer.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-PixelTransfer.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-PrintDensity.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-PrintDensity.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-PrintQuality.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-PrintQuality.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-Resolution.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-Resolution.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-RollFedMedia.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-RollFedMedia.xml' /bin/sh /home/software/p-touch/ptouch-driver-1.3/install-sh -c -m 644 'opt/Brother-Ptouch-TransferMode.xml' '/usr/local/share/foomatic/db/source/opt/Brother-Ptouch-TransferMode.xml' make[1]: Leaving directory /home/software/p-touch/ptouch-driver-1.3’

As you can see, there is a “Brother-PT-2420PC.xml” installed. This is a similar printer.
How to get a ppd from this *.xml files?


  1. are you running a 64bit OpenSuse system?

How to get a ppd from this *.xml files?

don’t know; but doubt that an install would halt things there;

and not give you .ppd

can you look in /usr/share/cups/model and see if any ppd files there …

… you seem computer-savvy; you have used linux before?

either a gui to look in the above, or in a terminal:

cd /usr/share/cups/model

and then


I see that this guy

Arne John Glenstrup’s Home Page

maintains the site you got the drivers from;

you might consider emailing him directly; you can bring your acquired wisdom then back to the forum and tell us all

  1. another thought:

why don’t you look in


and see what is there

1.) yes I run a 64 bit system
2.) - in /usr/share/cups/model are no appropriate ppd’s
- I try to get in contact with Arne
3.) -in the xml file are only information about the printer, which I guess are suitable to create a ppd

regards herby2


well, we will let you do some research and let us know how you get along; you are in a pretty special area there; if you google search on your topic, with linux in the search line, there is nothing really there; just your commendable efforts to seek help

**( - A Linux labeling program for Brother P-touch seriesAfter getting totally fed up with my hand-held Dymo, I bought their competitor’s PC-only model hoping someone would have made a proper Linux-drivers for it. That wasn’t the case, but the device uses the same protocol as Brother’s QL sticker printers, so I managed to get it partitially working with the QL-series CUPS driver. The CUPS driver however doesn’t seem to understand non-stop roll fed media, so using the printer with fixed sized pages wasn’t practical.

I had almost forgotten about the device, when I found a post about a C program that printed images with the device. I mailed the author and got the program. I was actually amazed how simple the printer’s imaging language was. In few hours, I came up with a simple GTK2-perl script that had two fields for inputting text, which it then rendered with GD.

As time went by, I started tweaking the program, made a more or less practical GUI with Glade, switched from GD to Pango for font rendering and added some features I saw in screenshots of the Brother’s included software. This program is far from finished, but it already does what I need it to do. I hope you find it useful as well.