Brother MFC-J6920DW all in one printer and openSuse

Hi all,

untill recently I had a Canon MP 510 Pixma all in one printer that worked fine with openSuse. I have used this all in one for years, but the printer has died on me (beyond repairs unfortunately).

I just started looking for a good replacement and heard that Brother has good support for Linux. Now I have found a good replacement (good scanning and printing performance, optional fax, printing via network (cable and wifi))in a **Brother **MFC-J6920DW.

Now I want to know if there are any people that (have) use(d) this all in one with good results on Linux (preferred openSuse).

Thanks for ideas, opinions in advance,

Vincent van den Bergh

(please note that English is not my first language so that there may be some errors in the writing)

I use brother all-in-one printer (MFC-5890CN) I am using this for 5 years now and openSUSE never failed.
Scanner and printer works flawlessly.

You have to download the linux driver from brother solutions.

One thing I noticed, your model seems to not have a driver available.
Are you sure your model is MFC-J6920DW? The driver available in their site is for

Here is the link so you can verify:


I have a Brother MFC-7360N (networked, Ethernet only) and I’m satisfied with the function and drivers for oS13.1/13.2. I haven’t tried the fax function for the PC at all.

Anyway drivers seems to be here for **Brother **MFC-J6920DW :

Good luck!


I am certain of it. I veriefied the model number both on the site of the web shop as well as on the site of Brother.
I already found the driver for it at .

The fax function is not that important for me, it is a bonus. The main concern was inferior printing or scanning quality due to driver issues.

Anyway I ordered the all-in-one at the shop.

I have a Brother MFC-L2700DW and I am wanting to know if I can get this working on the Open Suse. I tried to install this with another linux variation but did not have much success.

I am running 64 bit and the downloads all appear to be 32 is there a way to get around this?

32 bit generally will run ok on a 64 bit system