Brother HL2030 printer


I installed the lpr and cupswrapper drivers for the HL2030, and then I attempted to configure it through YaST and also KDE. Despite my efforts, the printer won’t print!

Can anyone, here, please tell me how to do it right? Thanks!

Hi. You can use the driver called “Brother HL-2060 Foomatic/hl1250 (recommended)”, then you don’t need to download any drivers from Brother. My flatmate’s HL-2030 printer was autoconfigured with the HL-2060 driver on ubuntu and it works.
I’ve got an older HL-1430 where drivers exist for. But for both of us, me and my flatmate, the quality of the printed output has always been better on windows with Brother drivers than on linux with the free drivers.
So, I’d encourage you to try with the above mentioned driver and if you’re not satisfied with the results you’ll surely find helpful advice on howto setup the proprietary ones in the forums here.

Thanks, but the 2060 driver doesn’t work either. It all worked on first try in Windows though, so it doesn’t seem to be the printer’s fault.

Is there a special way that drivers need to be installed?

I had to use the cups webinterface (localhost:631) to setup my printer because Yast didn’t work at all. Maybe that helps. As I never tried the drivers from Brother I can’t help you any further. Good luck!

Thanks. I just checked out the web interface. Unfortunately it’s too cryptic for my feeble mind, and the help files seem to be nonexistent. I guess printing is still a work-in-progress for Linux :expressionless:

Ok, trying again. The command lpstat -p -d ENTER indicates that the printer is now printing. But it also says that the printer is not connected.

However, it IS connected. The web interface produces the same result. :frowning:

Deleted printer. Trying again from the cups admin web console. I don’t know if the entries are right, but it looks like this:

Name: BrotherHL2030
Device: Internet Printing Protocol (ipp) ???
Device URI: usb:/dev/usb/lp0 ???

Any suggestions for what to use as a ppd file?

In the cups webinterface click “add printer”. Then give the printer a name and if you want location and description. Then continue. If you have a USB printer connected to your computer you can select it in the device dropdown-menu. In the next step select your printer manufacturer and then the driver. It’s “Brother HL-2060 Foomatic/hl1250 (recommended)”. You don’t need to use an extra ppd file. Enter your root password to finish installation.

Thanks again supertimorplusfort. I added it like you indicated, but no luck. Please note that I selected ipp and entered a path as per above; otherwise it wouldn’t have let me proceed to the next screen. I also enabled services for cups, and ipp client and server in the firewall.

I also tried the lpd/lpr option when creating the profile. No luck there either. In both cases, it reports that the job is being sent to the printer. But, in both cases, nothing further happens. I’m using either KWrite or Writer to print. Any suggestions?

I should probably also add, that lpstat -p -d ENTER produces the following:

printer BrotherHL2030 now printing BrotherHL2030-33. enabled since Wed 07 Jan 2009 08:08:46 PM CET
Printer not connected; will retry in 30 seconds…
no system default destination

However, the printer is displayed in the hardware settings. Again, I’d appreciate any suggestions!

Yeah, this really sucks :\ It looks like everything is configured correctly, but it still doesn’t work.

Description: BrotherHL2030
Printer Driver: Brother HL-2060 Foomatic/hl1250 (recommended)
Printer State: processing, accepting jobs, published.
Device URI: usb:/dev/usb/lp0