Brother CUPS driver MFC-210C not installable

The CUPS driver MFC210C-1.0.0-1 rpm package will not be installed on openSuse 11.0 (Worked 100% on 10.3)

It is complaining on a not existing requirement

but tcsh are installed and csh works

Could any one guide my?

— cut (yast)—

rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

— end cut —
— cut (install) —
nothing provides csh needed by cupswrapperMFC210C-1.0.0-1.i386
— end cut —

Stupid question, but is it in /bin/csh? you say ‘working’ imho that means that it is found somewhere in your PATH when called by you, but not nesessecary in /bin.

The csh exists as an soft link in /usr/bin (soft link pointing to tcsh).
The csh is found in the path to both my normal user and root.

Sorry, I responded whit an incorrect answer. Lot in my mind :wink:

What I was trying to say
– cut —
/bin> pwd
/bin> ls -l *csh
lrwxrwxrwx 1 root root 4 21 jun 13.29 csh → tcsh
-rwxr-xr-x 1 root root 334380 6 jun 21.48 tcsh
— end cut —

Thanks, correct, that was missing in your ‘prove of existence’.

But now I am convinced that csh exist where it belongs to. Why can’t it be found by the cupswrapper? Will think it over, but hope someone else will have a bright idea.

Sorry but I do not believe that it’s the cupswrapper thats do not find the csh. I do not know the mechanism behind the check of requirements when installing from a RPM package. I thought that the requirements was stated in the package and that YAST checked the requirements prior to the installation step. As I know that csh exists could I find a way to force YAST to install ignoring the missing requirement?

I never called zypper directly, but **man zypper **may give you a clue.

else download the RPM as a file and use rpm directly. rpm certainly has options for ignoring such dependencies (man rpm.

This was the solution! Thank you. In my pressent new 11.0 environment there exists only one user. For some reason that I do not know the installation tried to tuch a file own by that user in spite that the installation was made by root. In any case. The installation ended with a success and now I can print
— cut —
:/home2/install # rpm -i --nodeps cupswrapperMFC210C-1.0.0-1.i386.rpm
error: failed to stat /home/matgra/.gvfs: Permission denied
rm -f /usr/lib/cups/filter/brlpdwrapperMFC210C
Shutting down cupsd done
Starting cupsd done
:/home2/install # whoami
:/home2/install #
— end cut —