Broken X after Update with NVIDIA

I generally hate to upgrade my Linux.
There is almost a problem every time. I don’t do a update too often.
I feel lucky if an update works and my system is usable after.

Now the problem I have is screen resolution has been set extremely low.
Screen resolution is stuck at 640x480 (4:3), and I cannot change it.

I am running with the NVIDIA G05 drivers 460.73.01-lp152.39.1

It seems the nvidia driver is not loaded.

I reinstalled all the NVIDIA packages, including the kernel module.
But that did not work.

I am not running any other graphic card.

None of these suggestions helped me
https://en.opensuse.org/SDB:NVIDIA_troubleshooting#nvidia-settings_ERROR:_Unable_to_load_info_from_any_available_system

I even managed to get it worse. Now it will not boot into X, just leaves me at the login prompt.

I uninstalled everything NVIDIA, then rebooted. Still X, SDDM and KDE will not start up.
I installed NVIDIA back. No change. Still no X.

When I reinstalled the NVIDIA kernel module I noticed some errors, but was unable to record them.

Not sure what to do now.
Suggestions?

1 Like

From the output from NVIDIA KMP Package installation, I deleted some old kernel directories under
/lib/modules. Just keeping my current installed kernel (which now is the only kernel installed)

Force install of the NVIDIA kmp seemed to have less errors now, but still some

rm: cannot remove ‘/lib/modules/5.3.18-lp152.72-default/updates/nvidia*.ko’: no such file or directory
depmod: WARNING could not open modules.order at /lib/modules/5.3.18-lp152.19-default: No such file or directory
depmod: WARNING could not open modules.builtin at /lib/modules/5.3.18-lp152.19-default: No such file or directory
EI variables are not supported on this system

There is no 5.3.18-lp152.19 kernel instaled

A new reboot… X still doesn’t start up.

The problems are compounding.
After I uninstalled NVIDIA, rebooted, now Network does not work either.
I have no Internet, and cannot reinstall nvidia now.

Times like these I hate Linux.

Seems I have no other choice but to reinstall OpenSUSE.

1 Like

Hi
What if you boot with the nomodeset grub option temporarily? Since the drivers are not rebuilt for the current kernel, run dracut -f and see if it rebuilds properly.

How do I do that?

At the Grub boot loader.
Selectinh Advanded options
Linux-5.3.18-lp152.72-preempt
Linux-5.3.18-lp152.72-default

Edit the default, I get a text area.
adding a line with “nomodeset” gets me no such command found.

Found some help how, from Ubuntu of all things
https://www.udoo.org/docs-bolt/Operating_Systems/Linux/Known_issues.html

Hi
If you press e to edit, then arrow to at the line begining linux or linuxefi (if UEFI boot) and press end key and place the nomodeset after quiet and press F10 to boot.

Sure the issue is running preempt instead of default?

Hi
Here I see;


zypper se -si kernel

S  | Name                  | Type    | Version              | Arch   | Repository
---+-----------------------+---------+----------------------+--------+-----------------------
i+ | kernel-default        | package | 5.3.18-lp152.72.1    | x86_64 | Main Update Repository
i+ | kernel-default-devel  | package | 5.3.18-lp152.72.1    | x86_64 | Main Update Repository
i+ | kernel-devel          | package | 5.3.18-lp152.72.1    | noarch | Main Update Repository
i+ | kernel-firmware       | package | 20200107-lp152.2.6.1 | noarch | Main Update Repository
i  | kernel-macros         | package | 5.3.18-lp152.72.1    | noarch | Main Update Repository
i  | purge-kernels-service | package | 0-lp152.4.1          | noarch | Main Repository

uname -a
Linux oscar 5.3.18-lp152.72-default #1 SMP Wed Apr 14 10:13:15 UTC 2021 (013936d) x86_64 x86_64 x86_64 GNU/Linux

inxi -Gxx
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:0152 
           Device-2: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nvidia v: 465.24.02 bus-ID: 01:00.0 
           chip-ID: 10de:128b 
           Device-3: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nvidia v: 465.24.02 bus-ID: 03:00.0 
           chip-ID: 10de:128b 
           Display: server: X.org 1.20.3 compositor: gnome-shell driver: loaded: modesetting,nvidia unloaded: fbdev,vesa 

What is it with the preempt kernel? Seems it is the one being used, not the default.

With preempt I cannot get Internet with wicked network service.
I have to reboot with default to get Internet.

I reinstalled the NVIDIA drivers with he NVIDIA kmp-default.
It still complains during install that it needs the 5.3.18-lp152.19 Linux kernel, not the 5.3.18-lp152.72 I have installed.

grep: /etc/sysconfig/kernel: No such file or directory
depmod: ERROR: fstatat(5, e1000e.ko): No such file or directory
dracut: dracut module 'biosdevname' will not be installed, because command 'biosdevname' could not be found!
dracut: installkernel failed in module kernel-modules-extra
Generating /boot/initrd-5.3.18-lp152.72-preempt targets failed

Then rebooted with nomodeset.

My X, and KDE now comes up, and the resolutions is fine.

running dracut -f now outputs a lot more than it did before.

Hi
Can you install inxi and show that output? I would remove the preempt kernels… that will get rid of the benign preempt errors, so only running default kernels.

You should be able to not add the nomodeset and boot…

Output from inxi

CPU: 6-Core Intel Core i7-6850K (-MT MCP-) speed/min/max: 2734/1200/4000 MHz Kernel: 5.3.18-lp152.72-default x86_64 Up: 1h 18m
Mem: 5324.3/32027.6 MiB (16.6%) Storage: 1.38 TiB (73.6% used) Procs: 338 Shell: bash 4.4.23 inxi: 3.1.00

Hi
As per my example :wink:


inxi -Fxx

System: Host: mintaka Kernel: 5.3.18-lp152.72-default x86_64 bits: 64 compiler: gcc v: 7.5.0 Desktop: KDE Plasma 5.21.5
tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: openSUSE Leap 15.2
Machine: Type: Desktop Mobo: ASRock model: X99X Killer/3.1 serial: N/A UEFI [Legacy]: American Megatrends v: P3.20
date: 08/03/2016
Battery: Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K360 serial: 4004-48-ed-0a-45
charge: 100% (should be ignored) status: Discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master serial: 4060-ee-95-13-54
charge: 55% (should be ignored) status: Discharging
CPU: Topology: 6-Core model: Intel Core i7-6850K bits: 64 type: MT MCP arch: Broadwell rev: 1 L1 cache: 384 KiB
L2 cache: 15.0 MiB L3 cache: 15.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 86374
Speed: 3595 MHz min/max: 1200/4000 MHz Core speeds (MHz): 1: 3595 2: 3576 3: 3597 4: 3698 5: 3599 6: 3180 7: 3599
8: 3776 9: 3595 10: 3165 11: 3595 12: 3156
Graphics: Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: eVga.com. driver: nvidia v: 460.73.01 bus ID: 02:00.0
chip ID: 10de:1b80
Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: nvidia resolution: 2560x1440~60Hz s-dpi: 108
OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 direct render: Yes
Audio: Device-1: Intel C610/X99 series HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:1b.0
chip ID: 8086:8d20
Device-2: NVIDIA GP104 High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 02:00.1
chip ID: 10de:10f0
Sound Server: ALSA v: k5.3.18-lp152.72-default
Network: Device-1: Intel Ethernet I218-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f020 bus ID: 00:19.0
chip ID: 8086:15a1
IF: eth1 state: up speed: 1000 Mbps duplex: full mac: d0:50:99:9e:b6:b4
Device-2: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: ASRock driver: alx v: kernel port: c000
bus ID: 04:00.0 chip ID: 1969:e091
IF: eth0 state: down mac: d0:50:99:9e:b6:b2
Drives: Local Storage: total: 1.38 TiB used: 1.01 TiB (73.6%)
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 950 PRO 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4
serial: S2GMNX0H405060V temp: 50 C
ID-2: /dev/sda vendor: Crucial model: CT1000MX500SSD1 size: 931.51 GiB speed: 6.0 Gb/s serial: 1817E1396309
Partition: ID-1: / size: 98.30 GiB used: 41.10 GiB (41.8%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: /boot size: 1.94 GiB used: 91.5 MiB (4.6%) fs: ext4 dev: /dev/nvme0n1p1
ID-3: /home size: 368.93 GiB used: 150.38 GiB (40.8%) fs: ext4 dev: /dev/nvme0n1p3
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 37.0 C mobo: 41.0 C gpu: nvidia temp: 55 C
Fan Speeds (RPM): cpu: 859 psu: 0 case-1: 0 case-2: 0 case-3: 0 gpu: nvidia fan: 64%
Voltages: 12v: N/A 5v: N/A 3.3v: 3.34 vbat: 3.36
Info: Processes: 338 Uptime: 2h 56m Memory: 31.28 GiB used: 5.27 GiB (16.9%) Init: systemd v: 234 runlevel: 5
target: graphical.target Compilers: gcc: 7.5.0 alt: 7 clang: 9.0.1 Shell: bash v: 4.4.23 running in: konsole
inxi: 3.1.00

Hi
All looks good now…


**Graphics:  Device-1:** NVIDIA GP104 [GeForce GTX 1080] **vendor:** eVga.com. **driver:** nvidia **v:** 460.73.01 **bus ID:** 02:00.0  
           **chip ID:** 10de:1b80  
           **Display:** x11 **server:** X.Org 1.20.3 **compositor:** kwin_x11 **driver:** nvidia **resolution:** 2560x1440~60Hz **s-dpi:** 108  
           **OpenGL:****renderer:** GeForce GTX 1080/PCIe/SSE2 **v:** 4.6.0 NVIDIA 460.73.01 **direct render:** Yes  

Yes thankfully. I did not want to reinstall.
Seems when I get this problem is when both Kernel and NVIDIA have updates.
Deleting the old kernels that is laying around is something I have done before.
This time I had to use the default kernel. Not sure why the preempt kernel was installed, but I am going to uninstall it.

I deleted one of the update repos.
Now, “zypper se -si kernel” only shows one default kernel not two.

Guess there weren’t two kernels installed. Guess there was no potential problem after all.

thanks for help.

tom kosvic

https://bugzilla.opensuse.org/show_bug.cgi?id=1185113

OS wants to install preempt kernels because of Nvidia installer wants to compile drivers.
Solution is not ready yet. Brute-force method: https://bugzilla.opensuse.org/show_bug.cgi?id=1185113#c5

This post shows how to remove the kernel-preempt from updating…

https://forums.opensuse.org/showthread.php/549337-Is-it-normal-that-my-running-kernel-is-kernel-preempt-instead-of-kernel-default?p=3023676#post3023676

However, if there’s an update to kernel-sym, then you need to untaboo kernel-preempt-devel temporarily.

@DJViking did you ever fix your issue ? I’m having issues with the latest Tumbleweed on a fresh install with the Nvidia GTX 1070 Ti.

The computer is 5 years old but it ran TW for many years without issue, and things started going wrong with the nvidia driver maybe 6-10 months ago, so I stopped updating it. I assumed that a fresh install would make things smooth again, but not at all: I’m having lots of issues with nvidia keys not being trusted by the kernel and mokutil saying that it can’t do anything. It’s extremely frustrating.

It is best to start a new topic for your issue, rather than tacking on to on old topic like this.

1 Like