Broken Update to XBMC?

Today I installed the updated 12.1-1.11 64-bit version from Packman to my 12.3 box and now the video just shows as vertical green lines. The audio plays for a short while, then the program locks up. To complicate the troubleshooting process, I also just upgraded to Nvidia’s 319.17 driver from the repository for my GTX 660 Ti.

I tested with a video I know played yesterday, which also currently plays in Kaffeine and VLC. I’ve also tried a couple different plugins (i.e. Ted Talks and Youtube), but with the same fatal results.

Any help would be appreciated, even if it’s just to reconfirm “wait for the next update.”

Please let me know if I’ve left out any vital info. Thanks in advance.

I am not an XBMC user, thus my remark might be dumb.
But in general, I do not understand why you (apparently) use packages from a Packman 12.1 repo on your 12.3 system. For every package I know of, I would think this being a big NoNo.

I Think this is Known:

I Think this is Known:

Thanks for the info, it really helps.

I’m using the 12.3 repos for Packman–12.1 is XBMC’s version number. I can understand the confusion, however.

Yes, a real coincedence.

I can confirm that using openSUSE 12.3, kernel 3.9.1 and with nVIDIA driver 319.17 that xbmc version 12.1 locks up on video playback as a normal user. If you start XBMC as root, it plays videos just fine. That means there is a permissions problem with xbmc loaded as normal, but I am not sure whos fult the problem would be submitted to, but I think its an xbmc problem.

Thank You,

This XMBC thread shows how to increase the log level to report useful debug output that may assist assist with diagnosing the problem.

The bug has been tracked down to SA_NOCLDWAIT in main.cpp.

From #14318 (XBMC fails with Nvidia driver 319.17) – XBMC](

I have tracked it down to SA_NOCLDWAIT in main.cpp. Commenting out those lines make it work. Looks like the driver wants to wait for a child which is reaped before it was able to call waitpid."

Runs fine now with Nvidia’s beta 325.08 drivers. Tested with XBMC 12.2-3.7

Good to know. Thanks for the update. :slight_smile:

The nVIDIA proprietary video driver version 325.08 shows to be beta. I do wonder if it might also work with kernel 3.10, but I have not tried that myself so far.

Download: Read Me:

It says support for kernel 2.4 is removed and you must have 2.6.9 or higher, but that is all I see for kernels unless working with 2.4 was keeping it from working with 3.10.

More on installing the nVIDIA driver the hard way (which is not hard): Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

Thank You,