Broken HiPDI support of some applications after last update on Plasma 5

I have laptop Lenovo Y-50-70 with 240 DPI screen and Tumbleweed with Plasma 5 on it.

My display scale factor is set to 2, and before last update (24.01.2018, it brings ± 200 updates) all worked fine.
But after update my Firefox and Thunderbird have been ignoring scale factor and other Plasma settings such force font’s DPI, and have too small interface and fonts.
There was no updates of Firefox and Thunderbird itself.

I have only standard tumbleweed repositories + packman.

You should probably file a bug report at about this.

Firefox and Thunderbird are GTK3 applications, maybe the scale factor or DPI isn’t set properly for GTK3 anymore.

Btw, is this on X11 or Wayland?

PS: It might be caused by this change:

But that should actually fix the problem that the scaling did not affect GTK3 application (

What are those variables set to on your system? (inside Plasma)


This has long been my goto page for HiDPI settings:

On my laptop I have
layout.css.devPixelsPerPx set to 2
in the Firefox about:config page.

These variables are not set in my system because this section on startkde is not executed:

if  "$kdeglobals_kscreen_screenscalefactors" ]; then
    export QT_SCREEN_SCALE_FACTORS="$kdeglobals_kscreen_screenscalefactors"
    export GDK_SCALE=$kdeglobals_kscreen_scalefactor
    export GDK_DPI_SCALE=`awk "BEGIN {print 1/$kdeglobals_kscreen_scalefactor}"`

Additionaly I have


set to 0

But it should be executed if you changed the scaling settings.

Does it help if you run Firefox e.g. like this?


Have you tried to explicitly change the scaling since the update?

Additionaly I have


set to 0

That shouldn’t affect GTK though.

I changed gtk variables in startkde and run Firefox like you reccomended, but it has no effect.

You should not change anything in startkde. And that of course won’t have any effect if it is not executed.
But again, it should be executed (and the variables set) if you changed the scaling settings.
What does your ~/.config/startupconfig file contain?

Well, I can’t try with Firefox (because I’m on 42.3 with a GTK2 based Firefox), but those GDK_* variables do work with other GTK3 applications like gedit here.
You do use the standard Firefox 57 from the standard repos?

In startkde i changed it to force set variables. But even without it running firefox as GDK_*=… firefox has no effect. Firefox is from standard repos, 57.0.7.

From the HiDPI wiki that I referred to earlier (Applications>Browsers>Firefox):

Firefox should use the #GDK 3 (GTK+ 3)]( settings. However, the suggested GDK_SCALE suggestion doesn’t consistently scale the entirety of Firefox, …

I originally set the Firefox “layout.css.devPixelsPerPx” in Leap-42.1 and it has survived migrations through 42.2 to Tumbleweed (Plasma5 and Openbox-KDE) without any trouble.

Had the about the same problem as TS since 2 days.

This worked for me, thanks

Just found which is about a similar problem.

The mentioned change (setting the GDK* variables in startkde) will be reverted for 5.12 final, let’s hope that fixes your problems as well.

PS: if somebody wants to try if it helps, just remove the two “export GDK_*” lines from /usr/bin/startkde with a text editor…

PPS, as I just tried it myself on a Krypton LiveCD (based on Tumbleweed with the latest unstable KDE packages):
Those GDK_* variables do affect Firefox.
But setting both the way I suggested will actually force a scaling of 1 (as explained in the bug report).

Either of this would scale Firefox by a factor of 2:

GDK_SCALE=2 firefox


GDK_DPI_SCALE=2 firefox

Of course if they are already both set by startkde, you’d need to unset one or the other: