Broken Gnome 3.8 login on Tumbleweed (12.3)

I have a working openSUSE 12.3, 3.7.10-1.11-desktop x86_64 with Gnome I have also tried a Gnome 3.8 upgrade for the 12.3 kernel and got it to work (nouveau, intel xeon, Nvidia).

So I tried to upgrade a parallell root installation on the same hardware (dual boot, common /home) to Tumbleweed 3.9.4-11.g51bf0ff-desktop with Gnome 3.8.2, and got a broken GDM login with the message:

“Oh no! Something has gone wrong. A problem has occurred and the system can’t
recover. All extensions have disabled as a precaution. [Logout]”

(Now I have also tried openSUSE 13.1 Milestone 1 and Milestone 2, 3.9.0-1-desktop x86_64 and Gnome 3.8.x, and get the same broken GDM login problem.)

Has anybody success with Tumbleweed Gnome login?
What can possibly be done to fix this login, there is no longer fallback mode? (KDE works ok)

My first Tumbleweed install:

Gnome did not work (with nouveau driver). I installed the nvidia driver. Gnome still did not work.

Two days later, after a further update, it worked. I expect that was a TW problem. But that should not be what is affecting you.

On a different partition with the same box, I installed openSUSE-Edu-li-f-e-12.3-1-i686 which worked fine. Then I tried the nvidia driver. It still worked. Then I did an update, and Gnome 3.6 kept failing. I later reinstalled, but stuck to nouveau, and it still works with all of the updates.

On a different box, with Intel graphics:

I installed 12.3, moved to Tumbleweed. Gnome kept failing. I changed my repo priorities - 98 for Tumbleweed and Packman-Tumbleweed, 99 for the rest. I re-updated. Gnome started working and has worked well ever since (except for that icewm/GDM problem I mentioned in a reply to your prelease-beta post). I suggest you try that priority change with Tumbleweed. I’m guessing it won’t help, since you also have problems with 13.1 milestones. But it is at least worth a try.

Did you put your login user into the “video” group? Apparently the nvidia drivers require this.

As I already said on the Pre-release forum, I don’t think my Gnome session login problem is caused by GDM, because login to a KDE session from GDM has worked ok. (Now I have also tried KDM on 13.1 M2: Login to KDE works, login to Gnome breaks as before.)

The common denominator I’ve noticed, is that after upgrade to newer kernels than 3.7.x (3.8.x, 3.9.x or 3.10), the Gnome 3.8 login has been broken!?
Gnome 3.8 also worked on Tumbleweed with kernel 3.7.x, but after upgrade to 3.9 the login was broken.

I still have Tumbleweed with kernel 3.7.10-1-1-desktop and a working Gnome on another, AMD-based machine. On that machine I have never got upgrade to a 3.9 kernel. I just ran ‘zypper dup --from Tumbleweed’ on this system, and it reported there was problems with installed package 'kernel-desktop-, and suggested to keep this absolute kernel. (Yes, was installed, but 3.7.10 was booted and running).

On one of my Tumbleweed installs, I have kept kernel 3.7.10-1.11. That’s mostly because it’s a UEFI box, and kernel 3.7.10-1.11 is signed for secure-boot, but the more recent kernels are not.

In “/etc/zypp/zypp.conf” I have:

multiversion.kernels = oldest,latest,latest-1,running

so that the older 3.7.10 kernel won’t be purged in the multi-version cleanup.

You could probably try installing 3.7.10-1.11, and make similar changes to your multiversion settings.

However, my best guess for your Gnome problems is that your video drivers are not doing things the way that Gnome wants them to be done. It’s a pity that they removed “fallback”. I suspect that there will be pressure to reinstate fallback. I switched from Gnome to KDE, mostly because I concluded that the Gnome developers had become too arrogant, too insistent on wanting things to be done their way, the end-user be ****ed.