Broken Firefox, likely pushed via Leap 15.1 updates

Hello,

I have two PCs with OpenSUSE Leap 15.1 Linux with different hardware. At the very same time the Firefox browsers stopped completely working on both. By completely I mean one can start them and view pages like “about:support”, but any attempt to open a new tab results in a message “Gah! Your tab just crashed!”.

It doesn’t work in Safe Mode either. There are close to none plugins on one of them, disabling plugins on the other Firefox doesn’t help.
It can’t be an issue of bad memory or drive or graphic card driver - the two computers are different and it happened at the same time.
It wouldn’t even connect to my local router IP address, so it doesn’t seem to be some issue with external routing.

I followed advise on Firefox support and downloaded their binaries to test and they are working fine.
It’s been about 7-10 days since the issue started. I believe it may be either broken Firefox update or incompatible update of a system component that Firefox is dependent on. It seems that OpenSUSE Leap pushed updates that does not work with my systems, two totally different computers (hardware-wise).

Crash report: bp-c590e601-5e2c-4237-8b27-83d840200414https://static-media-prod-cdn.itsre-sumo.mozilla.net/static/sumo/img/questions/icon.questionmark.png](https://support.mozilla.org/kb/helping-crashes)
[FONT=arial]Version 68.7.0esr
Assembly ID 20200403171148
Identification of browser Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0
OS Linux 4.12.14-lp151.28.44-default

Anyone having similar problems? What do we do about it? Just wait for another updates?
[/FONT]

Please post:

zypper lr -d
zypper se -si firefox

Hello, the first list is pretty long, I omitted it for the moment, I think this one is important:


**#** zypper se -si firefox

S  | Název                              | Typ     | Verze               | Architektura | Úložiště                      
---+------------------------------------+---------+---------------------+--------------+------------------------------
i+ | MozillaFirefox                     | balíček | 68.7.0-lp151.2.42.1 | x86_64       | openSUSE:Leap:15.1:Update     
i+ | MozillaFirefox                     | balíček | 68.7.0-lp151.2.42.1 | x86_64       | Hlavní aktualizační repozitář
i+ | MozillaFirefox-branding-openSUSE   | balíček | 68-lp151.3.3.1      | x86_64       | openSUSE:Leap:15.1:Update     
i+ | MozillaFirefox-branding-openSUSE   | balíček | 68-lp151.3.3.1      | x86_64       | Hlavní aktualizační repozitář
i+ | MozillaFirefox-translations-common | balíček | 68.7.0-lp151.2.42.1 | x86_64       | openSUSE:Leap:15.1:Update     
i+ | MozillaFirefox-translations-common | balíček | 68.7.0-lp151.2.42.1 | x86_64       | Hlavní aktualizační repozitář

Here are the related repositories:

23 | repo-update                         | Hlavní aktualizační repozitář              | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss   
 5 | http-download.opensuse.org-14566a79 | openSUSE:Leap:15.1:Update                  | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/

I suggest that it is better do provide the information asked for. When it is “pretty long” the more chance something is wrong there. And when the above two lines are from the list, my conclusion is that they are in the wrong sequence to begin with, that with at least 23 repos, you indeed have many (maybe too many) repos and as last that these two show the same URL, thus one is superfluous and we are still even missing the OSS repo.

Also, a copy/past of a longer list is not much more tedious then two copy/pasts from two snippets. Thus no fear for RSI please.

Remember that to begin with nobody else here reported the same FF problem, thus it must be something in your systems. And secondly when asking for help it often means that one does not see something that might be obvious to others. But others can only see that obvious thing when they see the complete information.

So please again:

LANG=C zypper lr -d

No problem, the forum screamed that the **post is too long **and cannot be submitted. Obviously, I’m not lazy to put it all here :-). When I reviewed the pasted text now, I noticed it was all inserted twice, so it does fit the post limit now.

Note, that this output is made only from one of the two PCs. This is the new hi-spec PC with new clean Leap 15.1 (2 months old), the other one is about 10 years old 4 core, being updated (not reainstalled) along, now at Leap 15.1 too.

**#** zypper lr -d
#  | Alias                               | Název                                      | povoleno | Kontrola GPG | Obnovit | Priorita | Typ    | Adresa URI                                                                  
                     | Služba
---+-------------------------------------+--------------------------------------------+----------+--------------+---------+----------+--------+-----------------------------------------------------------------------------
---------------------+-------
 1 | 15.1                                | nVidia                                     | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.1                              
                     |        
 2 | Leap_15.1                           | VLC                                        | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.videolan.org/pub/vlc/SuSE/Leap_15.1/                        
                     |        
 3 | devel:languages:ruby:extensions     | devel:languages:ruby:extensions            | Ano      | (r ) Ano     | Ne      |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/ruby:/extensions
/openSUSE_Leap_15.0/ |        
 4 | http-download.opensuse.org-0d26a209 | Virtualization                             | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.1/
                     |        
 5 | http-download.opensuse.org-14566a79 | openSUSE:Leap:15.1:Update                  | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/                          
                     |        
 6 | http-download.opensuse.org-4270ef60 | Office                                     | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/repositories/Office/openSUSE_Leap_15.1/        
                     |        
 7 | http-download.opensuse.org-635c9960 | home:gottcode                              | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/gottcode/openSUSE_Leap_15.1/
                     |        
 8 | http-download.opensuse.org-bd78d9ce | home:happenpappen                          | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/happenpappen/openSUSE_Leap_1
5.1/                 |        
 9 | http-download.opensuse.org-bdb3a8ec | home:digitaltomm                           | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/digitaltomm/openSUSE_Leap_15
.1/                  |        
10 | http-download.opensuse.org-daa3b97b | home:digitaltomm                           | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/digitaltomm/openSUSE_Leap_15
.1/                  |        
11 | http-download.opensuse.org-db565e85 | home:gottcode                              | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/gottcode/openSUSE_Leap_15.1/
                     |        
12 | openSUSE-Leap-15.1-1                | openSUSE-Leap-15.1-1                       | Ne       | ----         | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-General_UDisk_1311161937162186920314-0:0-par
t2                   |        
13 | openSUSE_Leap_15.1                  | Pacman                                     | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.1/          
                     |        
14 | openSUSE_Leap_15.1_1                | Snappy                                     | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.1
                     |        
15 | repo-debug                          | Debug Repository                           | Ne       | ----         | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/         
                     |        
16 | repo-debug-non-oss                  | Debug Repository (Non-OSS)                 | Ne       | ----         | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/     
                     |        
17 | repo-debug-update                   | Update Repository (Debug)                  | Ne       | ----         | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.1/oss/                    
                     |        
18 | repo-debug-update-non-oss           | Update Repository (Debug, Non-OSS)         | Ne       | ----         | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.1/non-oss/                
                     |        
19 | repo-non-oss                        | Non-OSS repozitář                          | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/           
                     |        
20 | repo-oss                            | Hlavní repozitář                           | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/               
                     |        
21 | repo-source                         | Zdrojový repozitář                         | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/        
                     |        
22 | repo-source-non-oss                 | Source Repository (Non-OSS)                | Ne       | ----         | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/    
                     |        
23 | repo-update                         | Hlavní aktualizační repozitář              | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                           
                     |        
24 | repo-update-non-oss                 | Aktualizační repozitář (uzavřený software) | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                      
                     |        
25 | repo-update-test                    | Netestované aktualizace                    | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1-test/                         
                     |        
26 | skype-stable                        | skype (stable)                             | Ano      | (r ) Ano     | Ano     |   99     | rpm-md | https://repo.skype.com/rpm/stable/                                          
                     |       


Post:

zypper se -sir http://download.opensuse.org/update/leap/15.1-test/

I also do not trust that test repo. Why is it there?

And as already said #5 and #23 are the same. Better remove one.

And of course each one of those home: repos could be a source of problems. IMHO one better disables such extra repos (and maybe a few of the others) after one installed from them the sofware that one wanted from them. And only disable and use them again when exactly those packages are updated.

15.1-test - Python-related stuff:

**#** zypper se -ir http://download.opensuse.org/update/leap/15.1-test/
S  | Název               | Shrnutí                                                                                                                                                                                             | Typ     
---+---------------------+-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------
i+ | 11296               | Recommended update for mokutil                                                                                                                                                                      | patch   
i+ | 11857               | Security update for python                                                                                                                                                                          | patch   
i+ | 11991               | Recommended update for gdm                                                                                                                                                                          | patch   
i+ | 12044               | Security update for python                                                                                                                                                                          | patch   
i+ | 12080               | Recommended update for gdm                                                                                                                                                                          | patch   
i+ | 12190               | Recommended update for sysconfig                                                                                                                                                                    | patch   
i+ | 12309               | Recommended update for parted                                                                                                                                                                       | patch   
i+ | 12310               | Recommended update for rpm                                                                                                                                                                          | patch   
i+ | 12327               | Recommended update for azure-cli tools, python-adal, python-applicationinsights, python-azure modules, python-msrest, python-msrestazure, python-pydocumentdb, python-uamqp, python-vsts-cd-manager | patch   
i+ | gdmflexiserver      | Compatibility Wrapper for Display Managers                                                                                                                                                          | balíček
i+ | libparted0          | Library for manipulating partitions                                                                                                                                                                 | balíček
i  | libpython2_7-1_0    | Python Interpreter shared library                                                                                                                                                                   | balíček
i+ | mokutil             | Tools for manipulating machine owner keys                                                                                                                                                           | balíček
i+ | parted              | GNU partitioner                                                                                                                                                                                     | balíček
i+ | parted-lang         | Translations for package parted                                                                                                                                                                     | balíček
i  | python              | Python Interpreter                                                                                                                                                                                  | balíček
i  | python-base         | Python Interpreter base package                                                                                                                                                                     | balíček
i  | python-xml          | A Python XML Interface                                                                                                                                                                              | balíček
i+ | python3-PyYAML      | YAML parser and emitter for Python                                                                                                                                                                  | balíček
i+ | python3-rpm         | Python Bindings for Manipulating RPM Packages                                                                                                                                                       | balíček
i+ | python3-sshtunnel   | SSH tunnels to remote server                                                                                                                                                                        | balíček
i+ | rpm                 | The RPM Package Manager                                                                                                                                                                             | balíček
i+ | sysconfig           | The sysconfig scheme for traditional network scripts                                                                                                                                                | balíček
i+ | sysconfig-netconfig | Script to apply network provided settings                                                                                                                                                           | balíček


Please use copy and paste, i have wriiten: zypper se -sir, you have done: zypper se -ir

Also use LANG=C so that you get an English output:

LANG=C zypper se -sir http://download.opensuse.org/update/leap/15.1-test/

This is a 15.0 Repo:

3 | devel:languages:ruby:extensions     | devel:languages:ruby:extensions            | Ano      | (r ) Ano     | Ne      |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/ruby:/extensions/openSUSE_Leap_15.0/

I’m sorry, I was in the process of testing myself and mixed the two of them. Good to know about LANG flag, I’ll remember. Here it is:

**#** LANG=C zypper se -sir http://download.opensuse.org/update/leap/15.1-test/

S  | Name                | Type    | Version                | Arch   | Repository              
---+---------------------+---------+------------------------+--------+------------------------
i+ | 11296               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 11857               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 11991               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 12044               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 12080               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 12190               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 12309               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 12310               | patch   | 1                      | noarch | Netestované aktualizace
i+ | 12327               | patch   | 1                      | noarch | Netestované aktualizace
i+ | gdmflexiserver      | package | 3.26.2.1-lp151.16.10.1 | noarch | Netestované aktualizace
i+ | libparted0          | package | 3.2-lp151.9.9.1        | x86_64 | Netestované aktualizace
i  | libpython2_7-1_0    | package | 2.7.17-lp151.10.17.1   | x86_64 | Netestované aktualizace
i+ | mokutil             | package | 0.3.0-lp151.6.3.1      | x86_64 | Netestované aktualizace
i+ | parted              | package | 3.2-lp151.9.9.1        | x86_64 | Netestované aktualizace
i+ | parted-lang         | package | 3.2-lp151.9.9.1        | noarch | Netestované aktualizace
i  | python              | package | 2.7.17-lp151.10.17.1   | x86_64 | Netestované aktualizace
i  | python-base         | package | 2.7.17-lp151.10.17.1   | x86_64 | Netestované aktualizace
i  | python-xml          | package | 2.7.17-lp151.10.17.1   | x86_64 | Netestované aktualizace
i+ | python3-PyYAML      | package | 5.1.2-lp151.2.9.1      | x86_64 | Netestované aktualizace
i+ | python3-rpm         | package | 4.14.1-lp151.14.3.1    | x86_64 | Netestované aktualizace
i+ | python3-sshtunnel   | package | 0.1.4-lp151.2.3.1      | noarch | Netestované aktualizace
i+ | rpm                 | package | 4.14.1-lp151.14.3.1    | x86_64 | Netestované aktualizace
i+ | sysconfig           | package | 0.85.3-lp151.2.9.1     | x86_64 | Netestované aktualizace
i+ | sysconfig-netconfig | package | 0.85.3-lp151.2.9.1     | x86_64 | Netestované aktualizace

I would change all of the above packages to OSS or OSS Update Repo and delete the Update-Test Repo.

Please post:

LANG=C zypper se -si | grep -Ei 'systemp|system-p|system_p|system p'

I know about that repository, that was source of a package I couldn’t get for 15.1 (I don’t remember what, I think it didn’t work properly and I had to build it from sources, finally). It wasn’t set for automatic updates. I had disabled it and ran package manager and did force update of Firefox, no change.

I wonder what should be the latest version for Leap 15.1?
Package manager doesn’t show any dependency or any trouble and both Firefoxes on different computers stopped working at the same time.

**#** LANG=C zypper se -si | grep -Ei 'systemp|system-p|system_p|system p'
i+ | dbeaver-ce                               | package | 7.0.1-stable                              | x86_64 | (**System P**ackages)             
i+ | festvox-awb-arctic-hts                   | package | 2.5.0-3.fc30                              | noarch | (**System P**ackages)             
i+ | festvox-bdl-arctic-hts                   | package | 2.5.0-3.fc30                              | noarch | (**System P**ackages)             
i+ | festvox-clb-arctic-hts                   | package | 2.5.0-3.fc30                              | noarch | (**System P**ackages)             
i+ | festvox-jmk-arctic-hts                   | package | 2.5.0-3.fc30                              | noarch | (**System P**ackages)             
i+ | festvox-rms-arctic-hts                   | package | 2.5.0-3.fc30                              | noarch | (**System P**ackages)             
i+ | festvox-slt-arctic-hts                   | package | 2.5.0-3.fc30                              | noarch | (**System P**ackages)             
i+ | ffmpeg-3                                 | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | fingerprint-gui                          | package | 1.09-lp151.3.2                            | x86_64 | (**System P**ackages)             
i+ | gdmflexiserver                           | package | 3.26.2.1-lp151.16.10.1                    | noarch | (**System P**ackages)             
i+ | jre1.8                                   | package | 1.8.0_241-fcs                             | x86_64 | (**System P**ackages)             
i+ | kup                                      | package | 0.7.3-lp150.1.1                           | x86_64 | (**System P**ackages)             
i+ | libavcodec57                             | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libavdevice57                            | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libavfilter6                             | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libavformat57                            | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libavresample3                           | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libavutil55                              | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libfreebl3                               | package | 3.47.1-lp151.2.13.1                       | x86_64 | (**System P**ackages)             
i+ | libfreebl3-hmac                          | package | 3.47.1-lp151.2.13.1                       | x86_64 | (**System P**ackages)             
i+ | libparted0                               | package | 3.2-lp151.9.9.1                           | x86_64 | (**System P**ackages)             
i+ | libpostproc54                            | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i  | libpython2_7-1_0                         | package | 2.7.17-lp151.10.17.1                      | x86_64 | (**System P**ackages)             
i+ | libsoftokn3                              | package | 3.47.1-lp151.2.13.1                       | x86_64 | (**System P**ackages)             
i+ | libsoftokn3-hmac                         | package | 3.47.1-lp151.2.13.1                       | x86_64 | (**System P**ackages)             
i+ | libswresample2                           | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libswscale4                              | package | 3.4.5-4.pm151.1                           | x86_64 | (**System P**ackages)             
i+ | libx265-179                              | package | 3.2.1-pm151.3.3                           | x86_64 | (**System P**ackages)             
i+ | mbrola                                   | package | 302b-pm152.1.3                            | x86_64 | (**System P**ackages)             
i+ | mokutil                                  | package | 0.3.0-lp151.6.3.1                         | x86_64 | (**System P**ackages)             
i+ | mozilla-nss                              | package | 3.47.1-lp151.2.13.1                       | x86_64 | (**System P**ackages)             
i+ | mozilla-nss-certs                        | package | 3.47.1-lp151.2.13.1                       | x86_64 | (**System P**ackages)             
i+ | openSUSE-release-dvd                     | package | 15.1-lp151.298.1                          | x86_64 | (**System P**ackages)             
i+ | parted                                   | package | 3.2-lp151.9.9.1                           | x86_64 | (**System P**ackages)             
i+ | parted-lang                              | package | 3.2-lp151.9.9.1                           | noarch | (**System P**ackages)             
i  | python                                   | package | 2.7.17-lp151.10.17.1                      | x86_64 | (**System P**ackages)             
i  | python-base                              | package | 2.7.17-lp151.10.17.1                      | x86_64 | (**System P**ackages)             
i  | python-xml                               | package | 2.7.17-lp151.10.17.1                      | x86_64 | (**System P**ackages)             
i+ | python3-PyYAML                           | package | 5.1.2-lp151.2.9.1                         | x86_64 | (**System P**ackages)             
i+ | python3-rpm                              | package | 4.14.1-lp151.14.3.1                       | x86_64 | (**System P**ackages)             
i+ | python3-sshtunnel                        | package | 0.1.4-lp151.2.3.1                         | noarch | (**System P**ackages)             
i+ | qownnotes                                | package | 20.2.7-lp151.1.1                          | x86_64 | (**System P**ackages)             
i+ | rpm                                      | package | 4.14.1-lp151.14.3.1                       | x86_64 | (**System P**ackages)             
i+ | ruby2.5-rubygem-bundler                  | package | 2.1.4-lp150.113.1                         | x86_64 | (**System P**ackages)             
i+ | sysconfig                                | package | 0.85.3-lp151.2.9.1                        | x86_64 | (**System P**ackages)             
i+ | sysconfig-netconfig                      | package | 0.85.3-lp151.2.9.1                        | x86_64 | (**System P**ackages)  

I see Fedora package and packages from Leap 15.0 and 15.2…

i+ | mbrola | package | 302b-pm152.1.3 | x86_64 | (System Packages)

i+ | kup | package | 0.7.3-lp150.1.1 | x86_64 | (System Packages)

i+ | jre1.8 | package | 1.8.0_241-fcs | x86_64 | (System Packages)

And more Fedora…

Fedora: Yep, that’s correct, but those are only voices. Not available for OpenSUSE, sadly no decent TTS stuff for OpenSUSE is availble.

Leap 15.2: I believe I was testing an app not available for Leap 15.1. The fact, that it is from a different release doesn’t mean it wouldn’t work - it depends on used libraries.

EDIT: I mean I will disable them too for the moment and see if it makes a difference. I’ll give it a try and we’ll see.

i+ | jre1.8 | package | 1.8.0_241-fcs | x86_64 | (System Packages)

openjdk?

i+ | java-1_8_0-openjdk                                | Paket      | 1.8.0.242-lp151.2.9.1                | x86_64 | OSS-Update   

Other packages can/may work or may not work.

But it is better only use packages build for your Version of your Distribution.

Or rebuild them and install these new packages.

On a second thought, it can’t be the reason. All those a bit odd packages are only on one of the PCs, the other one is used by my wife and nothing uncommon is added, nothing was installed there, only updates pushed by the OS, it is also true for most of repositories. But I’m going through the repositories and I’ve already disabled suspect repositories and force-reinstalled Firefox few times (with no improvement).

However, there might be one possibility: The 2nd PC has a long time trouble with some videos, so I tried to include/update some video codecs - and it could have been around the time the Firefoxes on both PCs stopped working. I might have updated also video codecs on my PC in the process. The video codec packages are now identical on both computers, but it wasn’t resolved on the older PC, there is a picture now, but colours are messed.

I’m sorry, I didn’t get what you ask for?

I have java-11-openjdk package, which is the default one. I have also* jre1.8*, which is required by Cytoscape. But that is not installed on the old PC.