Broke the Login Screen on OpenSuse Tumblweed after removing packages

I mindlessly removed some packages which, I thought, were all installed by myself. However, I was wrong. The packages involved are there

btrfsmaintenance dejavu-fonts desktop-data-openSUSE docbook_4 efont-unicode-bitmap-fonts fonts-config ghostscript-fonts-other ghostscript-fonts-std ghostscript-fonts-std-converted google-carlito-fonts google-poppins-fonts gtk2-branding-openSUSE gtk2-metatheme-adwaita gtk3-metatheme-adwaita hicolor-icon-theme hicolor-icon-theme-branding-openSUSE intlfonts-euro-bitmap-fonts intltool iso_ent issue-generator libBasicUsageEnvironment1 libcfitsio9 libesmtp6 libglslang11 libgmp10-32bit libgraphite2-3-32bit libgssdp-1_2-0-32bit libgupnp-1_2-0-32bit libgupnp-igd-1_0-4 libjbig2-32bit libKF5Screen7 libkgantt-lang libldac2-32bit liblmdb-0_9_29 liblockdev1-32bit libmarkdown2 libmtdev1-32bit libnscd1-32bit libproxy1-config-kde-32bit libqgpgme7 libqpdf28 libraw20 libre2-9 libreoffice-share-linker libsbc1-32bit libsrt1_4 libtiff5 libts0-32bit libunistring2 libwebrtc_audio_processing1-32bit libZXing1 man-pages-posix media-player-info metatheme-adwaita-common parallel-printer-support perl-biber python38-cmdln python38-dbus-python python38-decorator python38-gobject python38-gobject-cairo python38-gobject-Gdk python38-ipaddr python38-notify2 python38-pycairo python38-six python38-slip python38-slip-dbus qemu-ipxe sound-theme-freedesktop system-user-mktex wallpaper-branding-openSUSE xdg-menu xorg-x11-essentials yast2-trans-stats

I reinstalled them after noticing that it was not a good idea, but seemingly it was too late, and now I get a login screen looking like this. I would like to revert it back to its original state, to be seen here

I appreciate your time!

login root
update-alternatives --config default-displaymanager
systemctl restart xdm; exit

The above sequence may be able to restore your original login screen, but only if removing those packages didn’t also remove the display manager you had had. You didn’t tell us which that was, or which DE you selected for original installation, so we can only suggest to reinstall, if necessary, whichever of the following it may have been:

  • gdm
  • kdm3
  • lightdm
  • sddm
  • Thanks for your answer, but unfortunately, it didn’t help.

    I’m sorry. I forgot to include this information.

    I had chosen KDE Plasma when I installed it.

    Maybe you should check which DM your are using now (as root):

    update-alternatives --config default-displaymanager

    (hit enter to leave the program without making any change).

    I get the following output:

      Selection    Path                                  Priority   Status
    * 0            /usr/lib/X11/displaymanagers/xdm       10        auto mode
      1            /usr/lib/X11/displaymanagers/console   5         manual mode
      2            /usr/lib/X11/displaymanagers/xdm       10        manual mode

    Strange. It seems that you are missing sddm as well as lightdm.

    I think the image of the one you want to see is of sddm.

    In any case, try to install both

    zypper in sddm lightdm

    and then switch using the update-alternativecommand.


    BTW please next time (and all times after) include the command you use with all the output and the new prompt when you post. In this case we can assume you used exactly the command that was suggested, but we very much like to see all in one copy/paste. Then we see what you saw and there can be no misunderstandings. Example from s system here:

    boven:~ # update-alternatives --config default-displaymanager
    There are 4 choices for the alternative default-displaymanager (providing /usr/lib/X11/displaymanagers/default-displaymanager).
      Selection    Path                                  Priority   Status
      0            /usr/lib/X11/displaymanagers/sddm      25        auto mode
      1            /usr/lib/X11/displaymanagers/console   5         manual mode
    * 2            /usr/lib/X11/displaymanagers/lightdm   15        manual mode
      3            /usr/lib/X11/displaymanagers/sddm      25        manual mode
      4            /usr/lib/X11/displaymanagers/xdm       10        manual mode
    Press <enter> to keep the current choice[*], or type selection number: 
    boven:~ # 
    1 Like

    Sorry, for my delayed response. But, thank you ver much! Now it is working.

    Ummm … can you share “what” fixed it - a bit of a vague reply :+1:

    It was solved by running zypper in sddm lightdm and then switching to sddm as it was written by hcvv.

    1 Like

    Thanks for reporting back that it worked.

    1 Like