Broadcom wireless problem, NDISwrapper and b43 driver fail

I asked this on the mailing list and only got one reply that did not work, and I need to figure this out I can’t have my laptop connected through the Ethernet port all the time. According to dmesg I have a “b43-phy0: Broadcom 4311 WLAN found
Broadcom 43xx driver loaded Features: PMLR, Firmware-ID: FW13 ]” and the first way I tried to install the driver is with NDISwrapper by hand, same way I did in the previous two version of SUSE, and it didn’t get my wireless card working. NDISwrapper -l prints this:

bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)

In the past it listed bcm43xx as the alternate driver now it is this ssb thing. Any ways, giving up on NDISwrapper I tried b43-fwcutter on my firmware but that is not supported by b43-fwcutter

SE-03:~/Broadcom driver/tmp # b43-fwcutter bcmwl5.sys
Sorry, the input file is either wrong or not supported by b43-fwcutter.
This file has an unknown MD5sum 30d20fc98bcfd52e1da778cf19b223d4.

So moving back to NDISwrapper, this time using the NDISinstaller GUI… well that has been stuck on writing the module for over an hour.

Can someone else suggest anything else to try? I am a college student and rely heavily on working wifi, which really had not been a problem until this release.

Well I got it working with the b43 driver, don’t ask how because I don’t really know myself i just did it.

This article from Linux Wireless was very useful.
I no longer require the ndiswrapper for using the b43 on my Dell Latitude D510.
As a result the device is fully functional at boot time and there is no wait time to connect to my network once I’ve logged in.

b43 - Linux Wireless

vendion wrote:
> Well I got it working with the b43 driver, don’t ask how because I don’t
> really know myself i just did it.

If you go back to your old log messages in /var/log/messages, you will
see that the b43 driver was complaining about the firmware not being
available. What you must have done was get it installed.

The message about the bad md5sum resulted because b43-fwcutter does
not support EVERY version of the Broadcom drivers. The reason that
ndiswrapper switched from bcm43xx to ssb as the alternative driver is
that the new drivers (b43 and b43legacy) have the PCI interface in
ssb. Glue code in ssb selects the proper version based on the revision
number of the 802.11 core in the device.

Congratulations on getting b43 working. With your BCM4311, the
open-source driver is faster and more reliable than the Windows driver.


Well I had the firmware installed on my first try with the b43 driver, but still no luck. I don’t know what was different about this time but what ever it was I’m glad it happened.