Broadcom wireless, partchy internet

I’m trying to get my wireless to work on my laptop (dell inspiron 1520 broadcom 4311). I installed the b43 firmware and was able to set up my wireless connection. However, the internet connection is extremely patchy and seems to continuously drop (in fact most of the time it doesn’t work). I can ping certain sites such as Google and get all packets received.

PING www.google.com (209.85.153.103) 56(84) bytes of data.
64 bytes from bom01s01-in-f103.1e100.net (209.85.153.103): icmp_seq=1 ttl=252 time=44.5 ms
64 bytes from bom01s01-in-f103.1e100.net (209.85.153.103): icmp_seq=2 ttl=252 time=48.0 ms
64 bytes from bom01s01-in-f103.1e100.net (209.85.153.103): icmp_seq=3 ttl=252 time=45.7 ms
64 bytes from bom01s01-in-f103.1e100.net (209.85.153.103): icmp_seq=4 ttl=252 time=44.7 ms
64 bytes from bom01s01-in-f103.1e100.net (209.85.153.103): icmp_seq=5 ttl=252 time=48.3 ms

However if i try to ping yahoo.com all packets are lost.

ping -c 5 yahoo.com
PING yahoo.com (209.191.93.53) 56(84) bytes of data.

--- yahoo.com ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4003ms

Here’s the output for iwconfig:


lo        no wireless extensions.                                                          

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"belkin54g"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:17:3F:9F:F8:18   
          Bit Rate=48 Mb/s   Tx-Power=20 dBm                                   
          Retry  long limit:7   RTS thr:off   Fragment thr:off                 
          Encryption key:(Encyption key here)[3]                                                                          
          Power Management:off                                                             
          Link Quality=66/70  Signal level=-44 dBm  Noise level=-71 dBm                    
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0                         
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0 


Is the noise/signal level high? My wireless router (belking54g) is set up very close to the laptop.

The output for sudo /usr/sbin/iwlist scan

lo        Interface doesn't support scanning.                                   

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:17:3F:9F:F8:18
                    Channel:11                
                    Frequency:2.462 GHz (Channel 11)
                    Quality=49/70  Signal level=-61 dBm  
                    Encryption key:on                    
                    ESSID:"belkin54g"                    
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s                 
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s          
                    Mode:Master                                         
                    Extra:tsf=00000002aaba2185                          
                    Extra: Last beacon: 125ms ago                       
                    IE: Unknown: 000962656C6B696E353467                 
                    IE: Unknown: 010882848B962430486C                   
                    IE: Unknown: 03010B                                 
                    IE: Unknown: 2A0100                                 
                    IE: Unknown: 2F0100                                 
                    IE: IEEE 802.11i/WPA2 Version 1                     
                        Group Cipher : TKIP                             
                        Pairwise Ciphers (2) : CCMP TKIP                
                        Authentication Suites (1) : PSK                 
                    IE: Unknown: 32040C121860                           
                    IE: Unknown: DD09001018020011000000                 
                    IE: WPA Version 1                                   
                        Group Cipher : TKIP                             
                        Pairwise Ciphers (2) : CCMP TKIP                
                        Authentication Suites (1) : PSK

Furthermore, in Firefox the opening websites only works some of the time. Sometimes the google search page will load and sometimes it won’t.

I’ve disabled ipv6 using yast-network settings.

Any help would be appreciated!

On 01/26/2010 02:06 PM, Anonymous1986 wrote:
>
> I’m trying to get my wireless to work on my laptop (dell inspiron 1520
> broadcom 4311). I installed the b43 firmware and was able to set up my
> wireless connection. However, the internet connection is extremely
> patchy and seems to continuously drop (in fact most of the time it
> doesn’t work). I can ping certain sites such as ‘Google’
> (http://www.google.com) and get all packets received.

That sounds like a nameserver problem. Please post the output of

cat /etc/resolv.conf

> Code:
> --------------------
>
> lo no wireless extensions.
>
> eth0 no wireless extensions.
>
> wmaster0 no wireless extensions.
>
> wlan0 IEEE 802.11bg ESSID:“belkin54g”
> Mode:Managed Frequency:2.462 GHz Access Point: 00:17:3F:9F:F8:18
> Bit Rate=48 Mb/s Tx-Power=20 dBm
> Retry long limit:7 RTS thr:off Fragment thr:off
> Encryption key:(Encyption key here)[3]
> Power Management:off
> Link Quality=66/70 Signal level=-44 dBm Noise level=-71 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
>
> --------------------
>
>
> Is the noise/signal level high? My wireless router (belking54g) is set
> up very close to the laptop.

Looks normal.

> I’ve disabled ipv6 using yast-network settings.

Some 11.2 kernels have IP6 built in, not as a module. You should disable it in
Firefox as well.

OT: I just detected the notices to the community. Unfortunately the link to [opensuse-wiki] Minutes Mentoring session, December 27th is dead :stuck_out_tongue:

Thanks for your reply iwfinger. I’ve changed my dns servers to the google ones in knetwork manager and disabled ipv6 in firefox. Everything seems to be working now (including the ping to yahoo.com). However I think I need to disable ipv6 systemwide, since konqueror still seems slow and I would like to use google chrome.

Here’s the ouput of cat /etc/resolv.conf

### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search Belkin
nameserver 192.168.2.1
nameserver 203.115.0.18
nameserver 222.165.160.2

There seem to be a fair few guides on how to disable ipv6 completely, would this one work:

http://wiki.suselinuxsupport.de/wikka.php?wakka=HowToDisableIPV6

In firefox: In firefox address bar - about:config
Look for … network.dns.disableIPv6 and set it to “true”.

In KDE:
YaST -> system -> etc/sysconfig editor -> Desktop -> KDE_USE_IPV6 = no
YaST -> system -> etc/sysconfig editor -> Network -> SuSEfirewall2 -> FW_IPv6_REJECT_OUTGOING = yes

In Kernel:
1- Modify /etc/modprobe.conf.local by adding the following:
install ipv6 /bin/true
2- Modify /etc/modprobe.conf
alias net-pf-10 off

Thanks a lot for your help!

On 01/26/2010 10:36 PM, Anonymous1986 wrote:
>
> Thanks for your reply iwfinger. I’ve changed my dns servers to the
> google ones in knetwork manager and disabled ipv6 in firefox. Everything
> seems to be working now (including the ping to yahoo.com). However I
> think I need to disable ipv6 systemwide, since konqueror still seems
> slow and I would like to use google chrome.

Some of the 11.2 kernels have IPV6 built-in, not as a module. For them, you need
to add “disable_ipv6=1” to the kernel boot line in /boot/grub/menu.lst.

Some of the 11.2 kernels have IPV6 built-in, not as a module. For them, you need
to add “disable_ipv6=1” to the kernel boot line in /boot/grub/menu.lst.

Oh, I understand what you mean now. Cheers for your help!