Broadcom Wireless on Suse 11/XP Home system

Had a quick search and didn’t find the solution on the OpenSUSE wiki or in the forums, so I took matters into my own hands.

Problem :: Dual Booting SUSE 11 and Windows XP Home on a HP G6032 laptop. The Wireless was working fine in Windows, but wouldn’t work in Suse. I figured that the problem was with Suse at 1st, but after some looking it occurred to me that Suse could see the wireless card, but couldn’t get it started. Moved on to looking at the XP side of things. There was no “Allow Windows To Turn Off This Device” option for the wireless card(A “Fix” I remembered from my last laptop). However there is another solution.

Before Attempting the following fix back up your Windows registry. I will also not be held responsible for a FUBAR windows install.
Started out with this MS Help & Support guide, read it and get the gist of it.

How to disable power management for a network adapter when you deploy Windows XP

Following on from this I selected my network card, and the “PnPCapabilities” isn’t listed in the registry. Just add it in as follows ::

Type “regedit”
Go to the key as per the instructions above.
Select Edit>New>DWORD Value
Call the new value “PnPCapabilities” (Caps seems to matter here, don’t leave them out). Press Enter and you have a new registry value :slight_smile:
Right Click on the registry value and select “Modify”
Make sure the Base is set to Hexadecimal, and enter a value of “38”. Close all the boxes down.

This is where I get hazy. By habit I rebooted into Windows to make sure it still booted, it did so I booted into SUSE. I’m guessing you should be able to boot Suse directly, but editing a registry usually means I personally like to test it.

It worked, and I’m now sat on my wireless connection typing this on my SUSE boot :slight_smile:

thanks for this help…hopefully it might get moved to a how to :wink:

really good post though,


Cheers, I’m assuming it’ll work on other chipsets as well. Though that should be tested before posting it up as working for anything else. Also worked on the Intel 2200 wireless on my spare lappy. So i’m making an assumption it’ll work on other machines.