Broadcom wireless and speed

Hello!
I recently installed Open SUSE on my HP laptop with a (duh) Broadcom Wifi card. I finally got it to work, but it works very slowly. The max speed I get at my college WiFi is 5 mbits, and at home I can’t access the Internet at all ,just the LAN. It works perfectly in Windows on the same machine. At my college the Internet works fine though.
Anybody got some tips how to get the speed up and how to get the Internet at home to work?

First: Welcome to these Forums.

I hope that for your speed problem someone more with more knowledge in this will answer that.

About the Internet access.
Check if you have a rout to the Internet. Please post the output of:

netstat -rn

Also some people have the idea that they have no access to the Internet while in fact they have, but their DNS is not properly working.
When you can not access these Forums from a browser, can you when you use http://130.57.4.15?

On 03/22/2010 05:56 AM, william S wrote:
>
> Hello!
> I recently installed Open SUSE on my HP laptop with a (duh) Broadcom
> Wifi card. I finally got it to work, but it works very slowly. The max
> speed I get at my college WiFi is 5 mbits, and at home I can’t access
> the Internet at all ,just the LAN. It works perfectly in Windows on the
> same machine. At my college the Internet works fine though.
> Anybody got some tips how to get the speed up and how to get the
> Internet at home to work?

What version of openSUSE? What Broadcom card do you have? Has if been updated
since the install? What driver are you using?

It is very frustrating to have to pry details out of posters. Please give us
some specifics!!!

I agree with hcvv that it is likely that you have a DNS problem.

It is very frustrating to have to pry details out of posters. Please give us
some specifics!!!

:slight_smile: As almost every first time visitor, he might be a bit nervous. You will see that often. They write whole stories about what they did with Windows and how they found out about others operating systems end in the end they almost forget that they had a problem let alone to be exact and specific about that problem. We not only have the task to teach people about Linux and openSUSE, but also that computer knowledge is an exact bussiness. It seems that former MS Windows users have never learned this. Frustrating sometimes indeed rotfl!

Sorry.
I have a BCM 4312 card.
The version of Open SUSE is 11.2.
I am not really sure what driver I am using, as I have tried both with ndiswrapper and the standard driver that comes with the distro.

Output of netstat -rn


Destination: 192.168.0.0 Gateway:0.0.0.0 Genmask: 255.255.255.0 Flags: U MSS: 0 Window: 0 irtt 0 Iface:wlan0    

Looks a bit strange to me. My *nestat -rn * output is in columns (but there aremore then one entry there). Still stranger, normaly there also a route for 127.0.0.0.

In any case, no default route to your router is shown. Thus no traffic outside the LAN is possible. Are you using DHCP? When yes, DHCP should provide you with the default router.

On 03/22/2010 10:56 AM, william S wrote:
>
> Sorry.
> I have a BCM 4312 card.
> The version of Open SUSE is 11.2.
> I am not really sure what driver I am using, as I have tried both with
> ndiswrapper and the standard driver that comes with the distro.

I still need more information. What does the command

lspci -nnv | grep 14e4

show? There are two different BCM4312 cards. One has 802.11a/b/g and the other
802.11b/g. If you have the former, there is no standard driver for openSUSE 11.2.

Hello!
Sorry for the late reply.
I solved the problem with the Internet at home, I had to configure it with the classical method using ifup (?) and not the network manager. At home I have a decent speed with that configuration, but my network at school does not support that configuration (PEAP) and therefore I need to use the network manager which gives me a very slow speed.
I am sorry that I cannot give you any information now due to my laptop is at home. :slight_smile:
But the problem may be within the WiFi at the college, the other day it was extremely slow with Microsoft Windows as well (many users, some distance from the access point etc).

To start with a clean Networkmanager config in KDE4, do next, I solved a longtime annoyance on a laptop just yesterday, do it with the settings still to ‘traditional method’.


rm -r ~/.kde4/share/apps/networkmanagement && rm ~/.kde4/share/config/networkmanagementrc

This removes all old settings for the Networkmanager from your KDE4. After this, set the method in Yast back to Networkmanager, reboot and things should be working.

It is quite surprising that the speed would differ between ifup and NM. Once a
wireless connection is made, the method used to establish the connection is
completely “out of the way”. The basic rate setting is then controlled by the
rate-control algorithm in mac80211 using the retry information provided by the
driver with a goal of obtaining maximum throughput. You should use a speed-test
program such as iperf, or one of the network speed-test sites to check the rate.
The output of iwconfig will show the rate set by mac80211.