Broadcom not connecting stuck with sticky

I have had probs with wifi since upgrading to 11.1 from 10.2 and spent all day looking at threads so far I have:

From hardware info - wifi card is broadcom bcm4312 802.11b/g named eth0

wlan not present in hw info

looking at the
UDI: /org/freedesktop/Hal/devices/pci_14e4_4315

14e4315 and 14e4: 04b5

I am now unsure whether it is a 12 or a 15.

I have tried to get ndiswrapper but cannot get it from my usb stick into the netbook says it cannot open as not a folder.

I have tried the bcn43 firmware cmd but this does not work.

I;m not vg with linux so easy idiot level ideas welcome.:slight_smile:

so this post

My wireless doesn’t work - a primer on what I should do next - openSUSE Forums

would say:

Determine what device you have.


larry finger also says

At this point, you need to match the bus number (the numbers at the front that look like 04:00.0) from the first list to the second. These are the PCI vendor and product ID codes. For my BCM4312, these data are 14e4:4312. When you post a request for help, include both lines.


Once you know what your hardware is, the next step is to see what the kernel has to say about it. The command for this is ‘dmesg | less’


dmesg | less

larry then says

On my system, it takes 473 lines of output before the line “b43-phy0: Broadcom 4311 WLAN found” appears. In particular, you should look for any lines that indicate that you are missing firmware

missing firmware?

If you have missing firmware, check online to learn how to install firmware for your device.

can you supply as above?

That’s v helpful I get:

/sbin/lspci -
05:00.0 Network controller: Broadcom Corporation BCM4312 80211b/g (rev 01)
unsure what the 2nd list is as this is the only entry with 0500?
on the dmesg cmd there is no sign of broadcom or wlan or b43

Updater - just seen another post and the second line I wanted is as below with the two together:

02:00.0 Ethernet controller: Broadcom Corporation Netlink BCM5906M fast Ethernet PCI Express (rev 02)

Hope this helps

checking again there is a broadcom bluetooth device - could that also be teh wifi card? in dmesg it reads :

usb2-2: product BMC2046 Bluetooth device
usb 2-2: Manufacturer : Broadcom Corp
usb2-2: Serial number 00234EF21B0B
udevd version 128 started

it later reports:
eth0 renamed to eth1 by udevd [1258]

last line reads:
ADDRCONF (NETDEV_UP): eth1: link is not ready

Not usre if any if this is rel.

If you read this entry,

and read post #3 from larry finger he says:

The BCM4312 802.11b/g, which is the one you have, will not work with b43. You need to use ndiswrapper with the Windows
driver, or better the Broadcom wl driver.

I recommend that you install the appropriate broadcom-wl-xxxx package for your kernel.

First you need to check which kernel you have installed: type

uname -r
in a terminal; write the answer down

now you can either go to the packman repository and search and download what you need

(thanks to deltaflyer for this link in post #6)

PackMan :: Package details for broadcom-wl

or post #4 says to type in a terminal

zypper in broadcom-wl broadcom-wl-kmp-xxxx

where xxxx is the kernel you will identify from uname -r

so you need: to download and install the appropriate broadcom-wl-xxxx package for your kernel

If you go to post #7, it seemed to work for one lucky punter;

I am not a wireless expert, but I am telling you what is written in previous postings; it is your computer; you are asking for help

All fixed now downloaded from packman and now fine, can’t thank you enough, super job! :wink:

delighted it works; if you keep an eye on this forum, you will find others coming along with the same broadcom as you; you are welcome to help them with what worked for you;