Broadcom BCM43227 Wireless PROBLEM!!!

Hi everyone,

i have an acer aspire 5750g with a broadcom BCM43227 wireless card installed.

Yesterday i installed for the very first time OpenSuse 12.3 on my computer. Everything’s fine until i open the system and try to get online, when i found out no wireless connection is shown… :frowning:

I spent the last 2 days searching for any solution online and on this forum but with no effective results (at least in my case).

I also tried to download the proprietary broadcom-wl driver from this website:

, but i actually have no idea how should i proceed to install or whatever i should do with this package… :shame:

Is there anyone who could show me the right path or at least give me a list of the text lines to put on the terminal? :stuck_out_tongue:

Thanks everyone!

The broadcom-wl driver is available through the Packman repo:

Yast - Software - Softwarerepositories
Add - Repositories maintained by the community
Check the Packman repo
Trust the key when prompted for

Yast - Software - Softwaremanager
If not autoselected for install, search for “broadcom-wl”, tick the checkbox for install, AFAIK the kernel driver will be selected too as a dependency.
Perform the install, reboot and report if the situation has improved, i.e. if wireless networking works.

EDIT: I see it’s your first post here. Welcome !!


now finally the network manager sees the WLAN connection!

the problem is that i cannot use it yet since it finds no available connections…

if i go from yast to the network options i can see the WLAN is not connected and it needs to be configured, but when i try to modify it i’m asked for the host name ( which i dunno what it is… :shame: )

Can u pls give me a little more help?

I’m not much into the broadcoms but it could very well be that you need firmware to be installed. Try

su -c 'zypper in b43-firmware' 

then reboot.


thank u! now it works! rotfl!

finally i can use the forum as well to learn more about this OS :wink:

and i just find out another problem with the graphic card which is an NVIDIA GeForce GT540M which doesn’t allow me to change the brightness now set on max… not really good for my poor eyes…

guess i’ll have to search for it on the forum! thank u again for ur help and you’re welcome to give me any other suggest if u wish, i’m willing to learn :stuck_out_tongue:

Yeah, I met the exactly same question with you and did the same, however I still cannot found any wifi signal though my wireless card is up. What should be the problem?

IIRC I already advized to start a new thread, state your openSUSE version, desktop used (KDE, GNOME). And give us more information than “I have this too”, we don’t have crystal balls, we look at real data. So please, when starting a new thread, also include the output of the following command:

/sbin/lspci -nnk

Copy the output and post it there, between CODE tags, the # in the editor.