Broadcom 4312 - unable to connect

I had followed the instructions in the primer and had my wifi working for a bit. After changing cable routers, I am unable to connect to any wireless network.

My setup is OpenSUSE 11.4 (32bit) on a HP Mini 1101 netbook.

Here is the info I have gathered so far:

from $ /sbin/lspci I identified my wireless card as:
01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

using the 01:00.0 ID, from $ /sbin/lspci -n I found the Product ID Code as:
01:00.0 0280: 14e4:4315 (rev 01)

On line 714 of $ dmesg | less I found:

    5.073329] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
    5.133467] input: HP WMI hotkeys as /devices/virtual/input/input13
    5.191728] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
    5.193419] Registered led device: b43-phy0::tx
    5.193515] Registered led device: b43-phy0::rx
    5.193707] Registered led device: b43-phy0::radio
    5.193760] Broadcom 43xx driver loaded  Features: PMLS, Firmware-ID: FW13 ]

When clicking on the Network Manager, I am able to see my wireless network ID. But when I try to connect, I get a little popup stating Ive been disconnected.

When I run $ dmesg | less again, I find the following at the end:

 2114.120831] wlan0: authenticate with 00:1d:d0:6e:57:d0 (try 1)
 2114.122591] wlan0: authenticated
 2114.123066] wlan0: associate with 00:1d:d0:6e:57:d0 (try 1)
 2114.125718] wlan0: RX AssocResp from 00:1d:d0:6e:57:d0 (capab=0xc11 status=0 aid=1)
 2114.125729] wlan0: associated
 2114.136662] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
 2114.136798] cfg80211: Calling CRDA for country: US
 2114.150073] cfg80211: Regulatory domain changed to country: US
 2114.150084]     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
 2114.150094]     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
 2114.150103]     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
 2114.150111]     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
 2114.150119]     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
 2114.150128]     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
 2114.150136]     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
 2119.492311] ieee80211 phy0: wlan0: No probe response from AP 00:1d:d0:6e:57:d0 after 500ms, disconnecting.
 2119.494105] cfg80211: Calling CRDA to update world regulatory domain
 2119.507175] cfg80211: World regulatory domain updated:
 2119.507183]     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
 2119.507191]     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
 2119.507198]     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
 2119.507204]     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
 2119.507210]     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
 2119.507216]     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
 2120.904916] wlan0: authenticate with 00:1d:d0:6e:57:d0 (try 1)
 2121.104280] wlan0: authenticate with 00:1d:d0:6e:57:d0 (try 2)
 2121.304308] wlan0: authenticate with 00:1d:d0:6e:57:d0 (try 3)
 2121.504251] wlan0: authentication with 00:1d:d0:6e:57:d0 timed out

Can anyone help me fix or understand what is going on?

In 11.4 I needed to use Broadcom ‘wl’ driver from packman
Install Broadcom Drivers from Packman - Blogs - openSUSE Forums

Thanks for the response, Caf4926.

I ran the zypper commands and installed the wl driver. After rebooting, Network Manager no longer sees any access points, and shows the Wireless Networks as Disconnected and greyed out.

running /sbin/lspci -nnk I get:

01:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
	Subsystem: Hewlett-Packard Company Device [103c:1507]
	Kernel driver in use: wl

I’m not sure where to go from here. Any other suggestions or help is appreciated. Thanks.

The ‘wl’ driver is in place

Is this 11.4 install fully updated?

I believe I am fully updated.

Update manager runs daily, and I install all updates as soon as I’m able.

Please install rfkill

su -
zypper in rfkill

Now post the result of

/usr/sbin/rfkill list

Looking around, I did see references to rfkill and had installed it. Sorry, I wasn’t thinking to include that before.

#  rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hp-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Thanks again, Caf4926, for your attention and assistance.

OK. That’s good.

Now lets confirm everything:

Pos the result of

uname -a
rpm -qa | grep kernel
rpm -qa | grep broadcom

#  uname -a
Linux Mercury 2.6.37.6-0.11-default #1 SMP 2011-12-19 23:39:38 +0100 i686 i686 i386 GNU/Linux

#  rpm -qa | grep kernel
kernel-firmware-2.6.38-1.2.1.noarch
kernel-default-2.6.37.6-0.11.1.i586

#  rpm -qa | grep broadcom
broadcom-wl-kmp-default-5.100.82.112_k2.6.37.6_0.11-9.5.i586
broadcom-wl-5.100.82.112-9.5.i586

When doing the zypper in dl/install of the drivers, I had grabbed the -default package.

— Edit: Additional Info
Ive seen several other request for info in other threads. Don’t know if this is any help or not.


02:10 PM root@Mercury /home/potato
#  /sbin/modprobe -rv b43

02:10 PM root@Mercury /home/potato
#  /sbin/modprobe -rv wl
rmmod /lib/modules/2.6.37.6-0.11-default/updates/wl.ko
rmmod /lib/modules/2.6.37.6-0.11-default/kernel/net/wireless/cfg80211.ko

02:10 PM root@Mercury /home/potato
#  /sbin/modprobe -v wl
insmod /lib/modules/2.6.37.6-0.11-default/kernel/net/wireless/cfg80211.ko 
insmod /lib/modules/2.6.37.6-0.11-default/updates/wl.ko 

OK
It all looks good. I have to crash for the night.

I’m wondering about this HP Mini. If it has a physical switch for the wireless. One which you actually move like a switch? Some devices don’t and they can be problematic.

Another option to the ‘wl’ driver in 11.4 is to use b43 with an updated kernel.
I had to do this in 11.4 (although ‘wl’ worked fine too) For me b43 with kernel 2 didn’t work

Now I use 12.1 which has kernel 3> so I’m OK on b43

Have a think about it.
Does the wireless switch look like it works. I mean does the light toggle on/off when you switch it?

See you on the other side

Thanks, Caf4926.

Yes, the HP Mini has a little slide switch. The LED glows blue and Network Manager shows wireless is enabled when I right click on it. Sliding the switch turns the LED orange and Network Manager has the ‘enable wireless’ option greyed out and Wireless Networks shows that wireless is disabled.

Heh, I never knew this till now. I had never played with the switch or paid any attention to it, aside that it has always glowed blue.

I did download a copy of 12.1 and will try booting the live test and see if I have any different results.

Thanks again. Hope you have a good evening.

On 03/06/2012 04:26 PM, Wandering Voice wrote:
>
> Thanks, Caf4926.
>
> Yes, the HP Mini has a little slide switch. The LED glows blue and
> Network Manager shows wireless is enabled when I right click on it.
> Sliding the switch turns the LED orange and Network Manager has the
> ‘enable wireless’ option greyed out and Wireless Networks shows that
> wireless is disabled.
>
> Heh, I never knew this till now. I had never played with the switch or
> paid any attention to it, aside that it has always glowed blue.
>
> I did download a copy of 12.1 and will try booting the live test and
> see if I have any different results.
>
> Thanks again. Hope you have a good evening.

When you boot the live test, run the following, where <xxxx> is the partition
with / for 11.4:


su -
mount /dev/<xxxx> /mnt
cp /mnt/lib/firmware/b43 /lib/firmware
modprobe -rv b43
modprobe -v b43

Unless you do that, b43 will not have access to firmware.

Even in 12.1 it will not work until you install firmware. Which cannot include in the release due to licensing.
@lwfinger was suggesting adding the firmware to the live session, which I have done myself and it works.
I keep a copy of the firmware on a pendrive for easy installation. The I don’t need to be hardwired at all.

The useability of b43 in 12.1 is due to the kernel
I suggested using a updated kernel in 11.4 to achieve the same
or
You could just install 12.1

For the record, ‘wl’ should have worked. And your wireless switch sounds similar to my eeepc (which is fine for me), but it’s a rt2800pci
My broadcom device is on a Lenovo and it’s the same pretty much as yours. b43 in 11.4 didn’t work unless I went to kernel 3>, but ‘wl’ always worked.

Thanks for the info Caf, especially the mount tip for the LiveCD. I did try the live CD and found that I didn’t have the firmware at the time.

Ive got the b43 firmware in place now and lspci shows the b43 driver is in use. Im again able to scan and see access points, but unable to connect to mine. As I rarely have a need to use the wireless, its not that big a deal. But when I did try, it wasnt there :frowning: Oh well.

Ill keep digging around, and will share if I find a solution.

Unable to connect?
So it’s working
You just have a connect problem?

What wireless encryption is in use?

Yes, I’m able to scan and I can see my SSID and others. But when I try to connect to any, whether its protected or not, I time out receive an error saying I’ve been disconnected.

The cable modem/router is setup with: WPA/WPA2-PSK-TKIP/AES using protocols B, G, N.

In Network Manager I have the following settings:

  Wireless Tab:
    SSID: <my_ssid>
    Mode: Infrastructure
    MTU: Automatic
  IPv4 Tab:
    Method: Automatic (DHCP)
  IPv6 Tab:
    Method: Ignore
  Wireless Security Tab:
    Security: WPA & WPA2 Personal
    Password <verified many times>

I know the wifi is working. Kindles and other PCs are able to connect.

When I had originally setup 11.4 on here, the wifi worked but it was flakey. It would disconnect after a short while requiring me to disable and re-enable wireless to reconnect. When I switched ISPs and received a new cable router I was unable to connect at all. But I am also unable to connect to other open networks like the library, hotels or shops. The new router works well with other devices.

Can you please confirm if 12.1 live cd worked at all?

Are your most recent comments based on 11.4?

This behavior is with 11.4.

I’ll give the 12.1 LiveCD another shot here, with the firmware this time. I’ll post those results shortly.

OK, I’m posting this from 12.1 using the b43 firmware.

There were no problems scanning and finding my ssid. I also was able to connect first time, without issue.

So you can either install 12.1

or update the kernel in your 11.4 install.

I have a post here about that
http://forums.opensuse.org/english/get-technical-help-here/wireless/473131-can-not-get-wireless-working-after-upgrading-11-4-a-6.html#post2446743

You must make sure you don’t have any ‘wl’ broadcom packages installed
Use the firmware folder I gave you
Just confirm, this is on the HP Mini? Not your machine with a nvidia card?