Broadcom 4312: It's working but I have some questions

Hi, I’m new to Opensuse, I just installed 11.3, no serious problems so far.

I see a lot of people with problems to make work their Broadcom 4312 wireless. These are the steps I took to solve it. Please remember I’m a total rookie on Opensuse, so there is probably a better way.

First, this is my setup:

/sbin/lspci -nnk
04:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
uname -a
Linux maq3.site 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

Steps:

  1. At first I connected through the Ethernet network, wich worked out of the box after installing.

  2. There is a tool called Webpin on the administration tools menu. There, I searched for “broadcom”.

  3. From the results, I selected “broadcom-wl” and installed it.

  4. There were some warnings about adding a new untrusted repository. As this is a test install, I just ignored the warning and went ahead.

  5. After downloading and installing the driver, I rebooted.

  6. On reboot, I noticed there is a new item on Grub menu. If you boot with the default selection, wireless will not work, but if you select the very first entry, it will.

Now, while this worked, I have a couple of questions:

a. Any repository suggested by webpin can be trusted? Is there an external list or validator about the security level of a repository?

b. Why is there a new entry on Grub? On debian based systems this happens when you install a new kernel, which as far as I know it’s not what I did.

Thanks for your answers, I hope these instructions help other people.

Hi, about my second question, I found there are “Desktop” and “Default” kernels. My wireless works only on the “Default” kernel (which is not the default grub selection). I suggest trying this when your Broadcom fails to work.

I created a new thread asking about the differences between the kernels.

PS
sorry for the double post but I can’t find the “Edit Post” option…

There is a kernel module, you need for the broadcom driver (broadcom-wl-kmp-
xxx).

You probably installed broadcom-wl-kmp-default and with this module also the
kernel-default package. Install broadcom-wl-kmp-desktop and after that you
can uninstall kernel-default and xxx-kmp-default packages.
The second step should also remove the grub entry.