Broadcom 4312 Drivers Installation

@Akoellh

Ok. Under IV. running sudo /usr/slib/iwlist scan gives me something like it should except…

IE: Unknown: Then a string of about 100 characters and next line
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Encryption Key : on

When I run the script I choose…

2 WLAN
1 WLAN Access > Linux client
SSID: stupid

I always get the message…

For the selected connection type there is no active network interface found on your system.

Where am I going wrong?

So does anybody have any other suggestions how I might get my wireless working?

On 05/06/2010 04:06 AM, stubble wrote:
>
> So does anybody have any other suggestions how I might get my wireless
> working?

Get the script from
http://www.linux-tips-and-tricks.de/index.php/collectNWData.sh/collectNWData.html,
run it and look at the output. If you do not understand it, then post
the output.

OK. Here it is. But before I post it, a couple of comments. My setup is computer > wireless router > dsl modem > internet. I’ve used the network named STUPID as my SSID, because nobody has yet told me how to identify my SSID. If you need any info for my wireless router I can retrieve it thru Windows, but I know it is set up at 192.168.0.1 if that’s any help. My Wireless Network is set up on eth1, so I’ve removed references to lo, eth0, pan0 to reduce the size of this message so it will fit within the rules of posting, 15,000 character limit.

— Which type of your network connection should be tested?
— (2) Wireless connection (WLAN)
— What’s the type of networktopology?
— (1) WLAN access point <—> LinuxClient
— On which host is the script executed?
— (1) LinuxClient
— WLAN SSID to connect to: s#u#i#

— NWEliza is analyzing the system for common network configuration errors …

!!! CND0110E: For the selected connection type there was no active network interface found on your system

*** uname -a
Linux linux-w65m 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux

*** cat /etc/-_]release || cat /etc/-_]version
/etc/SuSE-release
openSUSE 11.2 (x86_64)
VERSION = 11.2

*** cat /etc/resolv | grep -i “nameserver”

*** cat /etc/hosts
127.0.0.1 localhost
127.0.0.2 linux-w65m.site linux-w65m

*** route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

*** ifconfig
eth1 Link encap:Ethernet HWaddr ##:##:##:##:##:#2
inet6 addr: fe80::222:5fff:feb8:599/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17 Base address:0xc000

*** ping tests
connect: Network is unreachable
Ping of 195.135.220.3 failed
ping: unknown host Linux-Betriebssystem | SUSE Linux Enterprise
Ping of Linux-Betriebssystem | SUSE Linux Enterprise failed

*** dhcpcd-test
eth1: No DHCP server detected info, eth1: hardware address = ##:##:##:##:##:#2
info, eth1: broadcasting for a lease
debug, eth1: sending DHCP_DISCOVER with xid 0x8ef87c
debug, eth1: waiting for 3 seconds
info, eth1: exiting

*** lspci
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)

*** lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 05ca:180c Ricoh Co., Ltd
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 003 Device 003: ID 413c:8161 Dell Computer Corp.
Bus 003 Device 004: ID 413c:8162 Dell Computer Corp.
Bus 003 Device 005: ID 413c:8160 Dell Computer Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 04f3:0230 Elan Microelectronics Corp.
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

*** hwinfo (filtered)
28: PCI c00.0: 0282 WLAN controller
Model: “Dell Wireless 1397 WLAN Mini-Card”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x4315 “BCM4312 802.11b/g”
SubVendor: pci 0x1028 “Dell”
SubDevice: pci 0x000c “Wireless 1397 WLAN Mini-Card”
Driver: “wl”
Driver Modules: “wl”
Device File: eth1
Link detected: yes
Driver Status: ssb is active
Driver Activation Cmd: “modprobe ssb”
Driver Status: wl is active
Driver Activation Cmd: “modprobe wl”
29: PCI 900.0: 0200 Ethernet controller
Model: “Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller”
Vendor: pci 0x10ec “Realtek Semiconductor Co., Ltd.”
Device: pci 0x8136 “RTL8101E/RTL8102E PCI Express Fast Ethernet controller”
SubVendor: pci 0x1028 “Dell”
SubDevice: pci 0x02cf
Driver: “r8169”
Driver Modules: “r8169”
Device File: eth0
Link detected: no
Driver Status: r8169 is active
Driver Activation Cmd: “modprobe r8169”

*** lsmod # (filtered)
| ac | acpi_cpufreq | af_packet | battery | bluetooth |
| bnep | bridge | btusb | cpufreq_conservative| cpufreq_powersave |
| cpufreq_userspace| crc16 | dcdbas | dell_laptop | drm |
| edd | fuse | i2c_algo_bit | i2c_i801 | i915 |
| ide_cd_mod | ide_gd_mod | intel_agp | ip6t_LOG | ip6t_REJECT |
| iptable_raw | iTCO_vendor_support| iTCO_wdt | jbd2 | l2cap |
| lib80211_crypt_tkip| llc | lp | nf_conntrack_ipv4| nf_conntrack_netbios_ns |
| pcmcia_core | ppdev | r8169 | rfcomm | rfkill |
| sco | serio_raw | sg | snd_hda_codec | snd_hda_codec_idt |
| snd_hda_intel | snd_hwdep | snd_seq_device | sr_mod | ssb |
| st | stp | thermal | thermal_sys | uvcvideo |
| v4l1_compat | v4l2_compat_ioctl32| video | wl | wmi |
| xt_limit | xt_NOTRACK | xt_physdev | xt_pkttype | xt_state |
| xt_tcpudp |

*** cat /etc/sysconfig/network/ifcfg-[earwd]*
— /etc/sysconfig/network/ifcfg-eth0
BOOTPROTO=‘dhcp’
MTU=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
— /etc/sysconfig/network/ifcfg-wlan0
BOOTPROTO=‘dhcp’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=’’
MTU=’’
NAME=’’
NETMASK=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
USERCONTROL=‘no’
WIRELESS_AP=’’
WIRELESS_AUTH_MODE=‘sharedkey’
WIRELESS_BITRATE=‘auto’
WIRELESS_CA_CERT=’’
WIRELESS_CHANNEL=’’
WIRELESS_CLIENT_CERT=’’
WIRELESS_CLIENT_KEY=’’
WIRELESS_CLIENT_KEY_PASSWORD=’’
WIRELESS_DEFAULT_KEY=‘0’
WIRELESS_EAP_AUTH=’’
WIRELESS_EAP_MODE=’’
WIRELESS_ESSID=’’
WIRELESS_FREQUENCY=’’
WIRELESS_KEY=’’
WIRELESS_KEY_0=’@@@@@@’
WIRELESS_KEY_1=’’
WIRELESS_KEY_2=’’
WIRELESS_KEY_3=’’
WIRELESS_KEY_LENGTH=’@@@@@@’
WIRELESS_MODE=‘Managed’
WIRELESS_NICK=’’
WIRELESS_NWID=’’
WIRELESS_PEAP_VERSION=’’
WIRELESS_POWER=‘yes’
WIRELESS_WPA_ANONID=’’
WIRELESS_WPA_IDENTITY=’’
WIRELESS_WPA_PASSWORD=’’
WIRELESS_WPA_PSK=’’

*** iwconfig
eth1 IEEE 802.11bg ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Managementmode:All packets received
Link Quality=5/5 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

*** Actual date for bias of following greps
06:01:14 2010-05-07

*** grep -i radio /var/log/messages* | tail -n 5

*** dmesg | grep -i radio | tail -n 5

*** tail -n 300 /var/log/messages* | /bin/grep -i firmware | tail -n 5

*** ls /lib/firmware/*
Removed to save space. Will post it if required.

*** ndiswrapper -l
No ndiswrapper module loaded

*** Active processes
wpa_supplicant:YES knetworkmanager:YES nm-applet:NO

*** egrep -i “persistent|networkmanager” /etc/sysconfig/network/config | grep -v “^#|^$”
NETWORKMANAGER=“yes”

*** grep ‘eth|ath|wlan|ra’ /etc/udev/rules.d/net_persistent /etc/udev/rules.d/persistent-net
/etc/udev/rules.d/70-persistent-net.rules:SUBSYSTEM==“net”, ACTION==“add”, DRIVERS=="?", ATTR{address}=="##:##:##:##:##:#1", ATTR{type}==“1”, KERNEL=="eth", NAME=“eth0”
/etc/udev/rules.d/70-persistent-net.rules:SUBSYSTEM==“net”, ACTION==“add”, DRIVERS=="?", ATTR{address}=="##:##:##:##:##:#2", ATTR{type}==“1”, KERNEL=="eth", NAME=“eth1”

*** grep -r ‘eth[0-10]|ath[0-10]|wlan[0-10]|ra[0-10]’ /etc/modprobe.*

*** iwlist scanning
ESSID:“s#u#i#”
Quality:5/5 Signal level:-46 dBm Noise level:-91 dBm
IE: WPA Version 1
Encryption key:on

*** NWElizaStates
IF:eth0 IM:1 IF:eth1 IM:2 DI:2 AP:1 FALON:0

On 05/06/2010 05:46 PM, stubble wrote:
>
> OK. Here it is. But before I post it, a couple of comments. My setup is
> computer > wireless router > dsl modem > internet. I’ve used the network
> named STUPID as my SSID, because nobody has yet told me how to identify
> my SSID. If you need any info for my wireless router I can retrieve it
> thru Windows, but I know it is set up at 192.168.0.1 if that’s any help.
> My Wireless Network is set up on eth1, so I’ve removed references to lo,
> eth0, pan0 to reduce the size of this message so it will fit within the
> rules of posting, 15,000 character limit.

Your SSID is “stupid” according to the scan data from the script. It is
not “STUPID”. Case matters. Nobody has told you how to identify it
because that is something that was set when the access point was
installed. If you do now know what the setting is, then ‘sudo
/usr/sbin/iwlist scan’ will show the SSID for all nearby access points.
The scan data also shows that you are using WPA encryption.

Do you want to use NetworkManager or ifup.

I’m a tad more familiar with Network Manager.

On 05/07/2010 05:16 PM, stubble wrote:
>
> I’m a tad more familiar with Network Manager.

Then configure your AP with the applet.

I was kinda hoping you were going to tell me what to configure. I’ve tried configuring it already but since I don’t exactly know what i’m doing and what I need to fix, nothing so far has succeeded.

On 05/07/2010 08:16 PM, stubble wrote:
>
> I was kinda hoping you were going to tell me what to configure. I’ve
> tried configuring it already but since I don’t exactly know what i’m
> doing and what I need to fix, nothing so far has succeeded.

From the NetworkManager applet, select “Manage Connections”. On the
pop-up, select Wireless, and choose “Add” on that screen. On the next
screen, put in what you want to call the connection (just a label), and
press the “scan” button. On the map, choose the AP you want (the one
that is labeled “stupid”), and click on OK. That will fill in the SSID
line. Now, select the “Wireless Security” tab. The “Security” line
should say “WPA/WPA2 Personal” as that is what your AP is broadcasting.
Enter the passphrase in its box. You should also check the “Connect
Automatically” box. Now, click on the “IP Address” tab, and pull down
the widgit that shows “Basic settings” so that it shows “Routes”. If
either of the two check boxes on that page are checked, uncheck them. At
this point, click OK on this page and the underlying one. Now disconnect
the wire and the wireless should try to connect.

OK. I think I’ve already done all that. But I’m not sure what you mean by “disconnect the wire”. Here is what my Wireless Connection is set as…

Wireless

SSID: stupid
Mode: Infrastructure
BSSID: 00:21:91:2F:C3:CB
Restrict to interface: Any
MTU: automatic

Wireless Security

Security: WPA/WPA2 Personal
Password: ******** (it’s in the correct case)

IP Adress

Configure: Automatic DHCP
DHCP Client ID: blank

When I click on the wireless icon,

1st line: my wireless connection detailed above
2nd line: Connect to another Network
3rd line: Enable Wireless ticked
4th line: Manage Connections

When I hover over the wireless icon.

Not connected. (This appears to be a contradiction with the 1st line above)

So what is wrong with my setup as described above? (because I’m not connected).

On 05/07/2010 10:46 PM, stubble wrote:
>
> OK. I think I’ve already done all that. But I’m not sure what you mean
> by “disconnect the wire”. Here is what my Wireless Connection is set
> as…
>
> Wireless
>
> SSID: stupid
> Mode: Infrastructure
> BSSID: 00:21:91:2F:C3:CB

Don’t enter anything here.

> Restrict to interface: Any
> MTU: automatic

Did you click on the “Connect Automatically”?

> Wireless Security
>
> Security: WPA/WPA2 Personal
> Password: ******** (it’s in the correct case)
>
> IP Adress
>
> Configure: Automatic DHCP
> DHCP Client ID: blank
>
> When I click on the wireless icon,
>
> 1st line: my wireless connection detailed above
> 2nd line: Connect to another Network
> 3rd line: Enable Wireless ticked
> 4th line: Manage Connections
>
> When I hover over the wireless icon.
>
> Not connected. (This appears to be a contradiction with the 1st line
> above)
>
> So what is wrong with my setup as described above?

Fix the two things above, then click on that first line. It should then
start.

OK. I had to create a new wireless connection (starting over). This appears to be working and activated. Konqueror seems to be able to surf the net, but Firefox isn’t loading. I may have to install it again. Anyway. The problem appears to have been resolved. Thank you very much indeed.

PS: Sorry for the delay between my replies. My internet connection has been up and down all day long today.

On 05/08/2010 03:06 AM, stubble wrote:
>
> OK. I had to create a new wireless connection (starting over). This
> appears to be working and activated. Konqueror seems to be able to surf
> the net, but Firefox isn’t loading. I may have to install it again.
> Anyway. The problem appears to have been resolved. Thank you very much
> indeed.
>
> PS: Sorry for the delay between my replies. My internet connection has
> been up and down all day long today.

The delays don’t matter. I always figure that the person that does the
original posting sets the rate of response no matter what the pace.

Good to hear that you got your problem solved.

There are reports of Firefox 3.6.X failing to load on some systems for
reasons not yet determined. If you back out to 3.5.9, it should work.