Brightness on Sony Vaio VPCEG25FL

Hi, I have problems with my new notebook Sony Vaio model VPCEG25FL with brightness control, graphic card is a nVidia 410m. fn keys are working with kde 4.7, but brightness do not change, following is what I’ve try to solve my problem but still no luck. Hope this information should be useful.

From here:

when I do a

jagobook:/home/jago # lsmod | grep sony
sony_laptop            35200  0

module is already loaded

Also there is a post about a documentation from driver

For Fn keys (hotkeys): when I press fn + brightness up (or down) /var/log/messages show:

Jan 29 17:01:34 jagobook dbus[960]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 29 17:01:34 jagobook dbus-daemon[960]: dbus[960]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
Jan 29 17:01:34 jagobook org.kde.powerdevil.backlighthelper: QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
Jan 29 17:01:34 jagobook dbus[960]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
Jan 29 17:01:34 jagobook dbus-daemon[960]: dbus[960]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'

and nothing more, /var/log/acpid show nothing, and horizontal bar are showing and sliding when keys are pressed, keys are correctly assigned.

Backlight control: say to search path:


but i don’t have a “sony” path at the end, I have only one directory that is a link to “acpi_video0” , but nothing about a “sony” path

jagobook:/proc/acpi # cd /sys/class/backlight/
jagobook:/sys/class/backlight # ll
total 0
lrwxrwxrwx 1 root root 0 ene 29 16:29 acpi_video0 -> ../../devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
jagobook:/sys/class/backlight # cd acpi_video0/
jagobook:/sys/class/backlight/acpi_video0 # ls
actual_brightness  bl_power  brightness  device  max_brightness  power  subsystem  type  uevent
jagobook:/sys/class/backlight/acpi_video0 # 

Files mentioned there have relation with the lcd brightness, I get:

jagobook:/sys/class/backlight/acpi_video0 # ll
total 0
-r--r--r-- 1 root root 4096 ene 29 17:07 actual_brightness
-rw-r--r-- 1 root root 4096 ene 29 17:07 bl_power
-rw-r--r-- 1 root root 4096 ene 29 17:01 brightness
lrwxrwxrwx 1 root root    0 ene 29 17:07 device -> ../../../0000:01:00.0
-r--r--r-- 1 root root 4096 ene 29 16:30 max_brightness
drwxr-xr-x 2 root root    0 ene 29 17:07 power
lrwxrwxrwx 1 root root    0 ene 29 16:28 subsystem -> ../../../../../../class/backlight
-r--r--r-- 1 root root 4096 ene 29 17:07 type
-rw-r--r-- 1 root root 4096 ene 29 16:28 uevent
jagobook:/sys/class/backlight/acpi_video0 # 

I think that I could use “standard UNIX tools” to get information, using cat:

jagobook:/sys/class/backlight/acpi_video0 # cat brightness 
jagobook:/sys/class/backlight/acpi_video0 # cat max_brightness 
jagobook:/sys/class/backlight/acpi_video0 # cat actual_brightness 
jagobook:/sys/class/backlight/acpi_video0 # cat bl_power 
jagobook:/sys/class/backlight/acpi_video0 # cat type 
jagobook:/sys/class/backlight/acpi_video0 # cat uevent 
jagobook:/sys/class/backlight/acpi_video0 # 

and trying

jagobook:/sys/class/backlight/acpi_video0 # echo "15" > actual_brightness 
bash: actual_brightness: Permiso denegado
jagobook:/sys/class/backlight/acpi_video0 # echo "15" > brightness

“actual_brightness” is read only, “brightness” can be written, but nothing happen to brightness.

From here:

I’ve installed sonypid but I have:

jagobook:/home/jago/Escritorio/sonypid-1.9.1 # sonypid 
sonypid: Sony Vaio **** daemon version 1.9.1, Fev 20, 2004
Failed to open /dev/sonypi: No such file or directory

then following other post say that using smartdimmer should do something, but it don’t seem do something useful

jagobook:/home/jago # smartdimmer -g
SmartDimmer level: 0
jagobook:/home/jago # smartdimmer -i
jagobook:/home/jago # smartdimmer -g
SmartDimmer level: 0

nothing change in brightness

From here: documentation say that I must

	alias char-major-10-250 sonypi
	options sonypi minor=250

that are present inside: /etc/modprobe.d/00-system.conf

then do a # mknod /dev/sonypi c 10 250

I think that command is to create a /dev/sonpi device, it is created but deleted after reboot

jagobook:/usr/share/hal/fdi # sonypid
sonypid: Sony Vaio **** daemon version 1.9.1, Fev 20, 2004
Failed to open /dev/sonypi: No such device

Same issue here, but no answer:

From here:
bugzilla issue ends with nothing, launchpad link broken

I don’t have a path like /usr/share/hal/fdi/information/10freedesktop/30-keymap-module-sony-laptop.fdi, there is no ‘information’ folder, and post end without any final answer.

So I don’t know what else to do.

Trying something like but i don’t know where to find CONFIG_SONYPI

and for this:
I don’t have a /etc/modules path

Following this wiki: I can say that my notebook is a

        Device (SNC)
            Name (_HID, "SNY5001")

But still no luck.

Seems the only solutions is sell my notebook and get a new one more linux compatible.

Thanks for your time =)

Before resorting to this almost-draconian rectification, try adding acpi_backlight=vendor to your kernel boot options on the GRUB menu. If this option resolves your brightness control problem, you may then add it to the /boot/grub/menu.lst entry.

Another option that may help is to add acpi_osi=LINUX to the boot options. I would suggest trying the acpi_backlight option first.

I did not notice your openSUSE release and kernel identifier. I would caution that the above has not been tested (by me, anyway) on pre-oS 11.3 or on kernels prior to 2.6.37.

Thanks for your fast reply, well… don’t work for me =’(, I must type “vendor” as it?? or have to replace for something ??

my laptop is a Sony Vaio VPCEG25FL, i5 nVidia 410m 4GB Ram, and I talk about sell this notebook because I have others issues with this, like bluetooth and wireless.

openSUSE 12.1 x86
uname -a
Linux 3.1.9-1.4-desktop #1 SMP PREEMPT Fri Jan 27 08:55:10 UTC 2012 (efb5ff4) i686 i686 i386 GNU/Linux

Thanks for your time

When you boot, at the GRUB screen, there is a line Options. It most likely contains vga=xxx. After the vga=xxx, enter a space, followed by


exactly as in the code box above, hit enter and continue the boot.

I attempted to lookup “Sony Vaio VPCEG25FL” and only found “Sony Vaio VPCEG25FD”. Did you install openSUSE 12.1 from a liveCD ? If so, does the liveCD (still) properly connect to the wireless adaptor (wlan0) ? Can you connect to the wireless if you disable the bluetooth/bluedevil ?

check if acer_wmi is loaded - this prevented my wireless to function properly on a vaio

How/where to check if exist?, I have to check if it is loaded to work properly? or have to disable it to make work wireless ?

Thanks for your hint lol!

If you specify acpi_backlight=vendor, acer_wmi WILL BE present. You may, of course, verify this by viewing /var/log/boot.msg (using systemv) or searching /var/log/messages for “acer_”.

well… even with acpi_backlight=vender is not entered when booting I have this:

lsmod | grep acer

acer_wmi        27504  0
sparce_keymap   13658 1 acer_wmi
wmi             18744 1 acer_wmi
rfkill          24962 5 acer_wmi, sony_laptop, cfg80211,bluetooth


cat /var/log/messages | grep accer_

acer_wmi: Acer Laptop ACPI-WMI Extras

eleven times…

I had the same problem and it can be solved by having your 50-device.conf (located in /etc/X11/xorg.conf.d/) look as follows:

Section "Device"
  Identifier "Default Device"

    Driver "nvidia"

  Option "RegistryDwords" "EnableBrightnessControl=1"


Since I’ve configured it this way brightness changes as I press Fn+F5-Fn+F6 keys.
Good luck and please let me know if it worked in your case.

YES! that works!, but added to /etc/X11/xorg.conf at “Device Section” only line

Option "RegistryDwords" "EnableBrightnessControl=1"

needed, my previous xorg.conf have others options.

This problem is solved for me. How can I change this thread title with a [SOLVED] tag?

Hope someone can help me with my others posts:


Hi, it’s me again…

I’ve updated to 12.2 and the latest nvidia drivers from proper repository (nvidia-gfxG02-kmp-desktop-304.64_k3.4.6_2.10-21.1.x86_64.rpm), and this problem is back. I’ve trying same things here but no luck, fn keys disappear =’(

When updated nVidia drivers system need to install kernel-desktop-devel packages and installer seems need to compile something, this is my install log, Please take a look to pastebin log file.

nVidia installation log -

Thanks for your reply :slight_smile:

Hi it’s me again, I’ve fixed this issue using a very old nVidia driver (295.75), adding same lines posted before now fn keys work and brightness change with keys and kde battery application, last kernel (3.4.11-2.16.1) from opensuse repository.

Hope this help for someone else :slight_smile:

Hi, I’ve updated to opensuse 12.3 and last kernels update (3.7.10-1.16-desktop) with last nvidia driver 319.17 and this problem still here, but at least backlight keep on. :’) Maybe this link is related:

Hope someone help :slight_smile:

Hi everyone,

Backlight is working on 13.1 !! :smiley: but with nvidia propietary drivers only :frowning:

But there is an issue: when boot and load login window (kdm), backlight doesn’t work, blind I put user password and after that when start user kde session backlight work correctly again. Is there a way to solve it?? In oS12.3 I need to run a command (echo “10” > /sys/class/backlight/acpi_video0/brightness) every time I need to change backlight, and I’m wondering if is possible to run that command when login appear, once kdm keep running.

Thanks in advance.