Brightness keys are note detected


I recently installed opensuse 12.3 in my dell inspiron laptop. The brightness controlls (Fn+F4 and Fn+F5) don’t work, but the other multimedia buttons do (play, volume up/down, mute, etc). Changing the brightness in the settings works fine and also in the command line. I’ve tried to add a keyboard schortcut to run some script to make this task, but when I type this keys nothing happens (but other keys are perfectly detected).

Any ideas?

Thank’s in advance.

This unfortunately is not an uncommon problem. For example of what someone else did, see this thread and this post in particular:

A search of the forum may give you a better hardware match and other possible workarounds to try. :slight_smile:


Thanks for your answer. I tried to modify the grub file, as explained in the link, but it still doesn’t work.

No. not Grub. I pointed you at post #5, about setting hot keys to an xbacklight setting. Did you try that?

Hi. As I told at the beginning, the keys are not detected when I try to make a shorcut.