Brightness Key Suse 12.3 Intel HD

Hi I have a problem, when i press the function key of my laptop does’t change the backlight value of the correct file:

ls /sys/class/backlight/
dell_backlight  intel_backlight

The key change the value of /sys/class/backlight/dell_backlight/brightness and nothing hapen, but when i do somethin like that

echo 2000 > /sys/class/backlight/intel_backlight/brightness

The screen have a change.

How can i configure the key for change the intel_backlight instead of dell_backlight


[HR][/HR]Try addin to GRUB these options “acpi_backlight=vendor acpi_osi=Linux”. It kinda did the trick for me. I mean I can now set the brightness from power management widget but the Fn combinations still don’t work. I have an Acer AO-756 but it’s an universal fix.

Laptop/notebook? What machine? What graphics chipset?

What happens when you enter at comman line (normal user):


If it returns a current setting, you find how to use it with:

xbacklight -- help

It returns a value, can be adjusted by using + and - but still not a replacement for Fn+<key>.

Instead of opening another thread I will post it here.
I have the same problem on an Acer 5755G. in the beginning I could not do anything but I saw the sun icon flashing as I was writing, no difference to brightness. Then I added the GRUB configuration value *acpi_backlight=vendor acpi_osi=Linux *and reloaded the config. The sun icon is showing when I click the buttons but nothing happens.

Doing that

echo 200 > /sys/class/backlight/intel_backlight/brightness

does change the brightness but I need to add a lower value. I believe 967 is the max, 200 is a dimmed display.

I agree but hardly ever use the keys. I use KDE mainly, so I can set a default backlight at System Settings > Power Management. I reduce its 100 percent default “On AC Power” profile, and rarely need to change it after that. In KDE the battery profiles are already set lower by default.

You are a bit luckier than some whose graphics driver and kernel support isn’t working, leaving them without any control on the backlight. :slight_smile:

I do the thing of the grub, i have a :

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)

It’s a DELL N4010

And there’s a way to change the funcion of the function Keys???

Well that’s strange, today after I resumed from standby the keys on brightness work! Without the sun icon, but I don’t really care for that. Magic?? :slight_smile:

Can anybody tell me how to cahnge the value with the Brightness Down Button to affect the intel/brightness value and not the dell/brightness value?

I can confirm that these GRUB options works on my HP ProBook 4740s (Intel HD Graphics 4000). Even Fn keys.:slight_smile:

These options also solves it on HP EliteBook 2570p. Function keys work aswell now.

linux-2y6b:~ # lspci -v -s 00:02.0
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Device 17df
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at d4000000 (64-bit, non-prefetchable) [size=4]
        Memory at c0000000 (64-bit, prefetchable) [size=256]
        I/O ports at 4000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel driver in use: i915


On an Acer Travelmate with Intel HD4000 the backlight works: a) by echoing the values in /sys/class/backlight/intel_backlight/brightness; b) by the applet in the power managment of Gnome/KDE.
This should mean that the video driver is working and the problem should be related to the hotkeys of the keyboard.
On the previous, similar, computer model everything was working well, though … :expressionless:

Hi PiElle,

did you try to upgrade the standard 3.7 kernel to a newer version? In my case it fixed the problem with the brightness keys.
If it doesn’t work for you, add the following kernel parameter to the GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash” line:

acpi_osi=\"!Windows 2012\"

like this:

GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi_osi=\"!Windows 2012\""

Thanks, I know that parameter …
Actually, I’m running Kernel 3.11.
Anyway, I solved the problem blacklisting the acer_wmi module and now everything works well …

Works fine to me too, and function keys now works fine too.

I have a Lenovo yoga I had installed opensuse 12.3 and I have add to GRUB these options “acpi_backlight=vendor acpi_osi=Linux” and it work fine also the fn keys, but I have installed opensuse 13.1 and now it not work.

any advice?

You could try to add a newer kernel …