brightness is 100% after resume from RAM

opensuse 11.1, KDE4-Factory installed from repos. I have always had this problem, even with freshest installation of KDE4-CD opensuse11.1

When i am on battery power, it switches to ‘powersave’ mode. Good. When I suspend to ram, and resume, brightness is 100%. Anyway around this?

More info needed?
laptop = hp/compaq nx7400, intel graphics

Hi,

How do you suspend your laptop? Just with Kpowersave? Or from the
main menu? Have you tried suspend from the terminal? Do you know
if your machine is the s2ram’s whitelist? What is your graphics card?
Can you suspend your machine at the lid close? If it does, can you do it
again after have suspended once?

Bye.

  1. It suspends from powerdevil (kde4 has no kpowersave)
  2. It suspends from kmenu as well. Suspend button hotkeys on laptop do not function in 11.1, but did in 10.3, 11.0
  3. It suspends from terminal
  4. it is in whitelist
  5. graphics card is intel g945 (something similar to that)
  6. It can suspend on lid close
  7. It will suspend again after lid close

There are other ways to reproduce this bug. Close lid when on AC power. Remove AC power. Open lid. Screen is 100% brightness.

Also - when on battery power, allow screensaver to come on, and backlight will turn off. move mouse, screen returns 100% brightness (and still on powersave mode! And still on batteries!). This didn’t occur on previous version of opensuse. It started happening as soon as we got software brightness controls (wasn’t possible on my laptop with older opensuse versions (prior 11.1)).

When moving from AC to battery, brightness slider in powerdevil does not change/move at all but brightness is dimmed (lowered) as long as lid is not closed. If lid is closed will going from AC power to battery, screen brightness is not dimmed.

ps - I get so discouraged with so many bugs that I stop reporting them. Bugzilla people just tag it WONTFIX, or RESOLVED, when the problem is still there. The next version comes out, and an entire new set of bugs is released with it. I do RC testing and report when/where I can, but the volume of bugs (visible to me) is large, and my report often gets unnoticed for several weeks. I’m not sure what else to do. </rant>

Hi,

My laptop has Intel graphics card too (mine is GM 965). There are really many bugs with these graphics cards, and I suspect your problem is related to some bug of it.

My laptop does not suspend now that it has installed openSUSE 11.1, but it used to do when I had openSUSE 11.0. I though your problem could be the same of mine, but it is not. But, maybe the solution is the same. In 11.0, I used to suspend once on lid close, but after that the lid close used to cause nothing, only if I restarted the machine.

I solved this problem by adding the option “-p” when executing s2ram. So, if you have not tried this yet, it may be a workround for your problem. In Suspend to RAM - openSUSE page, you can find the common options that make suspend work fine with Intel cards.

Once you know what options of s2ram solve your problem, edit the pmutils options to make them available at the buttons in powerdevil, lid close etc.

I hope had helped.

Bye.

That’s just another bug from Intel Card driver.
I’m sick of them too, but still continue reporting
bugs, hoping someday it will be nice and stable.
And everyone will be happy.

Brightness bug seems to be fixed for me with this repository
(I use Intel GM965, but it can be the same for 945):
Index of /repositories/X11:/XOrg/openSUSE_11.1 .

Though with these newer packages, I get UGLY artifacts
in various programs from time to time, which hinder my work and annoy me,
even If I don’t use any 3D-acceleration or compositing.

So you can choose ugly artifacts or brightness bug.

Hi guys,

There are new drivers for Intel graphics cards available at Intel Linux Graphics.
These drivers where released in
April 15 of 2009, but they are still not available in the official
stable packages of Xorg. Maybe they are being tested int he
unstable packages of Index of /repositories/X11:/XOrg/openSUSE_11.1,
but I am not sure.

Anyway, reading the site Intel Linux Graphics, I have
realized that these drivers can be installed in our system, I mean,
they do not need to be available in Xorg packages to get
running in our system. Unfortunately, I am afraid of getting may
system massed up if try install these drivers, not because I think
they are not going to work, but because I am new to Linux and
probably could make some mistake when trying install them.

So, if some Linux expert want give a try, it could be a good idea.
For me, I would like just to have a step by step explanation of the
installation and know if the install fixes the bugs as promised in
Intel Linux Graphics.

Bye.

Hmm, if you don’t want to test KMS/UXA etc,
but just try newer drivers with default kernel:
add XOrg repository and update XOrg packages.
If you don’t like the changes, delete XOrg repository ,
downgrade to default packages.
Pretty simple.