Brightness doesn't change on openSUSE 13.1, Nvidia quadro.

Hi all,
I come from years and years of Ubuntu, and I installed openSUSE 13.1 about a month ago.
I really like it and I want to use it as my main distribution, but I can’t find a solution for the backlight which does’t change.

  • On Ubuntu backlight variation is working, both with keys and settings slider.
  • I’m using an HP elitebook 8560w, Nvidia Quadro 2000m.

I can’t change the brightness level neither with keys or settings slider.
Also when I try to change the values of /


the backlight doesn’t change.
I also tried some of the boot options you can find over internet, but again no success.

Interesting thing:
If I set the brightness during the bios boot phase, openSUSE mantains that value. If I close the LCD panel and let the PC go to sleep, it will wake up at maximum brightness value.

It’s about a month I try to figure out a solution, can you please help me in some ways?

thank you,


cat /sys/class/backlight/acpi_video0/

This will show you what controls the brightness i.e. intel, nvidia.

To enable brightness:

Add the following entry to the end of the GRUB_CMDLINE_LINUX variable in the /etc/default/grub file.

acpi_backlight=vendor acpi_osi=linux

Run as root:

grub2-mkconfig -o /boot/grub2/grub.cfg

Restart your laptop to review the brightness.

Install the Nvidia drivers provided by the Yast Control Center. Choose Software Repositories.

  • Click on the Add button -->Select Community Repositories
  • Click on the Next button
  • From the list select nVidia Graphics Drivers
  • Start Yast Software Management and the G03 drivers

You also try using xbacklight. If you do not have it installed use zypper to install:

zypper in xbacklight

xbacklight --help**
usage: xbacklight [options]
where options are:

  • -display or -d
  • -help
  • -set or =
  • -inc or +
  • -dec or -
  • -get
  • -time
  •  -steps <number of steps in fade> 

To increase:

xbacklight -inc 10

To decrease:

xbacklight -dec 10

If the problem still exists despite the grub entries and xbacklight there could be an ACPI bug with HP Elitebook 8560w and the present kernel.
Try the kernel 3.12x by adding this repository and updating the kernel: your laptop after updating the kernel.

Thank you very much for the help, I first included the parameters in the grub configuration file, and something happended, the brightness partially worked (a dimming of about +/- 10%).
So I tried installing the nvidia drivers, and now brightness controls are completely gone: no slider in settings and no control with keys.

Should I go with the kernel upgrade?

thank you, Silvio

I just tried to remove the grub options and now I have brightness controls again, unfortunately they’re not working.

It’s funny that changing the slider or using fn keys I can see the values of


change, but with no effect. :frowning:

Ok I tried to update the kernel, and got an “oh no, something went wrong” screen. I solverd uninstalling and reinstalling the nvidia drivers.

Unfortunately, I still can’t control the brightness.
Even in this case, if I add the suggested parameters to the grub configuration file, the PC boots with no backlight interface (no slider in settings, no fn keys, no files in /sys/class/backlight).

Any idea for solving this? I’m trying all my best but I’m kinda like a noob…

I just noticed that the backlight service is active but disabled:](

If I try to enable the service, I get this error:](

The “oh no, something went wrong” message was do to the fact that the nVidia driver rpms provided for openSUSE. They are only compiled for the stock kernel and future updates provided for openSUSE 13.1.

Did you in install install the nVidia drivers provided by the Community Repositories in Yast or did you download and install the driver from the nVidia site?
Which driver version are you using? Are you using x86_64?

I would like you to install the following packages in Yast in case you may need to install the nVidia driver from the nVidia website…

Please select and install the following files from the Yast2 Package search field.

gcc make patch kernel source kernel-syms

When searching for the kernel source in the search field, type “kernel-s” (without the quotes) to find kernel source and kernel-syms packages. They will pull in additional files for installation.

In the meantime we’ll see how the stock kernel will perform with the code below.
To enable the the brightness for the nVidia card add the following code to /etc/X11/xorg.conf.d/50-device.conf

Section "Device"
  Identifier "Default Device"
  Driver "nvidia"
  VendorName "NVIDIA Corporation"
  Option  "RegistryDwords" "EnableBrightnessControl=1"

Shutdown and restart your laptop. Check out the brightness by ensuring that the command in the two screenshots has been enabled and started.

Thank you very much Romanator, unfortunately the backlight control still doesn’t work.

I’m trying every combination but the problem still persist, here my actual configuration:

  • kernel 3.12
  • nvidia drivers (issues solved, thank you)
  • device added in /etc/X11/xorg.conf.d/50-device.conf
  • no additional parameters in GRUB (if I add the suggested options the backlight controls completely disappear)
  • process system-backlight@acpi_video0 is active but disabled, no way to enable it (I don’t know if there are other ways, actually…)
  • xbacklight gives me no output with --get or --set

Looks like this problem exists all over the Internet with the HP 8460p laptop with every Linux distro.

It appears that previous patches for the hp-wmi have broken the brightness keys mapped in the kernel for a number of HP laptops.
I would sign up with Bugzilla and submit a bug report marked “critical” for “brightness keys broken to control brightness with Nvidia Quadro 2000m” in the Linux kernel.

Follow Up

None of the keys work including xbacklight due to keys not being recognized.
Have you tried kernel v3.13? Here’s the repository

You’ll have to reinstall the nVidia driver.

Please add your Nvidia Quadro 2000m graphics card to the openSUSE Nvidia wiki.

Thank you

I’m sorry for the long delay, I tried to upgrade to 3.13 kernel and new nvidia drivers and I messed up everything, I was not more able to start xserver. As I said, I’m not that good with linux, I’m a noob.
So here I am with a new fresh install, I opened as suggested a bug for the brightness.

It’s time to create a solid backup and then try again with the 3.13 kernel.

Thank you

The nvidia drivers don’t work yet with Kernel 3.13 AFAIK. And I have no idea whether a patch is available somewhere or not.

So either don’t use Kernel 3.13 (3.12 should be ok though), or don’t install the nvidia driver and stick to nouveau.

You may also want to try the latest 3.11.10 kernel from here:

I found a patch, I cannot guarantee you that it works though:

No. Don’t use 1.2 - a newer 1.3 patch has been provided with better results so that you can apply CUDA:

This works for compiling 331.38 NVIDIA driver. For both kernel module and uvm module. This was tested by a number of users on the Factory Mail List.