Brightness control problem (openSUSE 12.3, Lenovo G560a)

Ok, I’m back to nouveau and I don’t want to change this. I’m not much of a gamer and I think nouveau can handle very well whatever else i do with this laptop.
In the meantime I noticed that the power management does not work at all when I start the computer.

  1. laptop starts with power adapter plugged - the power manager correctly determines that it is plugged and charging.
  2. unplug power adapter => power manager says it’s plugged in but discharging!
  3. plug back in => plugged in, charging
    Again, after a sleep-resume it magically works!

After all, it seems to me nvidia/nouveau have nothing to do with this.


I made some more test with different kernel versions (vanila 3.7 kernel, 3.8 kernel). Also changing to these kernel versions did not bring changing brightness back :’( (I can move the brightness controller in the power management, but nothing happens). Also xbacklight is showing only 100% and a change with e.g. xbacklight -set 50 is not possible.
Strange. This is the first openSUSE version where I had a problem with the screen brightness (and I used many versions on many different notebooks ;)).


I found, that adding the kernel parameter

acpi_osi="!Windows 2012"

would bring back the backlight adjustment in kernel 3.7.

Unfortunately, I can’t add this parameter using Yast. When writing the bootloader, it shows an error message.

Has somebody tried this parameter?


Did you try to manually add it to:


and then run:

grub2-mkconfig -o /boot/grub2/grub.cfg

? :expressionless:

I tried

acpi_osi=\"!Windows 2012\"

Note that I used escape character . grub2-mkconfig and YaST2 (which uses of course grub2-mkconfig) successfully generated grub.cfg with the escape characters.
For me it didn’t change anything. I’m curious if it works for others.

With the
acpi_osi="!Windows 2012"
instead of
acpi_osi="!Windows 2012"
it works rotfl!!
I can directly add this bootparameter in yast (bootloader).

Changing brightness is working again.
Brightness is controlled by power managment. Brightness can be changed with the slider in power management. Brightness can be changed with Fn+F5/F6!


Very interesting.
How did you know this new sort of string?
I’ve installed openSUSE 12.3 on an Acer notebook equipped with a Nvidia card.
After installing the latest driver (the hard way), backlight works perfectly, even without adding any string in the conf file (is the first time it happens …).
Any way, I’m glad you were able to solve the problem … lol!

Lucky you that it works!

(I assume you don’t know any C even if it may not be the case)
The “new type of string” is not that new. I do quite a lot of C programming and when you want to write a quote in a quote, the thing(compiler) that interprets the text(code) you write has to know where the string you opened with the first quote ends. So in C you use (so called) escape characters like \ to quote in quote.

My parameters list like

GRUB_CMDLINE_LINUX_DEFAULT=**"**resume=/dev/disk/by-id/ata-HITACHI_... acpi_osi=Linux acpi_backlight=vendor  splash=silent quiet showopts**"**

in /etc/default/grub, so they are within quotes. I assumed the developers of grub2 implemented the same escape mechanism as in C since Linux kernel and drivers and lots of low-level stuff is written in C.

To put i simple, it’s the same mechanism we use in normal writing when we say
“He shouted ‘I saw you!’.” to quote in quote… At least I think that’s the standard way in english (I’m not a native speaker)

I’m still waiting for a fix in my case but I’m glad it did the trick for you :wink:

I found the info about this new kernel parameter on following website:


Hi, I have this problem in my Sony VAIO VPCEG25FL, something very similar, look this:

My initial condition using nvidia drivers from repo is that it disable laptop backlight. When I say “disable” means that there is no light from lcd panel, but if you pay attention in the screen appear kde desktop in monochrome pixels, like black&white old pads and without light.

So doing a

echo "1" > /sys/class/backlight/acpi_video0/bl_power

get backlight on again, but if I press fn+f5 or fn+f6 it disappear again, so doing the same command it activate again, even with a “0” value. Using

echo "15" > /sys/class/backlight/acpi_video0/brightness

where “15” can be from “1” to “15” it change correctly backlight bright, it take a time, as 2 seconds, to change bright, but it does, and keys fn+f5,fn+f6 appear slider and change in 10 steps from left to right (as you see mine have 15) but there is no brightness change.

When I add lines inside /etc/X11/xorg.conf.d/50-device.conf at least problem of “poweroff” backlight disappear, but still can’t control brightness using fn keys, power management neither. Adding acpi_backlight=vendor acpi_osi=linux acpi_osi="!Windows 2012" doesn’t help.

So, I’ve downloaded beta drivers from nvidia ( and want to install if this solve the problem, but I have this message from /var/log/nvidia-installer.log

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Mar 21 04:16:01 2013
installer version: 313.09

PATH: /usr/lib64/mpi/gcc/openmpi/bin:/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games

nvidia-installer command line:

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 313.09.
-> Running distribution scripts
   executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/3.7.10-1.1-desktop/source'
-> Kernel output path: '/lib/modules/3.7.10-1.1-desktop/build'
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at

So doing an internet search I need to add base development, kernel development and c/c++ development in my package manager using Patterns, rebooted to run level 3, and when executing driver installer, have this error again.

How did you install driver? there is something else to do?

Thanks in advance

I didn’t have that kind of problem. I just did a logout, then CTRL+ALT+F1, log in as root and type ‘init 3’ which kills(I think) the X server. The I ran the script and it worked fine for me. If it doesn’t work for you, you may want to open a new thread. People will much more likely help you if you open a thread than if you stick with it here.

SDB:NVIDIA the hard way - openSUSE :slight_smile:

Thanks… but exactly is not enough, my problem is solved using this:

Now I have running 3.7.10-1.1-desktop kernel and nVidia driver 310.19 (both x86_64 version) but still have the same problem: can’t control brightness using fn keys and power slider. When I press fn+f5 (less bright) appear kde slider and start to move left as expected, but backlight doesn’t change, same thing with fn+f6 (more bright) and power slider.

The only thing that I can use is command line as root echo “11” > /sys/class/backlight/acpi_video0/brightness

So I’m still wondering what else to do

As you have a lot of experience with Lenovo laptops. Have you ever experienced a black scren when coming from sleep or hibernate on SuSE 12.3?

Me to, I have problems with hibernation. I click the button, the system logs out and I see for like 3 seconds a blue progress bar at the bottom of the screen. Then the screen is black but flickers at something like 1 second intervals. It does so without getting to an end so I long-press the power button to shutdown the computer. When it restarts it bypasses grub(as I guess it should).

Thanks, but doesn’t work for me.
I have to say that my laptop is a Sony Vaio model VPCEG25FL , not lenovo, but seems same issue.
Maybe offtopic: are kernel|drivers|whatever maintainers aware of forum when reporting problems ?

Hope someone have tips for this. Thanks in advance.

It’s an interesting question, especially regarding this thread and its perennial problem. The fact is that very few developers/maintainers actively attend the forum. Some may watch for relevant threads (lurking), but who knows without any evidence :. They expect bug reports filed on openSUSE’s bugzilla (see Wiki for details on how to use it), and most of them will probably go upstream from there.

Upstream kernel drivers and ACPI have struggled to keep up with so many new different laptop/notebook (BIOS levels, etc) implementations of backlight and special function keys. It’s even a problem for newer models within a single manufacturer wrt linux support e.g. lenovo and ThinkPads. :expressionless:

Hope more people write documentation