Brightness control problem (openSUSE 12.3, Lenovo G560a)


I just installed the fantastic 12.3 release of openSUSE. It’ll definetely become my workstation.
However, there is this problem with brightness control: the brightness does not change no matter if i try to change it using Fn+Left (lower brightness) or Fn+Right (higher) or try to change it from battery settings on the main panel. I should add that during the boot sequence it works. It stops working at the end of KDE Splash (you know - the animation after the login).

I added “acpi_backlight=vendor” “acpi_osi=linux” as boot parameters in YaST2 Bootloader Options as suggested in some threads here, but it doesn’t work either.
Also, I used a lot of distros before, even now i have a Kubuntu 12.10 in dual-boot on which brightness changing works well. So I don’t think it’s a kernel problem, or incorrect BIOS settings problem.

One last thing, I have an NVIDIA graphic card and I use the proprietary driver. I modified /etc/X11/xorg.conf.d/50-device.conf and added the following (it contained just commentaries before):

Section "Device"
   Identifier "Default Device"
   Driver "nvidia"
   Option "RegistryDwords" "EnableBrightnessControl=1"
   Option "NoLogo" "true"

Any ideas?

I noticed something interesting: if I put the computer to sleep, after waking up the brightness control just works! I tested it twice by restarting the computer: at KDE Splash the control stopped working, the put it to sleep, then wakeup and voila!

Also, just a little detail the control is done with Fn+Up,Down not Left,Right as i stated in the first post. But it’s not relevant…

Hi, I don’t know why it doesn’t work, but are you saying that the other distros, e,g. kubuntu have exactly the same kernel level and KDE release? :slight_smile:

Have a look here:
It expecially deals with Lenovo hardware (Thinkpads) …

A useful link anyway, and the OP should read it. However, thinkpad_acpi module (used on my system) is for ThinkPads, but I believe the Lenovo G series are not ThinkPads. :slight_smile:

Indeed, my laptop is not a Thinkpad, it’s from the Ideapad series.

Kubuntu 12.10 kernel is 3.5.0-25 while openSUSE 12.3 kernel is 3.7.10-1. As for KDE, on both is 4.10.

Regarding the kernel versions, I installed openSUSE on a partition where i had Manjaro Linux (which I think used 3.7.something kernel) and brightness worked on that one.

Another interesting fact I discovered is that if I wake computer from sleep, brightness control works only when modified via keyboard shortcuts (Fn+Up, Fn+Down) and not from the battery settings on the main panel.

Another clue: I restarted the computer, neither the key combination nor the battery slider did not change the brightness (as expected) and i typed

echo 9 > /sys/class/backlight/acpi_video0/brightness

That changed the brightness from 100% to 90% (There are only 10 levels of brightness).

Did you try entering xbacklight at a command line (normal user)?

yes, i tried xbacklight and it doesn’t change anything
i think it was something like

xbacklight -set 50

for 50%

It seems to have something to to with Nvidia proprietary driver. I tried to switch back to nouveau but i messed up everything and the quickest way to get back to a functional desktop was to do a complete reinstall. Now, with nouveau, the shortcuts don’t work but the battery menu slider does work. I might try to see how do I get along with nouveau but I would like a real solution to the issue.

Ok, thank you for all your feedback. It seems you are making some progress in the right area. Keep going. :slight_smile:

Did you try to install the latest driver the “hard way”? :\

Ok, I installed Nvidia driver “the hard way”. Now the booting screen has a wrong resolution up until the nvidia module is loaded i guess, which I don’t remember to be the case for the driver from repositories.
The brightness controls don’t work except for manually modifying /sys/class/backlight/acpi_video0/brightness, just as with the repo driver.

Did you insert the string

Option       "RegistryDwords" "EnableBrightnessControl=1"

in the “Device” section of the xorg.conf file? :expressionless:

Yes, I did.

There is also this thread in which the user andreadi says resuming from sleep results in working keys. They might be related.


I can add some experiences with the brightness control in 12.3 on an ASUS UX31A (Intel HD4000 card).
In 12.2. brightness control worked with the power management, the brightness keys did not work (FN+F5/F6) but it was possible to configure other keys (see also:

In 12.3. either brightness control by power management nor by keys is working. This is really bad, because also on battery the machine runs on 100% brightnes. Adding the kernel parameter did not change anything.


I’m running:

  1. Fedora 18 on a Thinkpad Edge E330 with intel HD 4000 and it works right out of the box;
  2. openSUSE 12.2 on an Acer 8573TG vith Nvidia GT 540M and it works with the Nvidia driver and the optional string in the xorg.conf file;
  3. openSUSE 12.2 on a Sony Vaio and it works the same as n. 2);
  4. openSUSE 12.3 on the above Acer 8573TG: fn keys for brightness do not work, running the Nouveau driver (i’m going to install the Nvidia driver as soon as possible).
    To adjust brightness in Linux can be tricky. One has to buy Linux friendly hardware. :slight_smile:
    May be Thinkpads are the best. :expressionless:
    Any way, I never had problems with Acer Travelmate equipped with Nvidia cards …

Yes, and most expensive: :slight_smile: