Brightness adjustment hotkeys not supported?

On Windows and Ubuntu, I can use Fn+F9 and Fn+F10 to lower or raise my screen brightness. This is a laptop-specific hotkey as far as I know.

openSUSE doesn’t respond to these hotkeys. Despite that, I am able to adjust the screen brightness in KDE’s power settings. Do I have to configure the hotkeys manually or something? Oddly enough, the laptop-specific volume hotkeys do work.

I wonder if the answer is in the question. KDE uses the brightness for its own purposes, eg. dimming windows that are not in focus - so you may have to rely on KDE. However, for most KDE functions, you can configure a hotkey.

Are you suggesting that it might be a KDE issue? I’ll try it under GNOME asap.

I have also examined the Power Settings applet. Unfortunately I don’t see any configurable hotkeys.

Nah, not a KDE issue, rather a wrong keyboard choice in KDE’s systemsettings. What’s the brand of the laptop, what’s the video card?

I’ve uploaded my entire configuration here:

Laptop: HP ProBook 6550b
Video: ATI Technologies Inc M93 [Mobility Radeon HD 4500 Series] Integrated Telecom Express Inc

The videocard needs the ATI driver.
In Systemsettings - Input Devices - Keyboard, there’s a lot of keyboard models, also for HP’s. One of them might bring full usage of your laptop’s one.

On my laptop I need the asus-laptop model, otherwise the extra keys don’t work properly, i.e. some do, some don’t.

I’m not sure if I’m looking at the right applet right now, because I can’t change the keyboard model.

Is this the correct driver?

Install ATi driver for HD 2000-series and newer.

This is not a simple matter of comparison.

I assume, as on my lenovo notebook, your HP came with Windows and everything pretty much worked OOTB. With openSUSE many features worked OOTB on mine, but not all. Very few of my Fn+F1-12 key functions work. However, brightness adjustment works correctly as labelled on Fn+Delete and Fn+Home. This is using 11.3 with distributed desktop kernel (+updates), and now the built-in speaker mute button works correctly with its backlight on when mute. However, I read an open Ubuntu bug report against my lenovo model with various users claiming a regression from Lucid to Maverick for a few function keys/buttons that now don’t work. Of course, that involves a newer kernel. For mine (now a year old), its further complicated because it has a different firmware/bios to other ThinkPad models that can use the special thinkpad_acpi kernel module. That module will not load, so there is no workaround for the Ubuntu problem, nor a solution for openSUSE in the very near future.

In the absence of a h/w specific ACPI kernel module, the special laptop functions, keys, and buttons rely on generic ACPI modules and the kernel, that also needs to interface with the laptops firmware/BIOS data. Brightness control is a known issue for ACPI support of various laptop models, and a complete rewrite is likely.

If that ACPI support fails your laptop, I assume KDE (or Gnome) settings will also fail.

Brightness control is a known issue for ACPI support of various laptop models, and a complete rewrite is likely.

See this generic acpi bugzilla report: ACPI video backlight control doesn’t work – need backlight manager, representing a “gathering of all the bugs that ACPI backlight control is broken”.

@pdedecker: I saw that screen to when I switched to “tree view”. Switch to the “icon view” and try again.

That doesn’t seem to change what’s displayed in the applets.

I just tried installing the ATI driver by following the instructions on the wiki. (“Install ATi driver for HD 2000-series and newer.”)

Sadly, after rebooting the X server seems to have trouble starting. I tried switching to tty1-tty7 using Ctrl+Alt+F1, …, Ctrl+Alt+F7 but the screen remained black. So then I tried uninstalling the driver, but that didn’t help. How do I revert to my last working X configuration? I can still boot into failsafe and log in to KDE.

My video card has been identified by Smolt as “M93 [Mobility Radeon HD 4500 Series]”.

If /etc/X11/xorg.conf has been created by the ATI installer, remove it. Then restart the X-server.

Merely removing /etc/X11/xorg.conf didn’t work. (It would have been cool if you could just delete the configuration and have X magically fix itself by reverting to default settings though.)

I did find a file called xorg.conf.install which, I assume, is a copy of the version of xorg.conf that was created during install. I cp’ed that to xorg.conf and now the graphical interface will boot again. What should I do with the driver? My system apparently works better without the proprietary(?) ATI driver or I picked the wrong one. Should I stick with the generic driver?

Here’s the guide on ATI: SDB:ATI drivers - openSUSE

Well, you know the rule: “If it works, don’t fix it”.

I’m getting word in the KDE forums that brightness adjustment hotkeys have been added in KDE 4.5. Zypper reports that I’m running version 4.4.4-1.5 if I’m not mistaken.

pdedecker@linux-s6cn:~> zypper info kdebase4
Loading repository data…
Reading installed packages…

Information for package kdebase4:

Repository: @System
Name: kdebase4
Version: 4.4.4-1.5
Arch: x86_64
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 508.0 KiB
Summary: The Base KDE Apps
This package contains the basic applications for a K Desktop
Environment workspace.

As far as I know, I have two options at this point. I can wait for the openSUSE guys to roll out KDE 4.5 through the updater or I can risk bricking my KDE install by looking for a homebrew repository that offers KDE 4.5. Is there an expected rollout date for the 4.5 update?

Uh oh… out of nowhere, I can only use 1024x768 at 76Hz. hwinfo says:

72: None 00.0: 10000 Monitor
[Created at fb.71]
Unique ID: rdCR.EY_qmtb9YY0
Hardware Class: monitor
Model: “Generic Monitor”
Vendor: “Generic”
Device: “Monitor”
Resolution: 1024x768@76Hz
Driver Info #0:
Max. Resolution: 1024x768
Vert. Sync Range: 50-90 Hz
Hor. Sync Range: 31-61 kHz
Config Status: cfg=new, avail=yes, need=no, active=unknown

Can I let YaST redetect my monitor?

That’s interesting, since I have brightness adjustment keys working on both KDE 4.4.4 and KDE 4.5.4 on my notebook. I noticed one difference, on 4.5.4 I also get a scale indicator of the brightness level displayed on the desktop, on 4.4.4 that doesn’t appear.