Bridge starts - but without WLAN?


I have created a bridge using the YaST2 GUI on a new 11.4 system. The bridge (br0) has a number of Ethernet ports (ethx) and a wireless port (wlan0).
On reboot the bridge is there and the ethx ports are registered and work (using brctl show).
However the wlan0 port is not there? If I add it (brctl addif br0 wlan0) it registers and works - until the next reboot of course.

I am sure that I have done just this on previous builds - maybe this is a faster machine and the wireless lan card is not ready in time to add to the bridge?

Question: Where are the scripts that create the bridge at startup?
How can I check that the necessary components are ready at the right run level?

Regards, Martin

Problem solved. I was using the wrong version of hostapd. Dho…!

I’d still like to know: where/how the bridge is started during the boot sequence, though.

Regards, Martin

I am looking to do the same thing. Never tried this before. I would like to chat with you about your experience.

I have a netbook with working wifi an eth with no modifications needed after install of OS11.4 64 bit. Its also dual boots to SLES 11 32bit, but has no wifi with out Kernel changes.

You said you you were using the wrong version of hostapd. Can you please elaborate?


No problems. I’ll be glad to help where I can. However, I’m no expert, but just ask away…

I have a netbook with working wifi an eth with no modifications needed after install of OS11.4 64 bit. Its also dual boots to SLES 11 32bit, but has no wifi with out Kernel changes.
11.4 64 bit here too.

You said you you were using the wrong version of hostapd. Can you please elaborate?
Yes, the version that comes packaged with SuSE 11.4 (and I had installed) is hostapd 0.6.10. And that was my mistake. The only version that I have ever got working is 0.7.3. However, that required me to learn how to compile it from source code. Not an easy task for me, but I plugged away at it and once I got it right, it seemed that it wasn’t so bad.
Problem is, documenting what I did! Three months down the line and its whole new ball game again. Ho hum…

Regards, Martin

Hey, thanks alot. So my box has a NL80211 wifi card. I tried installing 0.7.3 with no luck in what short time I had. I did install 0.6.10 which properly laid out all the config files an such in the proper directories. Do you know what the differences were between the 2 versions that may have contributed to the success?

Do you know of any patches to add the driver functionality to 0.6.10?

How can I confirm which drivers are loaded? I am under the impression I am running ath9k (nl80211/mac80211). In your searching, does this sound correct?

John Moore

I probably should further explain that after I broke my box playing with hostap 0.7.3 & 0.6.10, I did a complete rebuild an am starting with a fresh install of hostap 0.6.10 from SuSE repository’s.

An my netbook is running a ath9k card


Hi John,

Okay, lets see if I can cover these points? Firstly, as depressing as as it seems at the time, starting with a fresh install is not a bad idea.
In these games, we all take dead-ends and non-working experiments, which never get undone and will always come back to bite you sooner or later.

So, the first thing I would do is to uninstall hostapd 0.610, using the YaST contol panel. This will probably leave an /etc/hostaps.conf.rpmsave behind. We can use it later.
Next, get yourself the source code for 0.7.3 from here and compile it. Be aware that the makefile installs the executable in /usr/local/bin and not in /use/sbin as the 0.610 package does.

Test with **hostapd -v **in a command shell to test that there is nothing hanging about down the path. Then **/usr/local/bin/hostapd -v **to check that you see v0.7.3 ready and waiting to be used.

I think that we’ll leave the hostapd.conf until the above is done?

As to drivers. I’d suggest this, to provide the confidence you are looking for.
Run into the YaST control panel, then Hardware then, Hardware Information. Scan down to find your wireless LAN. Expand it and check the driver listed. I’d guess that it’ll say ath9k.
Then if you want the whole nitty-gritty, from a command prompt, type modinfo ath9k. Just to list a snippet from mine, it says for
“vermagic: SMP preenpt mod_unload modversions”

Call back when your ready for the next step.

Regards, Martin

Back again. I missed the 10 min edit window - so adding this addendum. Hope you read it before wasting too much time?

When you come compile the 0.7.3 code, before you can run make, you will need to copy defconfig (in the unpacked download) to .config.
Then un-REM the “CONFIG_DRIVER_NL80211=y” line (around line 16).


Well, I just got your message after a success. I was able to install hostapd 0.6.10 from yast, made 2 required changes. An away it went. No problems. Wide open AP. I just configured MAC address filtering an bumped to wifi-g. I will start configuring WEP/WAP. I am kinda thinking of setting up a RADIUS server an playing with that next.

It appears that prior to starting hostapd, I had to goto the network device module in yast an configure both devices as a bridge (br0) which is the default for hostapd to look for when using nl80211 drivers. As since br0 is a static device now, it shows up after reboot.

I created a start script named after the box, an copied to /ect/rc.d/. Loaded runlevel an enabled the script to run on init 3 & 5.

CODE modified from a script provided on this site.


Script to start/stop a hostapd-based access point

Symbols for needed programs


case “$1” in
echo “Starting AP”
# Stop any existing hostapd and dhcpd daemons
killproc hostapd
# Bring up hostapd
echo “Stopping AP”
# Stop hostapd daemons
killproc hostapd
echo “Usage: $0 {start|stop}”
exit 1

Thanks for all your help.