Breaks in sound output on all media players !

I installed OpenSuse 11.1 recently and audio was working fine until yesterday. I went to pulse audio preferences and in the speakers tab chose ‘stereo’ instead of blank. Since then all audio applications play audio with breaks inbetween.

What surprises me, is that when i play a video file with vlc for example, i go to audio - choose mono instead of stereo and then bring the option back to stereo … and audio plays fine (without breaks). I use GNOME.

How do i fix this or how do i blank my pulse audio preferences in speakers tab once again ?

If you know what you did to cause this, can you not put things back the way they were before?

Pulse audio has problems. It is still relatively immature. You could take a look here: SDB:AudioTroubleshooting - openSUSE - pulse audio problems to see if any of the guidance there helps.

Problem is i am not able to blank out the dropdown value any more. I have to select one among mono, stereo, 2.1, 3.1, etc. Already tried my hand at that.

I tried the help from the troubleshooting link that you gave but it didn’t work.