Brand new here - just installed 11.2 ms 8

I just installed 11.2 milestone 8 with KDE on a Thinkpad T61p. I am amazed at the great installation experience and the fact that my hardware works out of the box! Great stuff.

Now I want to tweak my Trackpoint settings. I want the pointer speed to be faster and the movement more sensitive. And I want to get middle button scrolling in Firefox to work better.

I also want to enable desktop effects. (My laptop has an NVidia 570M card.)

Where should I look for help on these issues? Thanks.

System Settings - Keyboard and Mouse - Mouse

Graphics is a bigger issue. I’m not sure about your GPU 570M

You could just try going to the System Settings - Desktop - Desktop Effects and Enable (This is for KDE, Gnome might be different)

You may need to go to Yast - Hardware - Graphics and Monitor
See if the 3D check box is ticked.

Open a terminal and do:

cat /etc/X11/xorg.conf

Post that and we will know some more

Thank you for your reply.

The Trackpoint settings (e.g. sensitivity, inertia, etc.) are not there. The pointer acceleration is the only option available there and it has little or no effect on the trackpoint.

Previously I set these Trackpoint values via text files under locations such as

/sys/devices/platform/i8042/

The specific location seems to be distro and device dependent and I’m not sure how one determines where to put these files.

I could experiment, but I’d rather know the right way to do this in OpenSUSE.

In Yast, under Hardware I do not have “Graphics and Monitor”. It shows everything else, including my Fingerprint reader, infrared and even lists TV Card. But no “Graphics and Monitor”.

I thought all the mouse and input stuff had been moved to evdev in the latest X org… I’m coming here from Ubuntu and I was a bit of a newbie on Ubuntu still, so now I’m back to feeling like a real newbie again.

myuser@linux-t9jd:~> cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory

I poked around and found this file:


cat /etc/X11/xorg.conf.install 
Section "Device"                                          
  Identifier "vboxvideo"                                  
  Driver  "vboxvideo"                                     
EndSection                                                

Section "Screen"
  Identifier "vboxvideo"
  Device "vboxvideo"    
EndSection              


Section "Device"
  Identifier "vmware"
  Driver  "vmware"   
EndSection           

Section "Screen"
  Identifier "vmware"
  Device "vmware"    
EndSection           


Section "Device"
  Identifier "cirrus"
  Driver  "cirrus"   
EndSection           
Section "Screen"
  Identifier "cirrus"
  Device "cirrus"
EndSection


Section "Device"
  Identifier "fbdev"
  Driver  "fbdev"
EndSection
Section "Screen"
  Identifier "fbdev"
  Device "fbdev"
EndSection


Section "Device"
  Identifier "vesa"
  Driver  "vesa"
EndSection

Section "Screen"
  Identifier "vesa"
  Device "vesa"
EndSection


Section "ServerLayout"
  Identifier "Layout"
  Screen  "vboxvideo"
  Screen  "vmware"
  Screen  "cirrus"
  Screen  "fbdev"
  Screen  "vesa"
EndSection


You must have done something wrong. Try again.

**cat /etc/X11/xorg.conf
**
Are you using gnome or kde4? Just so I know where to send you. I’m really a kde user.

BTW, here is a working X.org.conf that I used on this same hardware with a prior version of Ubuntu (8.04 I think). My hardware is still the same.

Can I use these same settings now on KDE/OpenSUSE 11.2?

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ExplorerPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "on"
        Option          "EmulateWheel"          "on"
        Option          "EmulateWheelTimeOut"   "200"
        Option          "Emulate3TimeOut"       "50"
        Option          "EmulateWheelButton"    "2"
        Option      "YAxisMapping"        "4 5"
        Option      "XAxisMapping"        "6 7"

EndSection

Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option          "HorizScrollDelta"      "1"
EndSection


Section "Device"
	Identifier	"nVidia Corporation G80 [Quadro FX 570M]"
	Driver		"nvidia"
	Busid		"PCI:1:0:0"
	# (WW) NVIDIA(0): Option "AddARGBVisuals" is not used
	# Option	"AddARGBVisuals"	"True"
	Option		"AddARGBGLXVisuals"	"True"
	Option		"NoLogo"	"True"
	Option          "NvAGP" "1" #I changed this see https://help.ubuntu.com/community/NvidiaLaptopBinaryDriverSuspend
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	Horizsync	28-96
	Vertrefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation G80 [Quadro FX 570M]"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Modes		"1920x1200"
	EndSubSection #https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/34043
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse" 
	
	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection
Section "Module"
	Load		"glx"
EndSection

and here are my previous Trackpoint settings:

#trackpoint configuration
devices/platform/i8042/serio1/serio2/speed=175
devices/platform/i8042/serio1/serio2/sensitivity=160
devices/platform/i8042/serio1/serio2/inertia=10

Maybe I’ll try the exact same thing with OpenSUSE…

I’m using KDE.

I didn’t do anything wrong with the cat. Here’s proof:

ls /etc/X11/
fs         qtrc         xdm    xinit           xorg.conf.install
lbxproxy   rstart       xim    Xmodmap         Xresources
proxymngr  x11perfcomp  xim.d  Xmodmap.remote  xsm

Logout and do a console login and switch to su and do:
sax2 -r

Comparing those two xorg.conf files (Ubuntu and openSUSE) it looks to me like with Ubuntu your driver was “nvidia” which is the proprietary nVidia graphic driver. With openSUSE your driver was “vesa” which is the low performance but highly compatible VESA graphic driver.

I confess I did not read the entire thread, but clearly the proprietary nVidia driver (that you installed on Ubuntu) should provide significantly superior performance over the lower peformance VESA driver. If you wish to compare apples to apples you need to install the high performance proprietary nVidia driver on openSUSE.

Since you are new :slight_smile: … some links that might help you:

Our forum installation stickie (yes it is written for 11.1 but most of it also applies to 11.2): NEW Users - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums

OpenSUSE concepts: Concepts - openSUSE

… also, a word about 11.2 milestone-8. This is in essence equivalent to a beta release. It is NOT intended for a production system and installing it as such is bound to lead to grief in most cases. If you want to try out openSUSE, then either install 11.1 or wait a couple of months and try out 11.2.

11.2 milestone8 is intended for users to test and write bug reports - it is not intended to remain on a PC. When 11.2 GM (the released version) comes out in November my recommendations will be to re-install 11.2.

Thanks. I did that. Now I have an xorg.conf file.

# /.../                                                  
# SaX generated X11 config file                          
# Created on: 2009-10-13T10:08:55-0400.                  
#                                                        
# Version: 8.1                                           
# Contact: Marcus Schaefer <sax@suse.de>, 2005           
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#                                                                             
# Automatically generated by [ISaX] (8.1)                                     
# PLEASE DO NOT EDIT THIS FILE!                                               
#                                                                             

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"        
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"          
  FontPath     "/usr/share/fonts/URW"            
  FontPath     "/usr/share/fonts/Speedo"         
  FontPath     "/usr/share/fonts/PEX"            
  FontPath     "/usr/share/fonts/cyrillic"       
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"          
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled" 
  FontPath     "/usr/share/fonts/baekmuk:unscaled"      
  FontPath     "/usr/share/fonts/japanese:unscaled"     
  FontPath     "/usr/share/fonts/kwintv"                
  FontPath     "/usr/share/fonts/truetype"              
  FontPath     "/usr/share/fonts/uni:unscaled"          
  FontPath     "/usr/share/fonts/CID"                   
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"     
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"    
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"   
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"  
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled" 
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"          
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"     
  FontPath     "/usr/share/fonts/xtest"                 
  FontPath     "/opt/kde3/share/fonts"                  
  InputDevices "/dev/gpmdata"                           
  InputDevices "/dev/input/mice"                        
EndSection                                              

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"        
EndSection                              

Section "Module"
  Load         "dri"
  Load         "dbe"
  Load         "extmod"
  Load         "glx"   
EndSection             

Section "InputDevice"
  # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section.                                     
  Driver       "kbd"                                                     
  Identifier   "Keyboard[0]"                                             
  Option       "Protocol" "Standard"                                     
  Option       "XkbLayout" "us"                                          
  Option       "XkbModel" "microsoftpro"                                 
  Option       "XkbRules" "xfree86"                                      
EndSection                                                               


Section "InputDevice"
  # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section.                                       
  Driver       "mouse"                                                     
  Identifier   "Mouse[1]"                                                  
  Option       "Buttons" "5"                                               
  Option       "Device" "/dev/input/mice"                                  
  Option       "Name" "SynPS/2 Synaptics TouchPad"                         
  Option       "Protocol" "explorerps/2"                                   
  Option       "Vendor" "Sysp"                                             
  Option       "ZAxisMapping" "4 5"                                        
EndSection                                                                 


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  331 207                      
  HorizSync    30-94                        
  Identifier   "Monitor[0]"                 
  ModelName    "LENOVO LCD MONITOR"         
  Option       "DPMS"                       
  Option       "PreferredMode" "1920x1200"  
  VendorName   "LEN"                        
  VertRefresh  43-60                        
  UseModes     "Modes[0]"                   
EndSection                                  


Section "Modes"
  Identifier   "Modes[0]"
EndSection               


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15     
    Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                    
  EndSubSection                                                                 
  SubSection "Display"                                                          
    Depth      16                                                               
    Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                    
  EndSubSection                                                                 
  SubSection "Display"                                                          
    Depth      24                                                               
    Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                    
  EndSubSection                                                                 
  SubSection "Display"                                                          
    Depth      8                                                                
    Modes      "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                    
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "Quadro FX 570M"
  Driver       "nv"
  Identifier   "Device[0]"
  VendorName   "NVidia"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "Composite" "off"
EndSection

I still do not have “Graphics and Monitors” in Yast Hardware.

EDIT. I also get this message in Desktop Effectss now (it was not there before):

Compositing is not supported on your system.
Required X extensions (XComposite and XDamage) are not available.

For the record, by running that command “sax2 -r”, your video driver has been changed from using the “VESA” graphic driver to using the “nv” graphic driver, where “nv” graphic driver is the open source free graphic driver for nvidia graphics hardware (not to be confused with “nvidia” which is the proprietary nvidia graphic driver). The “nv” driver is reasonably compatible with various kernel builds, and has much higher performance than the VESA driver but significantly less performance than the “nvidia” driver, which may in part explain why “Compositing is not supported on your system”.

Thank you. In Ubuntu I always ran the proprietary nvidia drivers. How would I do the same in OpenSUSE?

I still do not have a “Graphics and Monitors” entry in Yast Hardware.

Well, some reading may help … Per this post:

If you read that above thread, and if you noted the link to nVidia in post#6 NEW Users - Suse-11.1 Pre-installation – PLEASE READ POST#6 - openSUSE Forums you will find this link which takes you here: NVIDIA - openSUSE

In that link there are various methods described how to update one’s graphic driver to the proprietary nVidia driver. I prefer the “hardway” in that URL, which in fact is NOT hard. But each to their own.

This has been removed in 11.2 from YaST . …

In 11.1 and earlier, the entry was present in YaST. 11.2 is using some sort of automatic configuration method, that does not rely on the xorg.conf file. Hence since there is an automatic configuration method, the YaST developers decided to remove that section from YaST.

HOWEVER, if one decides to create an xorg.conf file, that file will over ride the automatic configuration method.

IMHO this may boil down to WHY are you installing 11.2 milestone8. Are you doing this to test and raise bug reports? Or are you planning to use this as a day to day system. If the later, then I think you may be making a mistake.

Agreed. If you do need the newer kernel, here’s about installing the NVIDIA driver. You need to install ‘the hard way’ anyway, since there’s no repo for 11.2 yet and the card’s too new.

Start the software installer and select the ‘Linux Kernel Development’ pattern for install, install. This will get all needed packages for installing the NVIDIA driver.
Next open a terminal window and follow instructions below:

mkdir NVIDIA
cd NVIDIA
++ a folder NVIDIA is created in /home/YOURUSERNAME and entered

++ now on a 32bit system do:
wget ftp://download.nvidia.com/XFree86/Linux-x86/190.36/NVIDIA-Linux-x86-190.36-pkg1.run
++ on a 64bit system do:
wget ftp://download.nvidia.com/XFree86/Linux-x86_64/190.36/NVIDIA-Linux-x86_64-190.36-pkg2.run
++ this downloads the driver from the NVIDIA site, into current folder

++ now on 32bit do:
su -c ‘sh NVIDIA-Linux-x86-190.36-pkg1.run -q’
++ on 64bit do:
su -c ‘sh NVIDIA-Linux-x86_64-190.36-pkg2.run -q’
++ Enter rootpassword when asked for. The installer will start, Accept the license, hit OK when asked for, until finished.

++ After install, you have to configure the driver, since you changed it for VESA:
su -c ‘sax2 -r -m0=nvidia’
++ Enter rootpassword. MIND: after the -m is a zero. Click Change Configuration, check values for videocard and monitor resolition. Save and exit.
++ Driver is now installed and configured. On next kernel update there’s no need for the sax2 command, since Xorg is already configured to use the nvidia driver.
++ Now we need to change to runlevel 5 to get your gui back:

su -c ‘init 5 && exit’
++ Enter rootpassword and you should be presented with the kdm login screen.

Because I am new here, I would really, really like to understand this and do things the right way. In an earlier post when I pointed out that evdev was used for mouse and input settings instead of xorg.conf now, no one replied and I was left with the impression that xorg.conf was still used in OpenSUSE. Maybe that is wrong.

Was it unnecessary to run sax2 -r? (see earlier post)
Can I remove the xorg.conf file? Creating it doesn’t seem to have helped in any way - e.g., I still don’t have the Desktop Effects.

I’m just doing it for learning and experimentation. If it goes well, I’ll keep it. In the past, I almost always went with a new version of Ubuntu by the time it reached beta. How does “milestone 8” compare with a beta release?

FYI, this is what started it all:
Anyone else switching to KDE thanks to Nokia? - maemo.org - Talk
I just wanted to switch to KDE and I planned to use Kubuntu. But so far OpenSUSE is way better on my Thinkpad T61p. The OpenSUSE installer is amazing. I did some advanced partitioning that I would not have been able to do in the normal Ubuntu installer (I always had to use the alternate installer CD).

openSUSE-11.1 is stable and most of us have a reasonable handle on it. For 11.1 one needs an xorg.conf file. But that is changing for 11.2 and the exact details of the 11.2 implementation are not known by most. I know I do not know.

However I read (and was also told on an IRC channel ) that if one puts an xorg.conf file in place, it will over ride the autoconfig in 11.2.

Necessary? No. BUT the “nv” driver you have in place now should have superior performance over the “vesa” driver. BUT neither have the needed performance for desktop effects. For that you need the proprietary “nvidia” driver and you were given advice as to that.

I have to run to supper now ! Can’t read the rest of your post. Sorry.

I suspect I was not using the vesa driver before xorg.conf was created. Would give 1920 x 1200 resolution at 24 bits? That’s what I had before.

Have a nice dinner. Thanks for your help.

Yes, I think it would support 1920x1200 @ 24 bits. But it would be slow.

Still, its possible you were not using the vesa driver … re-reading your posts I see you were refering to the cat /etc/X11/xorg.conf.install file which references the very low resolution fbdv driver (I can not believe you were using that) or the “vesa” driver. And there could be (in fact there are many) other aspects to this graphic driver under 11.2 milestone8 that I do not understand.

As noted, 11.2 milestone8 is for testing right now. Is that you intention?

It is NOT for nominal desktop use.

Well, there was a call for testers… I’m actually learning/experimenting more than testing, but I’m OK with using a pre-release version and reporting my problems.

I already reported, for example, that the KMenu NetworkManager does not open the application.

FYIl, my display was not slow. It was running just as well as it does now.

I think I will delete the xorg.conf file…