br0 suddenly appeared after a reinstall of 15.3

So I wound up reinstalling 15.3 a couple of times to try out using a pair of spinning disks on my laptop instead of the SSD’s. That didn’t work (very slow) so I reverted back to a pair of SSD’s, but now I notice that br0 appeared. I’m guessing some driver has been “updated” to include some functionality that it didn’t have before. I tried clicking around in the Network Manager applet, but can’t find any reference to br0 (the connections appear blank and "wired connection 1 reports “never used”). Is there a way to remove br0 from the system? I tried Wicked and deleted the configuration for br0, but it came back when I reinvoked Network Manager.

Here, “br0” was setup when I installed “virt-manager”. If you are doing any sort of virtualization, then “br0” is probably setup to allow a bridge network to your virtual machines.

Thanks NR! I always install VirtualBox and never saw br0 before… (VBox seems to run normally.)
Hmmm… Maybe I clicked on install some pattern during the initial installation that I don’t normally install.
I checked YaST patterns and didn’t see any server patterns installed.
I did install YaST “server utilities” pattern, also Minimal Appliance Base. (under Base Tech.)

Could I search YaST for “br0?” (probably something else…)

Maybe VBox was recently changed to invoke a system IP bridge in a way that it didn’t used to?

(More or less thinking out loud…)

I watch these things in gkrellm - sort of rely on it - that’s where I spotted the bridge.

I guess it’s not a big deal - I can just ignore it more or less, right?

I suspect that is right.

The Kernel’s Bridge capability is documented here – <;.

It seems to have been introduced around 2001 – you’ll need to install the “bridge-utils” package to really inspect what’s going on – despite a command “bridge” being available by default from the “iproute2” package …