Botched UEFI dual boot with W10, only installs/boots in Legacy

Hello, I bought a new desktop, and I decided to put a familiar OpenSUSE 42.3 KDE on it, and I am having the strangest experience. I will write in sequence.
0. I have sda=W10 SSD sdb=4TB data HDD sdc=linux drive.

  1. I installed OpenSUSE 42.3 in legacy mode. It worked very well, but I decided to re-install using UEFI mode.
  2. I installed OpenSUSE 42.3 in UEFI mode, it won’t boot!The sdc is set up in gpt system, it is seen by W10 OS, the installation medium is not corrupt!
  3. I disable secure boot, still no go.
  4. I remove sda and still no go.
    Sdc was installed with its own /boot/efi partition, and I know that is not the issue because I have my Lenovo T480 working with one SSD with W10 efi and the other SSD with OpenSUSE efi partition.

I am dealing with an ASUS motherboard which stubbornly won’t let me set up the efi path by myself. I did some search and couldn’t find too much resources. I will be attempting similar method to:http://www.jens-mueller.org/erfahrungsberichte/dualboot_opensuse422_win10.html#situationand
guided by this: https://docs.microsoft.com/en-us/windows-hardware/manufacture/desktop/bcd-system-store-settings-for-uefi
I have to admit, I don’t like the idea of keeping the W10 drive attached while doing this very comfortable because I don’t want to corrupt its data. Has anyone had experience in this?

Thank you for your time.

-SJL

You can not simply decide to install in UEFI mode. The PC is either in UEFI mode or not. And thus Windows is installed in UEFI or not and thus the openSUSE installer has to boot in UEFI mode or not and openSUSE will then be installed in UEFI mode or not. All of them the same.

It could be that the system can switch from non-UEFI to eUEFI (somewher in the “BIOS”) but then you have to re-install all.

Hello hcvv,
What I meant is that I set the BIOS to UEFI boot mode and re-install that way after I accidentally installed in Legacy mode. With my motherboard, I can choose to boot from installation medium (optical drive) from Legacy or UEFI mode.

Check the output from:

parted /dev/sdc print

(run that as root).

You can post the output here.

Look to see if the “pmbr_boot” flag is set. And if it is set, then clear it. You can get hints about that with google.

Some computers are fussy about that flag, and won’t boot in UEFI mode if the flag is set.

nrickert,
Indeed,

Disk Flags: pmbr_boot

is present. I will try to clear it then report back

nrickert,

you sir have just fixed my problem. Thank you!

-SJL

Glad to have helped. And thanks for reporting back.