Bose bluetooth earbuds stopped working

My Bose QC earbuds are connected in the bluetooth applet, but are not recognized in the volume applet. When this has happened in the past, I’ve been able to solve the problem by disconnecting them in the bluetooth applet and reconnecting. On rare occasions, I’ve had to delete them from the bluetooth applet and reinstall them. I’ve done both but neither solution is working. This started happening on October 1. I’ve update to the latest version of Tumbleweed, rebooted but no joy. My earbuds announce, “connected to tumbleweed.” The KDE bluetooth applet shows that they are connected, but the audio applet only shows the built in speakers on my laptop. Any suggestions would be appreciated.

I have tested several Bluetooth audio devices. All earbuds or headphones can be paired cleanly, but the audio device is not offered. Neither playback devices nor recording devices.

Restarting the bluetooth service solves the problem.

sudo service bluetooth restart

Unfortunately, I have to do this every time I reboot. Not sure what changed, but everything worked fine until a week or so ago.

Hi,

I’m having a similar experience!

After update to kernel 6, Bluetooth connection to speakers lost on this hardware. No device is detected

Bluetooth connection on another laptop ok with the same kernel installed

CMD
sudo service bluetooth restart
has no effect.

this os :-
17-105ng 2022-10-13 10:53:36
System: Kernel: 6.0.0-1-default arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.25.5 Distro: openSUSE Tumbleweed 20221008
Machine: Type: Laptop System: HP product: HP Notebook v: N/A serial: <superuser required>
Mobo: HP model: 8130 v: 25.13 serial: <superuser required> UEFI: American Megatrends v: F.14 date: 12/08/2015
CPU: Info: quad core model: AMD A6-6310 APU with AMD Radeon R4 Graphics bits: 64 type: MCP cache: L2: 2 MiB
Speed (MHz): avg: 999 min/max: 1000/1800 cores: 1: 998 2: 1000 3: 1000 4: 1000
Audio: Device-1: Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio driver: snd_hda_intel
Device-2: Advanced Micro Devices [AMD] FCH Azalia driver: snd_hda_intel
Sound Server-1: ALSA v: k6.0.0-1-default running: yes
Sound Server-2: PipeWire v: 0.3.58 running: yes
Network: Device-1: Broadcom BCM43142 802.11b/g/n driver: wl
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
IF: eno1 state: down mac: <filter>
Bluetooth: Device-1: Broadcom BCM43142A0 Bluetooth Device type: USB driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
17-105ng 2022-10-13 10:54:57

regards

Solved with the “zypper up” from today.

hi,

after todays update still no detection of Bluetooth devices

on boot the following messages are given

firmware patches not found,
brcm/BCM3142A0-0a5c-216c.hcd
brcm/BCM-0a5c-216c.hcd
Opcode 0x1003 failed: -110

any suggestion welcome

cheers

See drivers - BCM43142A0 Broadcom Bluetooth doesn't work with Ubuntu 18.04 - Ask Ubuntu, it seems you can “install” those files in /lib/firmware/brcm and searching for the files I found them at github.

I am not sure if they are also part of some Tumbleweed package.

I have the same issue. Started mid-October. Headphones connect, no source or sink gets registered in pulse audio. Play/pause buttons work. journal -xe says nothing on the matter. Dell XPS 15 9560 with:


**dell:~ #** hwinfo --bluetooth 
02: USB 00.1: 11500 Bluetooth Device                             
  [Created at usb.122] 
  Unique ID: xnLL.+cQZiM0o24C 
  Parent ID: k4bc.2DFUsyrieMD 
  SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.1 
  SysFS BusID: 1-4:1.1 
  Hardware Class: bluetooth 
  Model: "Qualcomm Atheros Bluetooth Device" 
  Hotplug: USB 
  Vendor: usb 0x0cf3 "Qualcomm Atheros Communications" 
  Device: usb 0xe301  
  Revision: "0.01" 
  Driver: "btusb" 
  Driver Modules: "btusb" 
  Speed: 12 Mbps 
  Module Alias: "usb:v0CF3pE301d0001dcE0dsc01dp01icE0isc01ip01in01" 
  Driver Info #0: 
    Driver Status: btusb is active 
    Driver Activation Cmd: "modprobe btusb" 
  Config Status: cfg=no, avail=yes, need=no, active=unknown 
  Attached to: #6 (Hub)


This works for me too.

systemctl restart bluetooth

also (still) tumbleweed 20221027 needs also this command to have jbl bluetooth speakers to work

I solved the bluetooth audio problem with follow:
Using Pipewire instead of pulseaudio :wink:

zypper in gstreamer-plugin-pipewire pipewire-alsa pipewire-aptx pipewire-libjack-0_3 pipewire-pulseaudio libfdk-aac2 libopenaptx0

and reboot

1 Like