borked grub

I always have several OSes on my disk, so I was surprised when 12.1 suggested that I delete all of them during install. After installing the first time, 12.1 failed to enter the other OSes into the grub menu. I re-installed a mint/ubuntu OS over 12.1 and was then able to boot other OSes. During the second install of 12.1, I selected no grub installation. Rather than just not writing grub, it erased the contents of my MBR, again claiming hegemony over the disk. So, after several hours and 4 installations I have abandoned openSuse 12.1 as just not ready for prime time by not playing well with others. I’ll check here periodically to see if and when this is fixed. It’s a shame: I enjoyed Suse back in the 90’s.

On 12/26/2011 06:46 PM, sillysally wrote:
>
> I enjoyed Suse back in the 90’s.

did misspell it back then also…i’ve said it many times: openSUSE is
not for everyone…bye.


DD
openSUSE®, the “German Engineered Automobiles” of operating systems!

Well, that’s not entirely true … but that’s not entirely false. Overwriting the MBR with a generic boot code is a shame indeed. I keep saying it for years … but they won’t listen. Most people are happy because Windows is happy with that. What do you want to say? That the majority is right? Well … I know why I never vote at least.

Ok, we won’t change openSUSE boot policy… but we might still change ourselves and become more clever. In this particular case, while playing with several OSes since the 90’, it would have meant:

  • Never accept any suggestion from any setup in the world, never even put yourself in a situation to receive such suggestions! Select “Create Partition setup” under openSUSE or “Create Custom Layout” under Fedora or “Something Else” under Ubuntu, Mint, etc (No kidding, that’s how it’s called). After 20 years of multibooting, you must be an expert, so choose “expert mode” and do what you want!
  • Further uncheck this stupid and destructive option (for other Linux bootloaders). That does the trick.
  • Finally use updategrub to add other distros to your boot menu… and Bob is your oncle!

On 2011-12-26 18:46, sillysally wrote:

> I’ll check here
> periodically to see if and when this is fixed.

Never, unless you do an official report.

> It’s a shame: I enjoyed
> Suse back in the 90’s.

If you have been using SuSE in the 90’s, you should know how to play around
boot idiosyncrasies. It always tells you what it is going to do. You should
not accept defaults without reading them carefully, no matter who tells you
to. It is your fault for not using expert settings, and choose yourself the
appropriate settings.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 12/27/2011 03:08 AM, Carlos E. R. wrote:
> If you have been using SuSE in the 90’s, you should know how to play around
> boot idiosyncrasies. It always tells you what it is going to do. You should
> not accept defaults without reading them carefully, no matter who tells you
> to. It is your fault for not using expert settings, and choose yourself the
> appropriate settings.

all VERY correct! therefore i assume this FUD spreader probably used the
worlds most loved desktop in the 90’s and so hates to see the market
slide, plants fear uncertainty and doubt wherever there might be fertile
ground.

http://en.wikipedia.org/wiki/Fear,_uncertainty_and_doubt


DD
openSUSE®, the “German Engineered Automobiles” of operating systems!