Borderless Konsole windows no longer obey window placement rules

Hi. I’m a huge fan of borderless/menuless terminals (just a blank box with a prompt). I have been doing this with konsole for several years (since Leap 42.2 at least) by using a general setting to “Remove window titlebar and frame” and/or a window rule that applies “No titlebar and frame” initially. I turn off “Show Menubar” and in the profile I have the Scrollbar position as “Hidden”.

After the upgrade to Leap-15.3, the placement of these windows seems to no longer work properly. In the past, if I started konsole on a blank desktop, it would go to the upper left corner. Starting a second one would place the new one just to the right of the first. Starting a third would put it to the right of the second; etc. After the upgrade, the first is placed in some seemingly random part of the screen, and subsequent instances are piled right on top of the first.

A very weird thing is that if I start one, move it to the upper left, turn on the menubar with Ctrl-Shift-M, then start a second, it is placed to the right of the first as expected (without a menubar), the third is placed to the right of the second, and so forth, as originally expected.

I see this on two machines: one is on bare metal with two monitors, the other a VirtualBox guest with a single screen. I also see it with a new user account in addition to my regular user account I assume there was a KDE change between 15.2 and 15.3, but I’m not sure why this behavior would have changed. Any ideas before I file an official bug report?