Bootup Problem with video

After installing Make - gcc and kernel-source I was restarting my PC and upon logging in I hit the space bar to have it load and I got an error “Out of Range” for the video. When I get to the boot loader screen it shows on the boot options line “vga=0x31a” now. Is there a way to reset it so I can get in as I even tried Failsafe and was unsuccessful. I was just about to install the latest nVidia drivers when this happened. Any help would be appreciated.

Ok I re-created the problem by doing a reinstall over the top. I got back in the system and performed all the updates. I rebooted and it came up fine. I think just installed Make / gcc / kernel-source and when I rebooted that is where something is going wrong. It starts to load and then I get the “Out of Range” window and it just dies right there. Any suggestions?

Very weird. This shouldn’t be related to kernel source updates.

Anyway, you can change/remove this line at boot time, editing the boot options line at the boot screen, or later using the bootloader module in Yast or even editing (as root) the /boot/grub/menu.lst file.

If you google for VGA Boot modes you’ll find lot of pages like this:


Color depth      | 640x480 | 800x600 | 1024x768 | 1280x1024
-----------------+---------+---------+----------+----------
256 (8bit)       |   769       771       773        775
32000 (15bit)    |   784       787       790        793
65000 (16bit)    |   785       788       791        794
16.7 Mill.(24bit)|   786       789       792        795

Those codes are decimal. In your case, 0x31A (hex) corresponds to 795 (dec), or 1280 x 1024 at 24 bits. Does your monitor supports that?

Last instance would be to try vga=normal, which, if I’m not mistaken, uses the vga framebuffer. I think it is the default if the option vga= is left unspecified.

Cut your losses, get a GUI going and install the nvidia drivers. I still use vga=0x31a with those drivers. But I’ve had the “out of range” thing a few times over the years. I have to adjust the scan rate (downwards I think) in Yast – > hardware → video card.

So boot and when the highlight is on Suse11 in the boot menu, type the number 3 and it will appear on the bottom bar. Press enter and you’ll get a boot to a console. Log in. Then here’s how to get a GUI going, and oldie but a goodie:
SuSELinuxSupport: HowToGetTheGuiBack

That one recommends “failsafe” boot, but I’ve given you an alternative boot because “failsafe” doesn’t work for you in this case.

Its a funny thing - the boot options says the vga=0x31a but when the screen is loading you can tell its not doing 1280x1024 and yes Windows did that just fine. I have a Westinghouse 19" LCD Monitor and an nVidia 7600GT card. When I check the hardware in Yast the video resolution keeps going down to 800x600 and no matter what I try to set it to it wont take anything else. I got around the out of range thing with installing Make - gcc - kernel-source however when I try to install the latest nVidia drivers it cant find the path to the kernel-source. The funny thing though when I try to boot up in the Failsafe mode my screen scrolls the text in the correct resolution. When booting in normal mode the text is large and its in 800x600. Im closer but not there yet - any suggestions from here?

Have you or are you do this nvidia install manually?

Try this method (you may need to delete and repo nvidia packages)

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.
Go to Yast>Software>Software Management
Search for and install if you don’t have these:
make
gcc
kernel-source
Now download the latest Nvidia driver:
Place the file in your /home/username
Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login
Type “root” then enter and then your root password and press enter.
now type
cd /home/username
*Now remember you can use the {TAB} key to auto complete
so type:
sh NVIDIA{TAB}
and the whole file name should auto complete
eg: sh NVIDIA-Linux-x86-173.14.09-pkg1.run
Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around
reboot

Yes I have tried that and right now I have gotten to a point where its telling me that it cant find the kernel-source and if I could specify it in the command line. I know I installed it so not sure why it cant find it. Im finding a lot of things Im use to using dont work on Linux, ie. music.yahoo.com and others. Would love to get this video working correctly.

Open a terminal and do

rpm -qi kernel-source

Make sure the installed kernel-source version matches your kernel version

Is the monitor type/model set correctly? Low resolutions usually mean high frequencies in analog monitors. LCD’s have only one frequency, usually 60 Hz. Maybe your system is mistakingly detecting a different monitor.

Also, it could also be a limitation of the video driver, but that would mean you’d be using a very basic framebuffer driver or such, not the nvidia nor even the nv driver.

Thats part of my problem, its not recognizing my monitor at all. Does not even have my type listed. Its a Westinghouse LCM-19 and I know it can handle 1280x1024 because that is what I have it set to in Windows.

You should set the monitor in Yast to generic —>LCD
your desired size and nearest but not exceeded refresh rate

Houston we have liftoff. Thank you all for your help.

WOW.
Thanks for letting us know.:wink: