Bootsplash has disappeared

I’ve been running 11.4 for a few weeks with the nvidia driver from the repos. I read somewhere that ‘nomodeset’ should be added to the kernel line in menu.lst, so I added this manually. However, on rebotting my bootsplash had disappeared. I’ve since read that I actually didn’t need this setting with the repo version of the driver so I removed it, but still no bootsplash. Any idea how to get it back?

The grub entry is currently:

title Desktop – openSUSE 11.4 -
root (hd0,4)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST3750630AS_9QK20F5D-part5 resume=/dev/disk/by-id/ata-ST3750630AS_9QK20F5D-part6 splash=silent quiet
showopts vga=0x31a
initrd /boot/initrd-

I lost it too
But it’s really not important to me. I actually prefer ‘verbose’.
Not sure if there is a solution. Sorry.

In Yast, go to /etc/sysconfig Editor. Make sure System, Boot, SPLASH is set to yes. System, Boot, THEME chooses what you want for bootsplash. I’m not sure, but then might have to in a terminal window (as root) do something like - mkinitrd -s 1024x768, you might want to do a man mkinitrd first.

Why are you running with ‘nomodeset’ with proprietary drivers?

Cheers Ill give that a try

Im not any more

First of all, what lead you to use ‘nomodeset’? I mean, if you used it, you had to had a purpose…

To achieve something, please share…

And what happens if you remove ‘nomodeset’ ?

You don’t have ‘nomodeset’. Did you updated, reinstalled the driver recently or tried to un-install it ? :slight_smile:

OK I was and still am getting occasional screen freezes that require a hard reboot (can’t even get a virtual terminal) so I thought the nomodeset option might help. It made no difference so I removed it. I’ve set the bootsplash and theme in /etc/sysconfig but it makes no difference. It’s not a huge issue for me though. I use Debian as my main system and that doesn’t have a splash by default. I’d just heard that this version of suse was very good so wanted to give it a spin. On the whole I’m impressed, although I’m comparing it to v10 as that was teh last time I tried it.