Boots ok in FailSafe, not in normal...error log somewhere??

I just installed OpenSUSE 11.4 on a completely blank machine, empty disks, etc. using a Network Install.

The install appeared to run OK, but when it rebooted to do the configuration, it hung.

I tried a manual reboot a couple of times, then booted in FailSafe mode - came up OK and ran through the auto-config.

Now, it still boots up ok in FailSafe, but in normal mode I get the wallpaper on the screen, but it hangs there.

Is there some sort of an error log I can get to see what the problem might be?




You can check those logs with these commands :

tail -f /var/log/messages


tail -f /var/log/boot.log

Other questions for you : what is your system ? Graph card ?

First off try to boot in runlevel 3 rather than failsafe. To do so, select the entry you would boot normally and append 3 to the Options line before booting. It will boot a normal multiuser networked system but without graphical login. From there run the command:

hwinfo --gfxcard | grep -i -e model -e driver

write down the output and post it here.

  • If you get garbage on the screen, also add “nomedeset” in the Options line before booting.

Hi DaaX,

it is a small Compaq 32 bit system. I was running openSUSE 11.2 on it last year.
It just uses the onboard graphics card.

The only difference from running 11.2 last year is that I added another HD, 200GB.

Maybe I didn’t get the jumpers right for promary/secondary drives - is that still relevant?

I’ll check that, and the logs, when I get out of work today.



SATA drives do not have master/slaver jumpers. IDE of course do.

OK, it boots up fine in normal mode, with the ‘3’ on the command line.

So, from looking inside the case, it seems that there is another graphics card there I was not expecting…
Here is the hwinfo information;

Model: “Intel i845”
Driver: “i915”
Driver Modules: “drm”
Model: “nVidea GeForce 6200 (0x0221)”
Driver: “nouveau”
Driver Modules: “drm”




Can you deactivate the integrated card on your motherboard through the BIOS settings ? I you can do so, do it.

Better stick with the nvidia card IMO.

I went to the BIOS and the PCI, nvidia, was selected.

So, I tried changing it to the OnBoard, didn’t work, and then changed it back and it appeared to work - one time anyway.

Now it is just as broken as ever, so I think I will leave it until tomorrow when I should have more time.

Thanks for all of the suggestions and help.



You need to boot with nomodeset (in the Options line where you typed 3 before) if you’re using the GeForce with the nouveau driver.

Or - if you have a network connection in runlevel 3 - you can install the nvidia driver from the nvidia repo and it should solve the problem.

zypper ar nvidia
zypper refresh
zypper in x11-video-nvidiaG02


thanks for the reply.

First I booted with nomodeset to get a system I could use.

Then I installed the nvidia driver using zypper as you suggested.

So, now it is all working great, cannot thank you enough and for the exact commands to get it working too.

Many Thanks,


You’re welcome. :slight_smile: