Boots in to grub command line after new install

Hello, I am new to Linux and don’t know why my installation is not working.

After I ran into an Nvidia driver problem where my system wouldn’t boot anymore, I decided to make a fresh install. I burned the Leap 42.1 ISO image onto a dvd and it worked fine the first time.

Now when I use the installer and keep everything to default options, it restarts and brings me to the grub command line where I can’t do much. I tried running the install DVD once again and select boot from hard disk. This gives me an error and says no bootable partition found. I also tried the recovery option but it asks me for a password that I don’t know.

I ran into this problem before with a live OS on a USB stick but reinstalling always fixed it. This time it gives me the same error after running the installer several times. I am running an ASUS R505C laptop with a 250gb Sandisk SSD. I left the partitioning to the recommended settings which are sda1 formatted as FAT for boot, sda2 as swap, sda3 in formatted as BtrFS for root(correct me if I am wrong it was mounted at /) and sda4 in XFS mounted at /home.

Thank you in advance for your help.

OK first is this a Optimus notebook?? ie Intel + NVIDIA GPU?? If so you must use bumblebee NOT the normal NVIDIA driver.

Run the media check on the menu of the installer. DVD/CD disks can and do go bad.
When burning always use the lowest sped you can

Note also that when install you need to boot the Install media in the right mode this would for modern hardware normally be EFI mode NOT legacy. Trying to boot in legacy when you installed in EFI won’t work