Bootproblem 11.4 on dualboot nvdia G7600 based system, fresh install "system console stolen at line"

I tried to update one of my home machines with a fresh install. This is far from new to me so I did not expect any problem. But I was proven wrong.
First: did install the system as usual. First anomaly: system blocked during the install process but did restart it flawlessly one I tried to eject the DVD from the player. It needed actually that intervention to retake working. It then went to install and froze during the first system start. I rebooted with failsafe settings, it then correctly configured. I reached a beautiful desktop. I performed the updates from the update repository and I joined the nvidia proprietary driver repository (which updated to the G02 driver).
I then rebooted the machine and now I am in trouble.
In normal mode the system (dual boot Opensuse, XP) does not boot at all and freezes immediately after hitting enter as before.
In safe mode it goes further but does not reach X anymore. It blocks with the following line statement: “system console stolen at line 266”.
I then tried “startx”. But the system goes into a scrolling loop that does not allow me to read the output.
Any suggestions on how to get at least the error message of the loop? I read some line passing by that the system might have an X11 authorization problem.
Thank you.

Athlon Phenom X4 905e
Nividea G7600 graphic card
Former system installed and running flawlessly: 11.1

If you are in trouble since you installed G02, why not trying to set nouveau as driver in /etc/X11/xorg.conf and see what it does. It might work as long as you don’t use openGL programs. See if you need to boot with nomodeset or not. Also for the nvidia driver, try to remove vga=xxx from the kernel boot options … although I never had problems with G02 but who knows… (had issues with G01 and Legacy nvidia). To run startx as user without session manager you need to make /usr/bin/Xorg SUID again (it is not since 11.4).
I would check the media and reinstall, I guess, and maybe not install G02 right away.

This reads like a bad install to me.

If I were you I would boot to a liveCD and backup all my data to an external hard drive (if not done so already).

I would also confirm that the installation DVD was good (do the md5sum check on downloaded iso file and compare it to md5sum posted on web site), and reburn installation DVD to a +R or -R high quality DVD (not to an RW and not to some bargain basement special) and burn at the slowest speed my burner allows.

Did you run the media check on the DVD ? (although that in itself is not always enough to confirm an installation DVD is good).

The media disk is not self produced but a commercial one (DVD double sided 32bit - 64 bit).
I will try to remove the G02 driver and up to now I did not try to remove the vga option. This could do. I have read about a bug in 11.4 that apparently causes this:
[Bug 642289] System does not boot correctly with sysvinit-tools-2.88-15.](
I will try also:


Hi folks. So this is a practical work around.
**Bug: **
on the system Opensuse KDE4 64bit with all updates the system will not boot with instant freeze. Fail safe will take you to runlevel 5 with the command prompt with the following error:

system console stolen at line 266

When you try to log into KDE via


you will get a fast running loop which output you will not be able to read.

Put in (into normal boot option) the following boot parameter:


This does the trick. You may experience waiting time during boot (to a total of about 60 seconds for a total boot. But the system itself seems to run fine.
The problem seems to be the aforementioned bug.

I searched and found a couple of bugs where that “system console stolen at line 266” was mentioned in the bug report, but the bug reports are so massive to read its hard to say if they are relevant:

In my brief skim I could not find a cause/effect as to what hardware/software configuration combination is more likely encounter this.

Without such characterisation, it is very difficult to provide specific advise to users on this as to whether this is what they have encountered. Perhaps the error message " system console stolen at line 266" is the only indication that one has.

Actually this is getting even more bothersome. I have again the problem on that machine, without having done whatsoever alteration. I will try to downgrade sysv to the precedent version to see whether this helps.
Up to now quite “mystical”.

So you are now saying the " RUN_PARALLEL=“no” " that you had thought was a solution, is not a solution? Out of curiosity, when you boot the PC and the grub menu appears, does removing the entry (in grub options line) “vga=0xYYY” make any difference ?

Do you have the nominal 4 repositories (OSS, Non-OSS, Update and Packman) or have you installed applications from other repositories ?

Hello and seasonal greetings. The solution run_parallel=no was working flawlessly. The removal of the vga did not show any change. The repository are the usual (noss, oss and packman plus the nvidia repository). Between the “normal boot” and the “hang boot” there was astonishingly no change in Linux. It worked…then suddenly it worked not. In failsafe it starts (with icons of course super oversized).
The problem must be the graphics I guess. I will try today to do the following in sequence:
Try the removal of the vga entry.
Try nomodeset jointly to run_parallel=no.
And finally try to downgrade sysv.
I will report on the results, cheers.

After having started the machine this morning no problem without any changes. Observations:
The “hang moment” of the boot is when /var/log/messages is created and before the AppArmor security fs is created. Between these two menu points is a ca 30 second long “meditation period”.
This is as you know a dual boot system. If you boot Windows XP with the Nvidia drivers of it, and then you try to restart directly, OpenSUSE will hang. If you switch off long enough to discharge the ICs then apparently the machine (still with our “meditation moment”) does boot.
The problem (for what I can see) appears to be similar to the one when some Windows driver do put the hardware in a state out of which it has trouble to reboot into windows. I am not a engineer but I can confirm you that there is this pattern.
SysV is apparently part of it, but as I do not have the time to fix (have to leave tomorrow morning) I will leave my father with the following advice to work around:
switch off and detach from current for about 1 minute if this presents and then try to restart. If not solvable boot one time in failsafe (that apparently does also some good).
I think this is quite annoying however (besides this and the tedious installation process) I find 11.4 with KDE pretty awesome!!!
The problems wouldn’t be a blocker for a medium-advanced user but can be troublesome for a beginner (I would claim would be blocker for a beginner, but then, how was it, walls are there to proof how badly you want things, right?)

Is this PC an HP ?

I’ve seen similar bizzare behaviour on other HP PCs. On my mother’s PC, if she were to reboot from MS-Windows to openSUSE Linux (without cycling off the power for a minute) her Network card would not work in openSUSE.

My solution there was to remove the MS-Windows boot from grub, and she can only boot to Linux now. Which is fine as she can run MS-Windows in Virtual Box (under openSUSE) and for the use she has on a PC, the performance in Virtual Box is adequate.

No, I do always build my system from the scratch, piece by peace. So it is much more powerful and cheaper. But it may be an issue of the graphics card as this one is the oldest piece. I did change the motherboard to run a Phenom X4 but did not change the graphics so the thing works through a dvi/hdci plug adapter to the monitor - as the monitor is dvi (which is not present on the card, only the precursor, which leads also to a sound transmission problem as the new dvi plugs are germane also for sound transmission to internal monitor speakers). This could be a problem I think, as maybe the monitor will not give the right feedback on his settings to the card? I have in program to substitute the card with a new one (as soon as the new Nivdia cards will consume less current then a Toyota Prius in full acceleration or as soon as ATI has decent OSS drivers… that may well be some time LOL), I will update if some future update changes the situation.
In the light of recent “changes” of M$: maybe it is the same with explorer, before it was installable in wine, now the routine has been rewritten to make it impossible. I would think about: first they laugh at you, then they fight you, then you win. We are, for what I see recently, definitely in phase 2.

That’s right. But you can always specify the resolution in Display SubSection, or enforce a resolution with the Option “PreferredMode” in the Monitor section, add the correct HorizSync and VertRefresh or even use the appropriate modeline if nothing else helps.

Further, on broken monitors, preventing the nvidia driver from reading the EDID might be necessary (see man nvidia-xconfig) . You can also explicitely set the DPI in xorg.conf (usually 96 or 100) and use the following option it that doesn’t work:

Option   "UseEdidDpi" "false"

Basically nothing that just xorg.conf editing.

yes, all this is probably right. If you have the time (huge opportunity cost) and the experience. So, the lack of sax proofs again crucial for user friendlessness. I really look forward that sax3 comes back.