Bootloader doesn't seem to be installed alright

Since I had a little time on my hand over christmas break, I decided to do my sister a favor and install linux on her computer (consentually, mind you). But so far, I’ve caused nothing but trouble, since I can’t get Suse to boot.

I’ve reinstalled over and over and over, but everytime I install and reboot, the computer complains that there is no operating system installed.

After a while of reinstalling, I tried to install a boot loader from the live cd instead, but when I open yast to do this, it compains that ‘because of the partitions, the bootloader can’t be installed properly’.

I’ve tried pretty much about everything, but nothing seems to work. Any suggestions?

Boot a live cd, open a terminal
type su and hit enter

now type:

fdisk -l

Post result

Additionally, is there/was there any other OS(s) installed?

Thanks so much for the response. In the end it was my own lack of attention that caused the problem. The memory card slot had a memory card in it, that showed up as a disk (naturally), and since it was placed before the hard drive, the boot loader was written to the memory card.

I solved the problem by taking out the memory card and doing a victory dance.

Dancing can be good.