Bootloader doesn't load

I installed OpenSUSE 11.1 yesterday using the net install cd.

It all worked great. I was able to boot into OpenSUSE, restart and then boot into Windows XP and restart and boot into OpenSUSE etc.

Yesterday I hit restart and GRUB didn’t start. The BIOS screens came and went and I was left staring at a black screen. I rebooted several times with the same result ever time.

On startup, I can choose my boot media by hiting F12. From there I choose my hard drive so it isn’t as if my computer is trying to boot from a cd or usb that is not there.

I got my computer working again by booting into my OpenSUSE cd and from there I picked “boot from hard disk” and there I was given the option of which partition to boot to. I picked the right one (Yay!) and OpenSUSE started up. However, this isn’t fun and I don’t feel like restarting my computer ever again.

To sum it up, GRUB worked right after OpenSUSE installation but stopped working the same day.

Boot up from your openSUSE cd, and go to
YaST -> System -> Boot Loader. Here from the Other menu (right bottom), select the Propose New Configuration option, and hit OK. Reboot.
Hope that helps.

Thanks I tried that and it is still not working. I spent some extra time in the Repair System menu and it looks as if my partitions are “corrupted”. Odd that.

So I’ll try to repair them and if it fails then I will do a complete install. And this time I’m giving XP more room. XP needs more than 5 GB. At least 5.5 GB this time.