Bootloader config - openSUSE 11.1


I just changed from Mandriva to openSuse. Yesterday I installed openSUSE 11.1 on my Dell XPS m1330. After I installed the nvidia driver, there was a new kernel ( in my bootloader. That new kernel is not selected as standard and it is the only one that works. The old standard kernel is Due to the new kernel is not selected as standard, I wanted to change the boot sequence in Yast/System/Bootloader. At my next reboot I got the message “ERROR No Operating System” (or something like that).

I tried the repair tool from the openSUSE 11.1 DVD but it didn’t work. Finally I installed openSUSE 11.1 a second time and now I have exactly the same problem again. How can I change the boot sequence after a new kernel is published?

It would be great if anyone could help me.


You can edit the /etc/boot/menu.lst file and change the default= argument to which ever kernel you wish to boot. (Note: Numbering begins at 0, not 1)

However - you really should not be getting a “no operating system found” message if the kernel does not boot. Are you getting a grub message like “file not foud” or some grub error code? It might be that the root (hd0,0) argument for the new kernel is somehow not the same as what it is for the original kernel?

If the trouble continues, please post your menu.lst file and let’s see what the deal is.


Also puzzling is that you not getting the conventional update for the kernel. By default when you update the kernel the old one is replaced and only the new one is available from the menu

Thank you guys!!

That’s what I did. Worked!
However, the path was /boot/grub/menu.lst

No idea why SuSE did it