Booting xp (new to linux)

I tried a new thing which was installing opensuse. I installed it on my 2nd hd in one of the partitions. However my question is how do i boot back into windows xp. When my computer boots it goes to the green screen and i have the option of open suse, failsafe, windows 1 and windows2. I have vista on a diff partion so thats why im guessing theres a windows 2.
Im trying to get back to windows xp so i press windows 1 but the only thing that comes up after that is

How do i fix this so i can load back into xp i got programs i need to run for school. (i might have to ask for detailed way because this is the first time i am using linux)

Thanks ahead of time

I never experienced problems with rebooting to windows after a linux installation, so I don’t know if I can help you…
But maybe this info could help us to find your problem:
Could you post the content of /etc/grub.conf?
And maybe also an overview of all your partitions (including info on which one you installed windows, etc)
Did you change anything to boot loader options?

Sorry I made a mistake:
/etc/grub.conf should be /boot/grub/menu.lst …

I wanted to edit my previous post, but there is no edit button… Why can’t I edit my own post?

You must have lost the MBR on the first disk. To repair it, you must boot up with your Windows XP CD and go into “rescue mode” or something like that, and then issue the fixmbr command. These are essentially the steps required, try googling for the exact step-by-step procedure and syntax. And be careful not to “fix” the MBR of the second drive…

Is this the situation:
You had xp on drive 1. Later you added vista to drive 1. Later you added Suse to drive 2.
Is that it? If not, tell us how it came about.

Assuming that’s how it was, edit the file /boot/grub/menu.lst and locate this set of lines:

###Don’t change this comment - YaST2 identifier … blah blah…
title windows something or other
rootnoverify (hd1,5)
chainloader (hd0,0)+1

Change this: rootnoverify (hd1,5)
To this: rootnoverify (hd0,0)

To edit the file (it has special permissions) you issue this command in a console and it will open in a text editor:
if you use KDE it’s this:

kdesu kwrite /boot/grub/menu.lst

or if you use Gnome it’s this:

gnomesu gedit /boot/grub/menu.lst

This is exactly how i got my oses on.
i will try this. thanks

okay i can boot of the 1st hd now but i cant get into windows still it just loads the opensuse installation, i know i didnt touch my xp tho. but after i burned opensuse onto a dvd i opened it up and now when i look on my hd now there is an opensuse file i canont delete.

I dunno if that makes any sense to you guys if not ill try to rephrase it.

I couldnt find the edit button but what im basicly asking is how to i edit/move/copy/delete files that are on my c drive if opensuse is on a different drive. cuz ill just remove the linux boot files from my c drive so i can load xp

I can advise you two ways depending what you want:
Do you mean that there are Linux files on your c drive in the first partition where windows xp was installed (that’s your “c drive”, technically known as partition 1) and that you think by removing those files that windows will boot?
Do you mean that Grub boot code has been installed in the Master Boot Record at the beginning of the first drive (not on partition 1 but sooner, in the very first record) and that you want to overwrite that Grub code with the original windows boot code?

I was in xp when i opened up the opensuse cd so i beleive it installed some files on the c parttition where i have xp. However i didnt do the install on the c drive, i did it on a completely different drive in a different partition. And yes i was planning on deleting those files on xp and hope i could boot into it. Or if i cannont do that there is one folder i need that i havent back up yet so if i could back that up ill just reinstall xp.

but when i look in the windows folder i see all my regular files i had saved on xp and i also see an opensuse folder that i think if i delete i could boot into windows.

unless there is something else i am missing?

i aprreciate you spending time to help

I think you’re missing something. But you may be right. Run these commands in a console and we’ll see the NTFS partitions and if they are mounted and if so where:

df -TH |  grep fuseblk


sudo /sbin/fdisk -l | grep NTFS

Paste the resulta back here.

/dev/sda1 fuseblk 161G 144G 17G 90% /windows/C
/dev/sdb2 fuseblk 146G 20G 126G 14% /windows/D
/dev/sda1 * 1 19456 156280288+ 7 HPFS/NTFS
/dev/sdb2 12749 30401 141797722+ 7 HPFS/NTFS

Now we’re getting somewhere: The files for the xp partition are available via your file manager/browser (Konqueror Nautilus or Dolphin depending what you’re running) at these locations: xp = /windows/C and vista = /windows/D. They may be writeable mounts (meaning you can delete, add or edit files). See if you can delete the offending file from /windows/C. If not then it’s not yet writable and post the response to this command and I’ll tell you how to make them writable:

cat /etc/fstab | egrep "sda1|sdb2"

i tried that code but it didnt work for me for some reason but what i did do to fix my problem is install vista on my last open partition, then i deleted the opensuse files in windows and boom my xp works. I just uninstalled vista on my last parttition so everything is like it was before… I appreciate the help :slight_smile:

Just goes to show there are many ways to the same place.