Booting Windows 10

Hello Everyone,

I wanted to try out an operating system other than Windows, and decided to go with openSUSE. I partitioned off the hard drive appropriately and successfully installed LEAP 42.1, which will boot correctly. However, Windows 10 is not even an option on the boot menu, and the Windows OS it does show (Windows 7, installed on my computer before updating to Windows 10) will not boot either. I recently backed up my data onto an external hard drive, so I’m not too concerned about losing data, but I did fail to create a Boot/repair disc for windows before (stupid, I know, but hindsight is 20/20).

I am not overly familiar with programming or computer jargon, so what forums or FAQs I can find on the subject are pretty far over my head. If possible, I would greatly appreciate a simple how-to or step-by-step instructions. If this has been covered in a previous post, I apologize. I’m sure there is plenty of info I am leaving out, but I can provide that if needed/requested.

Original OS: Windows 10
Installed: Leap 42.1
Problem: can no longer boot Windows, option does not appear on GRUB (?)
No Windows boot/repair disc

Hi
Open a console and switch to root user and run the command os-prober;


su -
os-prober

Does it see your windows install? If so, fire up Yast -> system -> bootloader, then on the ‘Bootloader Options’ tab, ensure the box is checked to ‘Probe Foreign OS’ and hit the ok button.

After performing the command, the return is:

/dev/sda1:Windows Recovery Environment (loader):Windows:chain
/dev/sda2:Windows 7 (loader):Windows1:chain
/dev/sda3:Windows Recovery Environment (loader):Windows2:chain

As far as I can tell none of these are my Windows 10 install. Am I doing something incorrectly?

Please update Leap and try once more. There were some fixes for os-prober after initial release. If it still does not work you should open bug report so it can be debugged and fixed.

Success! Thank you so much for the help!

I’m having this same problem. I ran os-prober with the following result:

linux-rswd:~ # os-prober
grub2-probe: error: unknown filesystem.

Opening a file manager, I can clearly see the partition with it’s contents intact at /dev/sda2. How do get W10 in the Grub so I can select it to boot?

May I recommend the “System” -> “YaST” graphical System Management GUI available from all the Desktop environments (root user password needed).

  • Select “Boot Loader” in the “System” section.
  • Go to the third tab: “Bootloader Options”.
  • Top right, there’s a Check-Box: “Probe Foreign OS” – select it.
  • Press “OK” (bottom right corner).
  • Done!

In Windows you MUST have set fast boot off. Fast boot leaves the MS file system in a unknown state and thus non mountable.

.Also Dynamic disk the MS equivalent to LVM containers is unmountable

Funny, isn’t it . . . On my Dual-Boot Windows 8.1 (Windows 10 “upgrade” disabled) / Leap 42.1 (previously 13.2) Lenovo G505S AMD A10-5750M APU with Radeon HD Graphics Laptop, the "Windows “Fast-Boot” is enabled. (I’ve checked just now with “Windows-Key”-X and “Power Options”.)
[HR][/HR]If I boot Windows (8.1), the return to my default of openSUSE Leap 42.1 means that I have to shut the thing down (power-off) [simply rebooting returns to Windows (8.1)]; then, I have to press the Lenovo “Novo” button and enter the BIOS/UEFI, check that openSUSE has the highest boot priority (it always does); then, “Save and reboot” the BIOS/UEFI (once again). Grub2 then reappears.
[HR][/HR]Even though Windows (8.1) has been “fast-shut-downed”, I can still access the main Windows (8.1) NTFS partition and pick up whatever JPEG Photos I have processed by the Sigma Photo Pro RAW converter. Ditto for any OpenOffice under Windows (8.1) testing.

  • I never write to the Windows (8.1) NTFS partition from openSUSE – the thing mounts read-only anyway – I do not use any special NTFS Linux drivers to allow writing to NTFS partitions.

Windows leaves the disk much like hibernate, which is more or less what it does. But that leaves things up in the air and other OS’s don’t want to touch it. This can cause problems of detecting the Windows when you scan for other OS. It leave the journal uncommitted so files may not correctly reflect the last changes made.