Booting to gnome instead of KDE 3

Using 11.1 64-bit
NVIDIA 8500 GT
KDE 3.5

I’ve got a fresh install 11.1 and I chose 3.5 as my desktop. My problem is that on reboot, Suse loads gnome. I log out (Even tried a reboot) and select KDE which is already selected, and login again. and I get gnome. I tried choosing another desktop - the ice-something, and reselected KDE, logged in and got the ice thing. Chose KDE again and got gnome 3-4 more times until finally it booted into KDE.

Can someone offer some advice please??

Thanks
Michael

Look into the hidden file .dmrc located at /home/yourname/.dmrc
Mine says

[Desktop]
Session=kde4

Yours might need to be for kde3 which would be like this IIRC:

[Desktop]
Session=kde

I found the same thing.
If you aren’t going to use gnome, you can uninstall it. If you still want gnome, try disabling autologin - it’s hidden in the group properties of the user management of yast.
You can then choose the type of session you want.
Last way is to have a terminal login. You then login at the terminal and then type kdestart to star kde.

My .dmrc file pointed to kde3, changing it to kde didn’t help, back to kde3, still same. Funny thing is… This doesn’t happen sometimes. Only most of the time.

Also, I do not have autologin enabled, never have…

Thanks for replies…

Michael