Booting problem

I have openSUSE 11.1 dual booting with CentOS (using suse grub menu/bootloader) and now it won’t boot. It doesn’t see CentOS and wont boot either one. I don’t mind losing the CentOS installation because it is fairly new and I’ve tried using the ‘Repair Installed System’ option on the DVD but after it says grub is fixed, it checks again and says there are errors…(tried multiple times)then exits the repair cd with an error.

additional partitioning info:
I took the default layout for suse when i installed it using the 1st half of the disk so I think it was booting from sda1

I don’t mind loosing centos because it was a fairly new installation if putting another suse on that drive will help,that’s okay with me I just want to save my suse.

Any help would be greatly appreciated.

Okay, I removed all partitions except the suse install(sda1)and the swap. The auto repair gives me the same errors…any ideas?

Is this a really unusual problem? Should I give up on it?

On Tue, 29 Sep 2009 03:06:02 +0000, dk82 wrote:

> Is this a really unusual problem? Should I give up on it?

No, you should perhaps give enough time for people around the world to
have woken up. Forums aren’t necessarily “real-time support”. :slight_smile:

(That said, I have no ideas either on this)


Jim Henderson
openSUSE Forums Moderator

Are you certain that your media is good and that the install completed? Sounds like you wiped the mbr and didn’t install a bootloader there in the process. Did you select to install the bootloader to a partition instead of a hard drive?

I suggest installing again and checking the media beforehand. Bad burn, bad iso, bad media, or bad drive have all happened to others. Use the checksum that comes with the iso file then check afterwards.

I double checked the iso’s checksum and checked the dvd for errors…it said it no errors found.

The installation I had was working for months then one day I booted up and got the grub cli. So I don’t know what’s going on with that but now when I try to repair the installation, every time it goes through it says I have some missing packages (it reinstalls them) and tells me my bootloader has errors (it fixes them, says grub successfully installs then checks again and errors out, fixes again & says it’s okay to reboot) when I say ok to reboot it gives me an error…then get the grub cli

Anyway, I guess there is no way to save it.
I finished installing another opensuse on the 2nd half of the drive and I’m copying my files over from the old to the new installation.

Thank you for your help, I really do appreciate you taking the time to read my post and respond.

Take Care,


At this point my best guess is that the filesystem has gotten corrupted. I’ve had odd errors that turned out to be from power outages corrupting files on the hard drive.