Booting OpenSuSE 12.3 on Sony Vaio Duo 11

Hello,

I just installed OpenSuSE 12.3 on a Sony Vaio Duo 11 ultrabook from a USB stick with OpenSuSE 12.3 x64 ISO image installed with imagewriter.

The installation went ok but in the end it does not boot correctly.

I have previously set the BIOS to secure mode and left it in UEFI (as not in legacy).

If I leave booting from the disk, Windows attempts to repair the installation and fails. So Windows is not even able to start.

If I use the Assist button to boot from the USB, it goes to the installation mode again.

It seems people that tried Ubuntu 12.10 were able to make it dual boot, apparently using a boot recovery tool.

I could always switch to using Ubuntu but I would rather stick to OpenSuSE that I use for more that 12 years so I am confortable with it.

Anybody has any idea of what I need to do to make this work?

Not sure but I think you need to set EFI to non secure for the install but maybe able to turn it back on after you fully update. Think there is a bug on the install media.

Which Windows. AFAIK Win 8 is the only one that supports secure boot

Can you post the output of:


df -k
gdisk -l /dev/sda
efibootmgr -v

Use “code” tags for the output. If possible, do that from the booted system. If you cannot boot the system, then the output of the second and third commands from a rescue boot would still be useful.

I have tried to install Ubuntu 13.04 but I needed to use the boot repair disk tools to fix the boot too. It works now, although I am not able to boot on Windows anymore.

I tried to install OpenSuSE on the same partitions again but it did not succeed. So I returned to Ubuntu again.

In the Ubuntu installation I ran those commands and it gave the following results:

df -k

Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/sda8       19872236 3468340  15387784  19% /
none                   4       0         4   0% /sys/fs/cgroup
udev             2985456       4   2985452   1% /dev
tmpfs             598996     888    598108   1% /run
none                5120       0      5120   0% /run/lock
none             2994972     152   2994820   1% /run/shm
none              102400      20    102380   1% /run/user
/dev/sda9       44028388   61696  41723520   1% /home
/dev/sda3         258048   48329    209720  19% /boot/efi

fdisk -l /dev/sda

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.




Disk /dev/sda: 128.0 GB, 128035676160 bytes
255 heads, 63 sectors/track, 15566 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb733e47c

efibootmgr -v


   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1   250069679   125034839+  ee  GPT
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,0001,2001
Boot0000* Windows Boot Manager    HD(3,363800,82000,b25481c2-a13f-473f-af99-23e59d4ae38b)File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Ubuntu    HD(3,363800,82000,b25481c2-a13f-473f-af99-23e59d4ae38b)File(\EFI\ubuntu\grubx64.efi)RC
Boot0002* Ubuntu    HD(3,363800,82000,b25481c2-a13f-473f-af99-23e59d4ae38b)File(\EFI\ubuntu\grubx64.efi)RC



It is not what you were asked to run and does not provide needed information.

Windows attempts to repair the installation and fails.

Please show output of gdisk as requested.

Sorry, since there was no program called gdisk in the rescue installations of OpenSuSE or Ubuntu, I thought you meant fdisk.

I managed to run gdisk using parted magic installation:

GPT fdisk (gdisk) version 0.8.6

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present


Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 250069680 sectors, 119.2 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 6BD3231A-762E-4142-8D63-42D1FD16CF9B
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 250069646
Partitions will be aligned on 2048-sector boundaries
Total free space is 3463 sectors (1.7 MiB)


Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          534527   260.0 MiB   ED00  EFI system partition
   2          534528         3553279   1.4 GiB     2700  Basic data partition
   3         3553280         4085759   260.0 MiB   EF00  EFI system partition
   4         4085760         4347903   128.0 MiB   0C01  Microsoft reserved part
   5         4347904        88239333   40.0 GiB    0700  Basic data partition
   6       222810112       250068991   13.0 GiB    2700  Basic data partition
   7        88240128        92438527   2.0 GiB     0700  primary
   8        92438528       133083135   19.4 GiB    0700  primary
   9       133083136       222810111   42.8 GiB    0700  primary