Booting issue, and errocodes? help greatly appreciated!

I am currently building a home theater PC, and decided to try the latest 11.0 release. I am using an AMD 64bit dual core AM2 2.4GHz processor, and SATA hard drives. I can’t remember the exact mother board model, but it is a relatively new ASUS model. The install disk has been verified as valid, both by MD5SUM, and self check before installation. After some issues trying to set up a software based RAID0, the install seemed to go off without a hitch.

The issue came in when I rebooted the computer. It is not able to boot from the HDD directly. I have been a Linux user for many (9) years, and an openSUSE user for well over a year now. It has been many years since I have had a system that required a boot disk, I would really prefer not to have to return to those days if at all possible. Additionally, before I had all of my components (mostly just the tuner card) I had installed 10.3 without any problems at all, so I don’t think that it’s an issue with the hardware not working properly. The odd thing is, if I boot from the install disk, and then tell it to continue booting from the HDD, it has no problems at all. I have already tried repairing the boot loader, both through the install disk and yast. I have tried rewriting the MBR, and tried both LILO and GRUB. I have never had this much trouble installing Linux, and am at a loss of what to try now. As I said, if anyone has some advice, or an idea to try to get it booting directly from the HDD, it will be greatly appreciated.

If anyone is still with me, I also had a question about the RAID I mentioned above (well, sort of anyway). When trying to format the disks in RAID0, there was an error that caused the formatting to fail (error -3008). As it turns out, I think one of my disks is bad so that may be what it was trying to tell me. My real question is:

Where can I find information on error codes from the installation? I have searched the openSUSE site for such information, but with no luck.

Thanks in advance,

I can’t say re the SuSE error code, but fwiw re your boot problem . . .

Grub does not recognize /dev/md<n> in the root command, only in the kernel line command. So in menu.lst, the root line should be hd<n,n> where hd<n> is one of the drives in your RAID0 array, wherever /boot is located. But on the kernel line, the syntax used is “root=/dev/md<n>” or the UUID of the array.

Thanks for the reply mingus725. Sadly, due to the bad drive, I don’t actually have RAID set up yet, so I’m not sure that your info will help just yet, though it is good to know. I have been doing a little more looking just on booting in general, and will be checking to make sure that my boot loader is installed on my first drive, although i’m pretty sure it already is. The drive set up when it is all done will be one 80GB drive as / and then two others set up in RAID0 for fast read/write for video purposes, so I’ll always be booting from /dev/sda. Again, any more ideas will help greatly.

Well then, my comment above will not apply because the partition you are booting from is not in an array. I gather also that you will have /home on that first partition, with the video data being on the array which is mounted at some point under /. I would only add that since you are striping, I’m sure you realize that if you lose either partition, it is almost certain that you will have lost the entire array. I use RAID0, and I mirror the array onto another non-RAID drive.